aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-15 08:12:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-15 08:12:56 +0000
commitc5110864ff9f95a7c7366d8cc42394482667141b (patch)
tree5ce6d288715bf0db5ead6af302e8764afd12c384 /cad
parent03c25851243d6f9ece73eb2a5e2dc0204f8dfc4f (diff)
downloadports-c5110864ff9f95a7c7366d8cc42394482667141b.tar.gz
ports-c5110864ff9f95a7c7366d8cc42394482667141b.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/admesh/Makefile31
-rw-r--r--cad/admesh/distinfo5
-rw-r--r--cad/admesh/files/patch-admesh.c11
3 files changed, 20 insertions, 27 deletions
diff --git a/cad/admesh/Makefile b/cad/admesh/Makefile
index a2d269a86bc7..1b1fed3d7504 100644
--- a/cad/admesh/Makefile
+++ b/cad/admesh/Makefile
@@ -2,31 +2,34 @@
# $FreeBSD$
PORTNAME= admesh
-PORTVERSION= 0.95
-PORTREVISION= 1
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.98.3
CATEGORIES= cad
-MASTER_SITES= http://launchpadlibrarian.net/67068999/ \
- http://www.sourcefiles.org/Scientific/Numerical_Analysis/
MAINTAINER= ports@FreeBSD.org
COMMENT= Program for processing STL triangulated solid meshes
LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= DOCS
-
+USES= autoreconf libtool
+USE_GITHUB= yes
GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DOCS
-PORTDOCS= admesh.doc
-PLIST_FILES= bin/admesh
+PORTDOCS= *
-post-patch:
- @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+PLIST_FILES= bin/admesh \
+ include/admesh/stl.h \
+ lib/libadmesh.so \
+ lib/libadmesh.so.1 \
+ lib/libadmesh.so.1.0.0 \
+ libdata/pkgconfig/libadmesh.pc \
+ man/man1/admesh.1.gz
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/admesh ${STAGEDIR}${PREFIX}/bin/
do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ADMESH.DOC ${STAGEDIR}${DOCSDIR}/admesh.doc
+ @${RM} ${STAGEDIR}${DOCSDIR}/COPYING
.include <bsd.port.mk>
diff --git a/cad/admesh/distinfo b/cad/admesh/distinfo
index 2f99b0d311c2..29e9e6ffd4b4 100644
--- a/cad/admesh/distinfo
+++ b/cad/admesh/distinfo
@@ -1,2 +1,3 @@
-SHA256 (admesh-0.95.tar.gz) = 90108cc412b77cc686fc264ccf5bbe73fd23d0c6cf2430216030392df955ded3
-SIZE (admesh-0.95.tar.gz) = 51340
+TIMESTAMP = 1531641582
+SHA256 (admesh-admesh-v0.98.3_GH0.tar.gz) = 6aa1bb3c68309ba72441ecb56e8b0cd6560ab9f7688de3333f8c72f8f6948ac6
+SIZE (admesh-admesh-v0.98.3_GH0.tar.gz) = 39898
diff --git a/cad/admesh/files/patch-admesh.c b/cad/admesh/files/patch-admesh.c
deleted file mode 100644
index 2dba43b3fba3..000000000000
--- a/cad/admesh/files/patch-admesh.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./admesh.c.orig 1996-07-27 00:07:15.000000000 +0200
-+++ ./admesh.c 2012-10-27 21:01:18.374482756 +0200
-@@ -27,7 +27,7 @@
-
- static void usage(int status, char *program_name);
-
--void
-+int
- main(int argc, char **argv)
- {
- stl_file stl_in;