aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-13 22:46:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-13 22:46:09 +0000
commit12d08248c8c48d28be36f6c4f6303d1f8b422b26 (patch)
tree0889f186700004fee418fb301a2f6d87b50c6894 /cad
parent506f1d5ee7cbee990050093dd175890bac2a9dd8 (diff)
downloadports-12d08248c8c48d28be36f6c4f6303d1f8b422b26.tar.gz
ports-12d08248c8c48d28be36f6c4f6303d1f8b422b26.zip
cad/verilator: Cosmetic fix - use bash as configure shell
Diffstat (limited to 'cad')
-rw-r--r--cad/verilator/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/cad/verilator/Makefile b/cad/verilator/Makefile
index 50a09029cd0e..158d36ef5033 100644
--- a/cad/verilator/Makefile
+++ b/cad/verilator/Makefile
@@ -11,7 +11,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= see https://github.com/verilator/verilator/issues/3037
-BUILD_DEPENDS= autoconf>0:devel/autoconf
+BUILD_DEPENDS= autoconf>0:devel/autoconf \
+ bash:shells/bash
LIB_DEPENDS= libsystemc.so:devel/systemc
RUN_DEPENDS= gmake:devel/gmake # verilator runs gmake for the --hierarchical option when the 'gmake' method is chosen
@@ -22,7 +23,7 @@ SHEBANG_FILES= bin/verilator_ccache_report
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL_SCRIPT}"
-#CONFIGURE_SHELL= ${LOCALBASE}/bin/bash # see https://github.com/verilator/verilator/issues/3132
+CONFIGURE_SHELL= ${LOCALBASE}/bin/bash # see https://github.com/verilator/verilator/issues/3132
TEST_TARGET= test