aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-18 09:08:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-18 09:08:12 +0000
commit214eec75155b1afda26d43a2944608e5f966df8a (patch)
tree9a8ba5cd484691569d6ed61f4cd39c467e6897ca /cad
parent00375943916a15269f4cd23babd794c995eab407 (diff)
downloadports-214eec75155b1afda26d43a2944608e5f966df8a.tar.gz
ports-214eec75155b1afda26d43a2944608e5f966df8a.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index 889f2699c5f7..0805fc6c59bc 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -7,7 +7,8 @@ CATEGORIES= cad
MAINTAINER= ports@FreeBSD.org
COMMENT= General purpose 3D CAD modeller
-LICENSE= LGPL20
+LICENSE= LGPL20+
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= pyside-rcc:devel/pyside-tools \
swig:devel/swig13 \
@@ -28,6 +29,8 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libmed.so:french/med \
libshiboken-${PYTHON_VERSION}.so:devel/shiboken
+BROKEN_FreeBSD_9= does not build on FreeBSD 9.x
+
USE_GITHUB= yes
GH_TAGNAME= 0ea7373
@@ -36,14 +39,11 @@ USE_XORG= ice sm x11 xext xt
USE_GL= gl glu
USE_QT4= qmake_build corelib gui moc_build network opengl rcc_build \
uic_build svg xml webkit
-
-BROKEN_FreeBSD_9= Does not build on FreeBSD 9.x
+CMAKE_ARGS= -DOCC_INCLUDE_DIR="${LOCALBASE}/include/OpenCASCADE" \
+ -DFREECAD_USE_EXTERNAL_PIVY=1
CMAKE_INSTALL_PREFIX= ${PREFIX}/${PORTNAME}
-CMAKE_ARGS+= "-DOCC_INCLUDE_DIR=${LOCALBASE}/include/OpenCASCADE"
-CMAKE_ARGS+= "-DFREECAD_USE_EXTERNAL_PIVY=1 -DCMAKE_BUILD_TYPE=Release ."
-
DESKTOP_ENTRIES=${PORTNAME} "" "${PREFIX}/FreeCAD/data/freecad.svg" \
${PORTNAME} "Engineering;" false