aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-01-02 16:49:24 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-01-02 16:49:24 +0000
commit51d04637cb2aa7e77e78d6b7de91125251405083 (patch)
treefefd75a0b797bfd5f2fbecc832b9a94f740ee983 /cad
parenta3cc859109302e74945b2f3684edfd3e5c434fdc (diff)
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile5
-rw-r--r--cad/openscad/Makefile3
2 files changed, 3 insertions, 5 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index e74dfdc0955f..f749702a0085 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -11,8 +11,7 @@ LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= pyside-rcc:devel/pyside-tools \
- swig3.0:devel/swig30 \
- ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3
+ swig3.0:devel/swig30
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
libboost_python.so:devel/boost-python-libs \
@@ -31,7 +30,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libhdf5.so:science/hdf5
RUN_DEPENDS= pivy>0:graphics/py-pivy@${PY_FLAVOR}
-USES= dos2unix compiler:c++11-lib cmake:outsource fortran jpeg \
+USES= dos2unix compiler:c++11-lib cmake:outsource eigen:3 fortran jpeg \
python:2.7 localbase
USE_XORG= ice sm x11 xext xt
USE_GL= gl glu
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 4c597ba6b746..0542eebfe20f 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -15,7 +15,6 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
- ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3 \
${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
@@ -24,7 +23,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libharfbuzz.so:print/harfbuzz \
libopencsg.so:graphics/opencsg
-USES= bison compiler:c++11-lang desktop-file-utils gettext-tools pkgconfig qmake shebangfix
+USES= bison compiler:c++11-lang desktop-file-utils eigen:3 gettext-tools pkgconfig qmake shebangfix
SHEBANG_FILES= libraries/MCAD/get_submodules.py
USE_GL= glu glew
USE_QT4= corelib gui opengl moc_build uic_build rcc_build