aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2002-02-09 10:03:42 +0000
committerKevin Lo <kevlo@FreeBSD.org>2002-02-09 10:03:42 +0000
commit9c47fcc98e263d809f5cbd3bb908ad700e2b78d8 (patch)
tree860110ba6119665d05e0557d76a6f3cee1745126 /cad
parent72fb55e19779cc6ee67f56365ca720e8328e7508 (diff)
downloadports-9c47fcc98e263d809f5cbd3bb908ad700e2b78d8.tar.gz
ports-9c47fcc98e263d809f5cbd3bb908ad700e2b78d8.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/ngspice_rework/Makefile22
-rw-r--r--cad/ngspice_rework/distinfo1
-rw-r--r--cad/ngspice_rework/files/patch-configure.in11
-rw-r--r--cad/ngspice_rework/files/patch-doc:Makefile.in11
-rw-r--r--cad/ngspice_rework/files/patch-doc:ngspice.texi14
-rw-r--r--cad/ngspice_rework/files/patch-src:frontend:parser:complete.c48
-rw-r--r--cad/ngspice_rework/pkg-comment1
-rw-r--r--cad/ngspice_rework/pkg-descr9
-rw-r--r--cad/ngspice_rework/pkg-plist171
10 files changed, 289 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 2be3a323d19a..41570ba4ac7f 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -18,6 +18,7 @@
SUBDIR += linux-eagle
SUBDIR += magic
SUBDIR += mars
+ SUBDIR += ngspice_rework
SUBDIR += oregano
SUBDIR += pcb
SUBDIR += pdnmesh
diff --git a/cad/ngspice_rework/Makefile b/cad/ngspice_rework/Makefile
new file mode 100644
index 000000000000..641b5ba131cf
--- /dev/null
+++ b/cad/ngspice_rework/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: ngspice_rework
+# Date created: 2002-01-02
+# Whom: AMAKAWA Shuhei <amakawa@jp.FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ngspice_rework
+PORTVERSION= 14
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ngspice
+DISTNAME= ng-spice-rework-${PORTVERSION}
+
+MAINTAINER= amakawa@jp.FreeBSD.org
+
+USE_AUTOCONF_VER?= 213
+
+pre-configure:
+ (cd ${WRKSRC} && ${AUTOHEADER})
+
+.include <bsd.port.mk>
diff --git a/cad/ngspice_rework/distinfo b/cad/ngspice_rework/distinfo
new file mode 100644
index 000000000000..0aac7a3887a4
--- /dev/null
+++ b/cad/ngspice_rework/distinfo
@@ -0,0 +1 @@
+MD5 (ng-spice-rework-14.tar.gz) = 5405d78a531fe9f30d70c35a8a469690
diff --git a/cad/ngspice_rework/files/patch-configure.in b/cad/ngspice_rework/files/patch-configure.in
new file mode 100644
index 000000000000..7bb26c5835ca
--- /dev/null
+++ b/cad/ngspice_rework/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Mon Dec 10 20:21:11 2001
++++ configure.in Wed Jan 2 13:36:55 2002
+@@ -155,7 +155,7 @@
+
+ dnl Look for termios first (posix)
+ AC_CHECK_HEADERS(termios.h termio.h sgtty.h , break)
+-AC_CHECK_FUNCS(isatty)
++AC_CHECK_FUNCS(isatty tcgetattr tcsetattr)
+
+ dnl Check for a few functions:
+ AC_FUNC_VFORK
diff --git a/cad/ngspice_rework/files/patch-doc:Makefile.in b/cad/ngspice_rework/files/patch-doc:Makefile.in
new file mode 100644
index 000000000000..77e324c095b6
--- /dev/null
+++ b/cad/ngspice_rework/files/patch-doc:Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Mon Dec 10 20:26:23 2001
++++ doc/Makefile.in Mon Jan 7 16:54:16 2002
+@@ -69,7 +69,7 @@
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ MAINT = @MAINT@
+-MAKEINFO = @MAKEINFO@
++MAKEINFO = @MAKEINFO@ --no-split
+ OBJDUMP = @OBJDUMP@
+ OBJEXT = @OBJEXT@
+ PACKAGE = @PACKAGE@
diff --git a/cad/ngspice_rework/files/patch-doc:ngspice.texi b/cad/ngspice_rework/files/patch-doc:ngspice.texi
new file mode 100644
index 000000000000..c18196c0eed8
--- /dev/null
+++ b/cad/ngspice_rework/files/patch-doc:ngspice.texi
@@ -0,0 +1,14 @@
+--- doc/ngspice.texi.orig Mon Dec 10 20:21:11 2001
++++ doc/ngspice.texi Mon Jan 7 17:15:34 2002
+@@ -5,6 +5,11 @@
+ @setchapternewpage odd
+ @c %**end of header
+
++@dircategory Utilities
++@direntry
++* NGSPICE: (ngspice). NGSPICE User Manual
++@end direntry
++
+ @ifinfo
+ This file documents NGSPICE.
+
diff --git a/cad/ngspice_rework/files/patch-src:frontend:parser:complete.c b/cad/ngspice_rework/files/patch-src:frontend:parser:complete.c
new file mode 100644
index 000000000000..dc4d335d0d6f
--- /dev/null
+++ b/cad/ngspice_rework/files/patch-src:frontend:parser:complete.c
@@ -0,0 +1,48 @@
+--- src/frontend/parser/complete.c.orig Mon Dec 10 20:21:11 2001
++++ src/frontend/parser/complete.c Wed Jan 2 13:57:11 2002
+@@ -410,11 +410,6 @@
+ # else
+ # ifdef HAVE_TERMIOS_H
+
+-# ifdef __NetBSD__
+-# define TCGETS
+-# define TCSETS
+-# endif
+-
+ # define TERM_GET TCGETS
+ # define TERM_SET TCSETS
+ static struct termios sbuf;
+@@ -423,7 +418,7 @@
+ # endif
+ # endif
+
+-# if defined(TERM_GET) || defined(__NetBSD__)
++# ifdef TERM_GET
+ static bool ison = FALSE;
+
+ if (cp_nocc || !cp_interactive || (ison == on))
+@@ -431,7 +426,7 @@
+ ison = on;
+
+ if (ison == TRUE) {
+-#ifdef __NetBSD__
++#if HAVE_TCGETATTR
+ tcgetattr(fileno(cp_in),&OS_Buf);
+ #else
+ (void) ioctl(fileno(cp_in), TERM_GET, (char *) &OS_Buf);
+@@ -440,13 +435,13 @@
+ sbuf.c_cc[VEOF] = 0;
+ sbuf.c_cc[VEOL] = ESCAPE;
+ sbuf.c_cc[VEOL2] = CNTRL_D;
+-#ifdef __NetBSD__
++#if HAVE_TCSETATTR
+ tcsetattr(fileno(cp_in),TCSANOW,&sbuf);
+ #else
+ (void) ioctl(fileno(cp_in), TERM_SET, (char *) &sbuf);
+ #endif
+ } else {
+-#ifdef __NetBSD__
++#if HAVE_TCSETATTR
+ tcsetattr(fileno(cp_in),TCSANOW,&OS_Buf);
+ #else
+ (void) ioctl(fileno(cp_in), TERM_SET, (char *) &OS_Buf);
diff --git a/cad/ngspice_rework/pkg-comment b/cad/ngspice_rework/pkg-comment
new file mode 100644
index 000000000000..4e9a4c5aeb97
--- /dev/null
+++ b/cad/ngspice_rework/pkg-comment
@@ -0,0 +1 @@
+A circuit simulator derived from spice3f5
diff --git a/cad/ngspice_rework/pkg-descr b/cad/ngspice_rework/pkg-descr
new file mode 100644
index 000000000000..39c3745f82d4
--- /dev/null
+++ b/cad/ngspice_rework/pkg-descr
@@ -0,0 +1,9 @@
+ Ngspice is the name of a project and of a program in the project.
+ Spice is the famous circuit simulator developed by the CAD Group of
+ the University of California at Berkeley (UCB). The NG prefix has a
+ lot of meanings: Next Generation, New Good, etc. Choose or invent the
+ one you prefer. The ngspice project aims to improve the capabilities
+ of the Spice3 circuit simulator. The heart of the project is the
+ ngspice program, a circuit simulator derived from spice3f5.
+
+WWW: http://ngspice.sourceforge.net/
diff --git a/cad/ngspice_rework/pkg-plist b/cad/ngspice_rework/pkg-plist
new file mode 100644
index 000000000000..5e88293ce2e9
--- /dev/null
+++ b/cad/ngspice_rework/pkg-plist
@@ -0,0 +1,171 @@
+bin/makeidx
+bin/nghelp
+bin/ngmultidec
+bin/ngnutmeg
+bin/ngproc2mod
+bin/ngsconvert
+bin/ngspice
+@unexec install-info --delete %D/info/ngspice.info %D/info/dir
+info/ngspice.info
+lib/libdev.a
+lib/ng-spice-rework/libasrc.a
+lib/ng-spice-rework/libasrc.la
+lib/ng-spice-rework/libasrc.so
+lib/ng-spice-rework/libasrc.so.0
+lib/ng-spice-rework/libbjt.a
+lib/ng-spice-rework/libbjt.la
+lib/ng-spice-rework/libbjt.so
+lib/ng-spice-rework/libbjt.so.0
+lib/ng-spice-rework/libbsim1.a
+lib/ng-spice-rework/libbsim1.la
+lib/ng-spice-rework/libbsim1.so
+lib/ng-spice-rework/libbsim1.so.0
+lib/ng-spice-rework/libbsim2.a
+lib/ng-spice-rework/libbsim2.la
+lib/ng-spice-rework/libbsim2.so
+lib/ng-spice-rework/libbsim2.so.0
+lib/ng-spice-rework/libbsim3.a
+lib/ng-spice-rework/libbsim3.la
+lib/ng-spice-rework/libbsim3.so
+lib/ng-spice-rework/libbsim3.so.0
+lib/ng-spice-rework/libbsim3soidd.a
+lib/ng-spice-rework/libbsim3soidd.la
+lib/ng-spice-rework/libbsim3soidd.so
+lib/ng-spice-rework/libbsim3soidd.so.0
+lib/ng-spice-rework/libbsim3soifd.a
+lib/ng-spice-rework/libbsim3soifd.la
+lib/ng-spice-rework/libbsim3soifd.so
+lib/ng-spice-rework/libbsim3soifd.so.0
+lib/ng-spice-rework/libbsim3soipd.a
+lib/ng-spice-rework/libbsim3soipd.la
+lib/ng-spice-rework/libbsim3soipd.so
+lib/ng-spice-rework/libbsim3soipd.so.0
+lib/ng-spice-rework/libbsim3v1.a
+lib/ng-spice-rework/libbsim3v1.la
+lib/ng-spice-rework/libbsim3v1.so
+lib/ng-spice-rework/libbsim3v1.so.0
+lib/ng-spice-rework/libbsim3v2.a
+lib/ng-spice-rework/libbsim3v2.la
+lib/ng-spice-rework/libbsim3v2.so
+lib/ng-spice-rework/libbsim3v2.so.0
+lib/ng-spice-rework/libbsim4.a
+lib/ng-spice-rework/libbsim4.la
+lib/ng-spice-rework/libbsim4.so
+lib/ng-spice-rework/libbsim4.so.0
+lib/ng-spice-rework/libcap.a
+lib/ng-spice-rework/libcap.la
+lib/ng-spice-rework/libcap.so
+lib/ng-spice-rework/libcap.so.0
+lib/ng-spice-rework/libcccs.a
+lib/ng-spice-rework/libcccs.la
+lib/ng-spice-rework/libcccs.so
+lib/ng-spice-rework/libcccs.so.0
+lib/ng-spice-rework/libccvs.a
+lib/ng-spice-rework/libccvs.la
+lib/ng-spice-rework/libccvs.so
+lib/ng-spice-rework/libccvs.so.0
+lib/ng-spice-rework/libcsw.a
+lib/ng-spice-rework/libcsw.la
+lib/ng-spice-rework/libcsw.so
+lib/ng-spice-rework/libcsw.so.0
+lib/ng-spice-rework/libdio.a
+lib/ng-spice-rework/libdio.la
+lib/ng-spice-rework/libdio.so
+lib/ng-spice-rework/libdio.so.0
+lib/ng-spice-rework/libhfet.a
+lib/ng-spice-rework/libhfet.la
+lib/ng-spice-rework/libhfet.so
+lib/ng-spice-rework/libhfet.so.0
+lib/ng-spice-rework/libhfet2.a
+lib/ng-spice-rework/libhfet2.la
+lib/ng-spice-rework/libhfet2.so
+lib/ng-spice-rework/libhfet2.so.0
+lib/ng-spice-rework/libind.a
+lib/ng-spice-rework/libind.la
+lib/ng-spice-rework/libind.so
+lib/ng-spice-rework/libind.so.0
+lib/ng-spice-rework/libisrc.a
+lib/ng-spice-rework/libisrc.la
+lib/ng-spice-rework/libisrc.so
+lib/ng-spice-rework/libisrc.so.0
+lib/ng-spice-rework/libjfet.a
+lib/ng-spice-rework/libjfet.la
+lib/ng-spice-rework/libjfet.so
+lib/ng-spice-rework/libjfet.so.0
+lib/ng-spice-rework/libjfet2.a
+lib/ng-spice-rework/libjfet2.la
+lib/ng-spice-rework/libjfet2.so
+lib/ng-spice-rework/libjfet2.so.0
+lib/ng-spice-rework/libltra.a
+lib/ng-spice-rework/libltra.la
+lib/ng-spice-rework/libltra.so
+lib/ng-spice-rework/libltra.so.0
+lib/ng-spice-rework/libmes.a
+lib/ng-spice-rework/libmes.la
+lib/ng-spice-rework/libmes.so
+lib/ng-spice-rework/libmes.so.0
+lib/ng-spice-rework/libmesa.a
+lib/ng-spice-rework/libmesa.la
+lib/ng-spice-rework/libmesa.so
+lib/ng-spice-rework/libmesa.so.0
+lib/ng-spice-rework/libmos1.a
+lib/ng-spice-rework/libmos1.la
+lib/ng-spice-rework/libmos1.so
+lib/ng-spice-rework/libmos1.so.0
+lib/ng-spice-rework/libmos2.a
+lib/ng-spice-rework/libmos2.la
+lib/ng-spice-rework/libmos2.so
+lib/ng-spice-rework/libmos2.so.0
+lib/ng-spice-rework/libmos3.a
+lib/ng-spice-rework/libmos3.la
+lib/ng-spice-rework/libmos3.so
+lib/ng-spice-rework/libmos3.so.0
+lib/ng-spice-rework/libmos6.a
+lib/ng-spice-rework/libmos6.la
+lib/ng-spice-rework/libmos6.so
+lib/ng-spice-rework/libmos6.so.0
+lib/ng-spice-rework/libmos9.a
+lib/ng-spice-rework/libmos9.la
+lib/ng-spice-rework/libmos9.so
+lib/ng-spice-rework/libmos9.so.0
+lib/ng-spice-rework/libres.a
+lib/ng-spice-rework/libres.la
+lib/ng-spice-rework/libres.so
+lib/ng-spice-rework/libres.so.0
+lib/ng-spice-rework/libsoi3.a
+lib/ng-spice-rework/libsoi3.la
+lib/ng-spice-rework/libsoi3.so
+lib/ng-spice-rework/libsoi3.so.0
+lib/ng-spice-rework/libsw.a
+lib/ng-spice-rework/libsw.la
+lib/ng-spice-rework/libsw.so
+lib/ng-spice-rework/libsw.so.0
+lib/ng-spice-rework/libtra.a
+lib/ng-spice-rework/libtra.la
+lib/ng-spice-rework/libtra.so
+lib/ng-spice-rework/libtra.so.0
+lib/ng-spice-rework/liburc.a
+lib/ng-spice-rework/liburc.la
+lib/ng-spice-rework/liburc.so
+lib/ng-spice-rework/liburc.so.0
+lib/ng-spice-rework/libvccs.a
+lib/ng-spice-rework/libvccs.la
+lib/ng-spice-rework/libvccs.so
+lib/ng-spice-rework/libvccs.so.0
+lib/ng-spice-rework/libvcvs.a
+lib/ng-spice-rework/libvcvs.la
+lib/ng-spice-rework/libvcvs.so
+lib/ng-spice-rework/libvcvs.so.0
+lib/ng-spice-rework/libvsrc.a
+lib/ng-spice-rework/libvsrc.la
+lib/ng-spice-rework/libvsrc.so
+lib/ng-spice-rework/libvsrc.so.0
+@dirrm lib/ng-spice-rework
+share/ng-spice-rework/helpdir/ngspice.idx
+share/ng-spice-rework/helpdir/ngspice.txt
+share/ng-spice-rework/scripts/setplot
+share/ng-spice-rework/scripts/spectrum
+share/ng-spice-rework/scripts/spinit
+@dirrm share/ng-spice-rework/helpdir
+@dirrm share/ng-spice-rework/scripts
+@dirrm share/ng-spice-rework