aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-08-13 15:54:07 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-08-16 17:40:30 +0000
commitf6fd64da6675285651feed9ca8fb333c69ab361a (patch)
tree91380db595c9f21fe7d52081269904014683b151 /cad
parent6d3e9fb0922e4b73327e9f87a23bbf69cbd4ec39 (diff)
downloadports-f6fd64da6675285651feed9ca8fb333c69ab361a.tar.gz
ports-f6fd64da6675285651feed9ca8fb333c69ab361a.zip
Diffstat (limited to 'cad')
-rw-r--r--cad/openvsp/Makefile39
-rw-r--r--cad/openvsp/distinfo6
-rw-r--r--cad/openvsp/files/patch-src_external_angelscript_sdk_CMakeLists.txt4
-rw-r--r--cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__callfunc__x86.cpp38
-rw-r--r--cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__config.h20
-rw-r--r--cad/openvsp/pkg-plist26
6 files changed, 70 insertions, 63 deletions
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index 1b0e8e6700b3..978768bd3c9d 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -1,7 +1,6 @@
PORTNAME= openvsp
DISTVERSIONPREFIX= ${GH_PROJECT}_
-DISTVERSION= 3.20.0
-PORTREVISION= 2
+DISTVERSION= 3.25.0
CATEGORIES= cad
MAINTAINER= fernape@FreeBSD.org
@@ -13,7 +12,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_aarch64= fails to compile: invokes x86 asm
+BROKEN_FreeBSD_11= undefined reference to __atomic_load
+BUILD_DEPENDS= ${LOCALBASE}/lib/libopenNURBS.a:graphics/opennurbs \
+ ${LOCALBASE}/include/glm/glm.hpp:math/glm \
+ ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
LIB_DEPENDS= libdrm.so:graphics/libdrm \
libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
@@ -21,18 +24,18 @@ LIB_DEPENDS= libdrm.so:graphics/libdrm \
libfontconfig.so:x11-fonts/fontconfig \
libfltk.so:x11-toolkits/fltk \
libcpptest.so:devel/cpptest
-BUILD_DEPENDS= ${LOCALBASE}/lib/libopenNURBS.a:graphics/opennurbs \
- ${LOCALBASE}/include/glm/glm.hpp:math/glm \
- ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
USES= compiler:c++11-lang cmake:noninja localbase\
gl gnome jpeg xorg
USE_GITHUB= yes
-GH_PROJECT= OpenVSP
GH_ACCOUNT= ${GH_PROJECT}
+GH_PROJECT= OpenVSP
+
+USE_GL= gl glew glu
+USE_GNOME= libxml2
+USE_XORG= ice sm x11 xau xcb xdamage xdmcp xext xfixes xft \
+ xinerama xrender xxf86vm
-CMAKE_SOURCE_PATH= ${WRKSRC}/SuperProject
-CMAKE_INSTALL_PREFIX= ${STAGEDIR}${PREFIX}
CMAKE_ARGS= -DVSP_USE_SYSTEM_CMINPACK:BOOLEAN=yes \
-DVSP_USE_SYSTEM_CPPTEST:BOOLEAN=yes \
-DVSP_USE_SYSTEM_CODEELI:BOOLEAN=no \
@@ -42,22 +45,8 @@ CMAKE_ARGS= -DVSP_USE_SYSTEM_CMINPACK:BOOLEAN=yes \
-DVSP_USE_SYSTEM_CMINPACK:boolean=no \
-DVSP_USE_SYSTEM_GLM:BOOLEAN=yes \
-DVSP_USE_SYSTEM_GLEW:BOOLEAN=yes
-USE_XORG= ice sm x11 xau xcb xdamage xdmcp xext xfixes xft \
- xinerama xrender xxf86vm
-USE_GL= gl glew glu
-
-USE_GNOME= libxml2
-
-.include <bsd.port.options.mk>
-
-.include <bsd.port.pre.mk>
-
-# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=230888
-.if ${OPSYS} == FreeBSD
-.if (${OSVERSION} < 1104507) || (${OSVERSION} >= 1200000 && ${OSVERSION} < 1202000) || (${OSVERSION} >= 1300000 && ${OSVERSION} < 1300115)
-BROKEN= undefined reference to __atomic_load
-.endif
-.endif
+CMAKE_INSTALL_PREFIX= ${STAGEDIR}${PREFIX}
+CMAKE_SOURCE_PATH= ${WRKSRC}/SuperProject
BUILD_PREFIX= OpenVSP-prefix/src/OpenVSP-build/_CPack_Packages/FreeBSD/ZIP/OpenVSP-${DISTVERSION}-FreeBSD
@@ -76,4 +65,4 @@ do-install:
${CP} ${BUILD_WRKSRC}/${BUILD_PREFIX}/LICENSE ${STAGEDIR}${DATADIR}
${RM} ${STAGEDIR}${PREFIX}/LICENSE
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/cad/openvsp/distinfo b/cad/openvsp/distinfo
index d2ced7a6ad45..d925c28ecc71 100644
--- a/cad/openvsp/distinfo
+++ b/cad/openvsp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1577742241
-SHA256 (OpenVSP-OpenVSP-OpenVSP_3.20.0_GH0.tar.gz) = a4b10cbd79d46b706a46afe04651f0ce0c5fc0931b0d489cfaedc46585694152
-SIZE (OpenVSP-OpenVSP-OpenVSP_3.20.0_GH0.tar.gz) = 112232950
+TIMESTAMP = 1628870018
+SHA256 (OpenVSP-OpenVSP-OpenVSP_3.25.0_GH0.tar.gz) = 1471032c683149c377c7e7ac9a1b9e9e8306e63c5f33d3ca98d4c2dbf6d0595a
+SIZE (OpenVSP-OpenVSP-OpenVSP_3.25.0_GH0.tar.gz) = 115423311
diff --git a/cad/openvsp/files/patch-src_external_angelscript_sdk_CMakeLists.txt b/cad/openvsp/files/patch-src_external_angelscript_sdk_CMakeLists.txt
index 60761bffebc2..5c56f96b545a 100644
--- a/cad/openvsp/files/patch-src_external_angelscript_sdk_CMakeLists.txt
+++ b/cad/openvsp/files/patch-src_external_angelscript_sdk_CMakeLists.txt
@@ -1,6 +1,6 @@
---- src/external/angelscript/sdk/CMakeLists.txt.orig 2019-10-23 07:44:07 UTC
+--- src/external/angelscript/sdk/CMakeLists.txt.orig 2021-08-10 01:31:47 UTC
+++ src/external/angelscript/sdk/CMakeLists.txt
-@@ -124,7 +124,6 @@ if(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^arm")
+@@ -125,7 +125,6 @@ if(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^arm")
enable_language(ASM)
if(CMAKE_ASM_COMPILER_WORKS)
set(ANGELSCRIPT_SOURCE ${ANGELSCRIPT_SOURCE} ./angelscript/source/as_callfunc_arm.cpp ./angelscript/source/as_callfunc_arm_gcc.S)
diff --git a/cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__callfunc__x86.cpp b/cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__callfunc__x86.cpp
index f3d8fb4a01f6..eb0ddb0e75f7 100644
--- a/cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__callfunc__x86.cpp
+++ b/cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__callfunc__x86.cpp
@@ -1,4 +1,4 @@
---- src/external/angelscript/sdk/angelscript/source/as_callfunc_x86.cpp.orig 2017-08-02 20:09:54 UTC
+--- src/external/angelscript/sdk/angelscript/source/as_callfunc_x86.cpp.orig 2021-08-10 01:31:47 UTC
+++ src/external/angelscript/sdk/angelscript/source/as_callfunc_x86.cpp
@@ -340,7 +340,7 @@ endcopy:
volatile asPWORD a[] = {asPWORD(args), asPWORD(paramSize), asPWORD(func)};
@@ -6,9 +6,9 @@
asm __volatile__(
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -385,7 +385,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
@@ -24,9 +24,9 @@
asm __volatile__ (
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -508,7 +508,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
@@ -42,9 +42,9 @@
asm __volatile__ (
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -631,7 +631,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
@@ -60,9 +60,9 @@
asm __volatile__ (
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -767,7 +767,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
@@ -78,9 +78,9 @@
asm __volatile__ (
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -896,7 +896,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
@@ -96,9 +96,9 @@
asm __volatile__ (
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -1030,7 +1030,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
@@ -114,9 +114,9 @@
asm __volatile__ (
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -1145,7 +1145,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
@@ -132,9 +132,9 @@
asm __volatile__ (
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -1285,7 +1285,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
@@ -150,9 +150,9 @@
asm __volatile__ (
-#ifdef __OPTIMIZE__
+#if defined(__OPTIMIZE__) && !defined(__clang__)
- // When compiled with optimizations the stack unwind doesn't work properly,
+ // When compiled with optimizations the stack unwind doesn't work properly,
// causing exceptions to crash the application. By adding this prologue
- // and the epilogue below, the stack unwind works as it should.
+ // and the epilogue below, the stack unwind works as it should.
@@ -1445,7 +1445,7 @@ endcopy:
// Pop the alignment bytes
"popl %%esp \n"
diff --git a/cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__config.h b/cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__config.h
index 7fe6427caad7..54a2d000dcd1 100644
--- a/cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__config.h
+++ b/cad/openvsp/files/patch-src_external_angelscript_sdk_angelscript_source_as__config.h
@@ -1,11 +1,11 @@
---- src/external/angelscript/sdk/angelscript/source/as_config.h.orig 2019-11-25 15:18:37 UTC
+--- src/external/angelscript/sdk/angelscript/source/as_config.h.orig 2021-08-10 01:31:47 UTC
+++ src/external/angelscript/sdk/angelscript/source/as_config.h
-@@ -953,7 +953,7 @@
- #define COMPLEX_RETURN_MASK (asOBJ_APP_CLASS_DESTRUCTOR | asOBJ_APP_CLASS_COPY_CONSTRUCTOR | asOBJ_APP_ARRAY)
- #define THISCALL_PASS_OBJECT_POINTER_ON_THE_STACK
- #define AS_X86
-- #elif defined(__LP64__)
-+ #elif defined(__amd64__)
- #define AS_X64_GCC
- #define HAS_128_BIT_PRIMITIVES
- #define SPLIT_OBJS_BY_MEMBER_TYPES
+@@ -1008,7 +1008,7 @@
+ // Free BSD
+ #elif defined(__FreeBSD__) || defined(__DragonFly__) || defined(__OpenBSD__)
+ #define AS_BSD
+- #if (defined(i386) || defined(__i386) || defined(__i386__)) && !defined(__LP64__)
++ #if (defined(i386) || defined(__i386) || defined(__i386__)) && !defined(__amd64__)
+ #undef COMPLEX_MASK
+ #define COMPLEX_MASK (asOBJ_APP_CLASS_DESTRUCTOR | asOBJ_APP_CLASS_COPY_CONSTRUCTOR | asOBJ_APP_ARRAY)
+ #undef COMPLEX_RETURN_MASK
diff --git a/cad/openvsp/pkg-plist b/cad/openvsp/pkg-plist
index 02554eb0c93b..4ad27287876a 100644
--- a/cad/openvsp/pkg-plist
+++ b/cad/openvsp/pkg-plist
@@ -39,10 +39,12 @@ bin/vspviewer
%%DATADIR%%/Stack.vspscript
%%DATADIR%%/StructuresParmContainerTest.vspscript
%%DATADIR%%/SubSurface.vspscript
+%%DATADIR%%/SurfaceIntersection.vspscript
%%DATADIR%%/TestAll.vspscript
%%DATADIR%%/TestAnalysis.vspscript
%%DATADIR%%/TestAnalysisVSPAERO.vspscript
%%DATADIR%%/TestAreaProj.vspscript
+%%DATADIR%%/TestAxisProj.vspscript
%%DATADIR%%/TestDXF.vspscript
%%DATADIR%%/TestFacet.vspscript
%%DATADIR%%/TestMassProperties.vspscript
@@ -53,6 +55,8 @@ bin/vspviewer
%%DATADIR%%/TransportFuse.vsppart
%%DATADIR%%/VKTAirfoil.vspscript
%%DATADIR%%/VKT_e0.1_k0.1_t10.dat
+%%DATADIR%%/VSPAERO_ActuatorDisk_CSGroup.vspscript
+%%DATADIR%%/VSPAERO_UnsteadyProp.vspscript
%%DATADIR%%/VSPBoxXSec.PNG
%%DATADIR%%/VSPCircXSec.PNG
%%DATADIR%%/VSPIXSec.PNG
@@ -71,6 +75,7 @@ bin/vspviewer
%%DATADIR%%/plotDegenPlate.m
%%DATADIR%%/plotDegenStick.m
%%DATADIR%%/plotDegenSurf.m
+%%DATADIR%%/readvspgeom.m
%%DATADIR%%/redbluearrow.tga
%%DATADIR%%/sc2_0404.af
%%DATADIR%%/testanimate.vspscript
@@ -78,13 +83,26 @@ bin/vspviewer
%%DATADIR%%/window.tga
vspaero_ex/Isolated_Rotor/README.md
vspaero_ex/Isolated_Rotor/Steady_Rotating_Frame/README.md
+vspaero_ex/Isolated_Rotor/Steady_Rotating_Frame/prop_DegenGeom.csv
vspaero_ex/Isolated_Rotor/Steady_Rotating_Frame/prop_DegenGeom.vspaero
-vspaero_ex/Isolated_Rotor/Unsteady_Rotating_Blades/README.md
-vspaero_ex/Isolated_Rotor/Unsteady_Rotating_Blades/prop_DegenGeom.groups
-vspaero_ex/Isolated_Rotor/Unsteady_Rotating_Blades/prop_DegenGeom.vspaero
vspaero_ex/Isolated_Rotor/prop.vsp3
-vspaero_ex/Isolated_Rotor/prop_DegenGeom.csv
vspaero_ex/README.md
+vspaero_ex/Swept_Wing_API/Images/GUI_Airfoil.png
+vspaero_ex/Swept_Wing_API/Images/GUI_DegenGeom.png
+vspaero_ex/Swept_Wing_API/Images/GUI_DesignVariables.png
+vspaero_ex/Swept_Wing_API/Images/GUI_Gen.png
+vspaero_ex/Swept_Wing_API/Images/GUI_GeomBrowser.png
+vspaero_ex/Swept_Wing_API/Images/GUI_Sect.png
+vspaero_ex/Swept_Wing_API/Images/GUI_VSPAERO_Advanced.png
+vspaero_ex/Swept_Wing_API/Images/GUI_VSPAERO_Overview.png
+vspaero_ex/Swept_Wing_API/Images/GUI_VSPAERO_Results.png
+vspaero_ex/Swept_Wing_API/Images/GUI_XFORM.png
+vspaero_ex/Swept_Wing_API/Images/geometry.png
+vspaero_ex/Swept_Wing_API/Images/parmName.png
+vspaero_ex/Swept_Wing_API/NACA63A012.af
+vspaero_ex/Swept_Wing_API/README.md
+vspaero_ex/Swept_Wing_API/TR1208.vsp3
+vspaero_ex/Swept_Wing_API/TR1208.vspscript
vspaero_ex/Uber_eCRM-002/README.md
vspaero_ex/Uber_eCRM-002/uber2.vsp3
vspaero_ex/Uber_eCRM-002/uber2_DegenGeom.csv