aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-11-26 06:31:58 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-11-26 06:31:58 +0000
commit1568bb8e0053cd99f3b5156479687536f04ef292 (patch)
tree303e29ac9216fd59eab1a3dcdc59c9a74801680c /cad
parentb915ce8529c242c62180bd64442c482030703456 (diff)
downloadports-1568bb8e0053cd99f3b5156479687536f04ef292.tar.gz
ports-1568bb8e0053cd99f3b5156479687536f04ef292.zip
cad/alliance: respect users' IMAGEMAGICK_DEFAULT setting
While here, fix submake invocation correctly and quote the explanation from the GNU make manual.
Diffstat (limited to 'cad')
-rw-r--r--cad/alliance/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index f6472b71e480..9b9f8473d2d1 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -18,7 +18,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_aarch64= fails to link: collect2: error: ld returned 1 exit status
-BUILD_DEPENDS= convert:graphics/ImageMagick7 \
+BUILD_DEPENDS= convert:graphics/ImageMagick${IMAGEMAGICK_DEFAULT} \
fig2dev:print/fig2dev
USES= autoreconf:build gmake libtool motif tar:bz2 xorg
@@ -45,9 +45,9 @@ ALLIANCE_TOP= ${PREFIX}/alliance
post-patch:
@${REINPLACE_CMD} -e '/include <malloc.h>/d' \
${WRKSRC}/xgra/src/XSB_parse.c
- # These Makefiles contain hardcoded references to make(1). Replace them with
- # gmake(1) to avoid build failures of the documentation.
- @${REINPLACE_CMD} -e 's/; make/; gmake/' \
+# Recursive make commands should always use the variable MAKE, not the
+# explicit command name `make' (see the GNU make manual, section 5.7.1)
+ @${REINPLACE_CMD} -e 's/; make/; $$(MAKE)/' \
${WRKSRC}/documentation/Makefile.am \
${WRKSRC}/documentation/alliance-examples/Makefile \
${WRKSRC}/documentation/tutorials/Makefile.am