aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2011-10-31 15:39:01 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2011-10-31 15:39:01 +0000
commit19f03cc47eb935a4a3820adaadd73db9382c6a31 (patch)
tree57f79ef50331008db1340f4c1ca24c0c1b964e13 /cad
parent15e44bb18d0f535d1694558736795aab2b681041 (diff)
downloadports-19f03cc47eb935a4a3820adaadd73db9382c6a31.tar.gz
ports-19f03cc47eb935a4a3820adaadd73db9382c6a31.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/qcad/Makefile2
-rw-r--r--cad/qcad/files/patch-ad28
-rw-r--r--cad/qcad/files/patch-ae10
3 files changed, 39 insertions, 1 deletions
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index b27242f2f29b..f6867b4a7df8 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -39,7 +39,7 @@ post-patch:
${WRKSRC}/scripts/build_qcad.sh
do-build:
- cd ${WRKSRC}/scripts && ${SETENV} ${MAKE_ENV} bash ./build_qcad.sh notrans
+ cd ${WRKSRC}/scripts && ${SETENV} ${MAKE_ENV} bash ./build_qcad.sh
pre-install:
@${ECHO_CMD} bin/qcad > ${PLIST}
diff --git a/cad/qcad/files/patch-ad b/cad/qcad/files/patch-ad
new file mode 100644
index 000000000000..c336456c040b
--- /dev/null
+++ b/cad/qcad/files/patch-ad
@@ -0,0 +1,28 @@
+--- scripts/release_translations.sh
++++ scripts/release_translations.sh
+@@ -0,0 +1,24 @@
++#!/bin/bash
++cd ..
++cwd=`pwd`
++echo "### $cwd"
++for dir in qcad qcadactions qcadguiqt qcadcmd qcadlib
++do
++ cd $dir/src
++ echo "### $dir"
++ echo "running lrelease in $dir/src..."
++ find . -type f -name '*.ts' -exec $QTDIR/bin/lrelease '{}' \;
++ find . -type f -name '*.pro' -exec $QTDIR/bin/lrelease '{}' \;
++ cd ../..
++
++ cd $dir/src/ts
++ echo "copying from $dir/src/ts..."
++ for tf in *.qm
++ do
++ if [ ! -e $cwd/qcad/qm/$tf ]
++ then
++ cp $cwd/$dir/src/ts/$tf $cwd/qcad/qm/$tf
++ fi
++ done
++ cd ../../..
++done
+
diff --git a/cad/qcad/files/patch-ae b/cad/qcad/files/patch-ae
new file mode 100644
index 000000000000..5902aba86063
--- /dev/null
+++ b/cad/qcad/files/patch-ae
@@ -0,0 +1,10 @@
+--- scripts/build_qcad.sh 2005-11-22 12:27:33.000000000 +0100
++++ scripts/qcad.sh 2009-01-23 20:28:12.000000000 +0100
+@@ -249,6 +249,7 @@
+ echo "-------- Building Translations --------"
+ cd scripts
+ sh ./release_translations.sh
++ cd ..
+ fi
+
+ if [ "x$platform" == "xosx" ]