aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-25 19:04:03 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-25 19:04:03 +0000
commit8ad2090df40d6ef54addc2c0d5985dd416121d7c (patch)
tree49b82a8aa36cdebdf81697141e1ca3206ffe162a /cad
parent6e05ae4775ebc715957ec1e73cfe758ef411b486 (diff)
downloadports-8ad2090df40d6ef54addc2c0d5985dd416121d7c.tar.gz
ports-8ad2090df40d6ef54addc2c0d5985dd416121d7c.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/gmsh/Makefile11
-rw-r--r--cad/gmsh/distinfo4
-rw-r--r--cad/gmsh/files/patch-CMakeLists.txt49
-rw-r--r--cad/gmsh/files/patch-Common::StringUtils.cpp10
-rw-r--r--cad/gmsh/files/patch-Fltk::aboutWindow.cpp10
-rw-r--r--cad/gmsh/files/patch-Fltk::messageWindow.cpp10
-rw-r--r--cad/gmsh/files/patch-Geo::GModelIO_CGNS.cpp10
-rw-r--r--cad/gmsh/files/patch-Geo_MZoneBoundary.h18
-rw-r--r--cad/gmsh/files/patch-Post::PViewDataIO.cpp10
-rw-r--r--cad/gmsh/files/patch-Solver::linearSystemCSR.cpp11
-rw-r--r--cad/gmsh/files/patch-contrib::Chaco::main::Gmsh_printf.cpp10
-rw-r--r--cad/gmsh/pkg-plist12
12 files changed, 54 insertions, 111 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 02fd6185e97b..07a5d7e107b6 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gmsh
-PORTVERSION= 2.4.2
-PORTREVISION= 5
+PORTVERSION= 2.5.0
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/ \
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/
@@ -24,6 +23,8 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
jpeg.11:${PORTSDIR}/graphics/jpeg \
lapack.4:${PORTSDIR}/math/lapack
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
+
SLAVEDIRS= cad/gmsh-occ
USE_FORTRAN= yes
@@ -73,7 +74,7 @@ IGNORE= requires that WITHOUT_METIS is not set if WITH_TAUCS is set
.if !defined(WITHOUT_METIS)
CMAKE_ARGS+= -DENABLE_METIS=ON
.if defined(NOPORTDOCS)
-IGNORE= The license for Metis requires that its documentation is included
+IGNORE= the license for Metis requires that its documentation is included
.endif
DISTFILES+= manual.pdf
PLIST_SUB+= METIS=""
@@ -190,6 +191,10 @@ post-extract:
@${ECHO} "because Taucs requires Metis." >> ${PKGMESSAGE}
.endif
+post-patch:
+ ${REINPLACE_CMD} -e s+share/doc/gmsh+${DOCSDIR_REL}+ \
+ -e s+share/man/man1+man/man1+ ${WRKSRC}/CMakeLists.txt
+
post-install:
.if !defined(WITHOUT_SHARED_LIB)
${MV} -f ${PREFIX}/lib/libGmsh.so ${PREFIX}/lib/libGmsh.so.0
diff --git a/cad/gmsh/distinfo b/cad/gmsh/distinfo
index 135313201723..a65b4c032831 100644
--- a/cad/gmsh/distinfo
+++ b/cad/gmsh/distinfo
@@ -1,4 +1,4 @@
-SHA256 (gmsh/gmsh-2.4.2-source.tgz) = b922b1f8f63085361cb4b94a16eb72b4d75d580d5610ebeeccd0a2223920acc1
-SIZE (gmsh/gmsh-2.4.2-source.tgz) = 3109391
+SHA256 (gmsh/gmsh-2.5.0-source.tgz) = db1d3b92e56a85be9ec1c020aa2c705ccf5b7f0d00fa0f29b50efc73b378debc
+SIZE (gmsh/gmsh-2.5.0-source.tgz) = 3642009
SHA256 (gmsh/manual.pdf) = 8a682ee7f02380f52d5efdde5f9f9d8e927a4f4eb29287a878c1016225568911
SIZE (gmsh/manual.pdf) = 206713
diff --git a/cad/gmsh/files/patch-CMakeLists.txt b/cad/gmsh/files/patch-CMakeLists.txt
index 2e0e6b18acc6..aa5568412b56 100644
--- a/cad/gmsh/files/patch-CMakeLists.txt
+++ b/cad/gmsh/files/patch-CMakeLists.txt
@@ -1,21 +1,21 @@
---- CMakeLists.txt.orig 2009-09-21 13:54:49.000000000 -0500
-+++ CMakeLists.txt 2010-01-17 21:14:51.000000000 -0600
-@@ -41,6 +41,7 @@
+--- CMakeLists.txt.orig 2010-10-15 13:35:00.000000000 +0000
++++ CMakeLists.txt 2011-07-25 03:34:11.000000000 +0000
+@@ -53,6 +53,7 @@
option(ENABLE_TAUCS "Enable Taucs linear algebra solver" ON)
option(ENABLE_TETGEN "Enable Tetgen mesh generator" ON)
option(ENABLE_TETGEN_NEW "Enable experimental version of Tetgen" OFF)
+option(INSTALL_DOCS "Install the docs (FreeBSD only)" ON)
set(GMSH_MAJOR_VERSION 2)
- set(GMSH_MINOR_VERSION 4)
-@@ -478,13 +479,17 @@
- if(ENABLE_TAUCS)
- find_library(TAUCS_LIB taucs)
+ set(GMSH_MINOR_VERSION 5)
+@@ -574,13 +575,17 @@
+ endif(NOT HAVE_METIS)
+ find_library(TAUCS_LIB taucs PATH_SUFFIXES lib)
if(TAUCS_LIB)
-- find_path(TAUCS_INC "taucs.h" PATH_SUFFIXES src include)
+- find_path(TAUCS_INC "taucs.h" PATH_SUFFIXES src include taucs)
- if(TAUCS_INC)
-- set(HAVE_TAUCS TRUE)
-- list(APPEND CONFIG_OPTIONS "Taucs")
+- set_config_option(HAVE_TAUCS "Taucs")
+- add_definitions(-DTAUCS_CILK)
- list(APPEND EXTERNAL_LIBRARIES ${TAUCS_LIB})
- list(APPEND EXTERNAL_INCLUDES ${TAUCS_INC})
- endif(TAUCS_INC)
@@ -33,32 +33,16 @@
endif(TAUCS_LIB)
endif(ENABLE_TAUCS)
-@@ -518,7 +523,7 @@
+@@ -673,7 +678,7 @@
list(LENGTH OCC_LIBS NUM_OCC_LIBS)
if(NUM_OCC_LIBS EQUAL NUM_OCC_LIBS_REQUIRED)
find_path(OCC_INC "BRep_Tool.hxx" PATHS ENV CASROOT PATH_SUFFIXES inc
- include opencascade)
+ include opencascade OpenCAS/ros/inc)
if(OCC_INC)
- set(HAVE_OCC TRUE)
- list(APPEND CONFIG_OPTIONS "OpenCascade")
-@@ -654,15 +659,6 @@
- if(HAVE_LAPACK AND LAPACK_FLAGS)
- set_target_properties(shared PROPERTIES LINK_FLAGS ${LAPACK_FLAGS})
- endif(HAVE_LAPACK AND LAPACK_FLAGS)
--if(HAVE_FLTK)
-- target_link_libraries(shared ${FLTK_LIBRARIES} ${EXTERNAL_LIBRARIES}
-- ${OPENGL_LIBRARIES} ${LAPACK_LIBRARIES})
--elseif(HAVE_OPENGL)
-- target_link_libraries(shared ${EXTERNAL_LIBRARIES} ${OPENGL_LIBRARIES}
-- ${LAPACK_LIBRARIES})
--else(HAVE_FLTK)
-- target_link_libraries(shared ${EXTERNAL_LIBRARIES} ${LAPACK_LIBRARIES})
--endif(HAVE_FLTK)
-
- # binary targets
- if(HAVE_FLTK)
-@@ -762,13 +758,15 @@
+ set_config_option(HAVE_OCC "OpenCascade")
+ list(APPEND EXTERNAL_LIBRARIES ${OCC_LIBS})
+@@ -969,11 +974,13 @@
install(TARGETS gmsh DESTINATION ${GMSH_BIN} OPTIONAL)
install(TARGETS lib shared DESTINATION lib OPTIONAL)
install(FILES ${GMSH_API} DESTINATION include/gmsh)
@@ -75,8 +59,5 @@
+ install(FILES ${DEMO_FILES} DESTINATION ${GMSH_DOC}/demos)
+endif(INSTALL_DOCS)
if(UNIX AND NOT CYGWIN)
-- install(FILES ${CMAKE_SOURCE_DIR}/doc/gmsh.1 DESTINATION share/man/man1)
-+ install(FILES ${CMAKE_SOURCE_DIR}/doc/gmsh.1 DESTINATION man/man1)
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/doc/gmsh.1 DESTINATION ${GMSH_MAN})
endif(UNIX AND NOT CYGWIN)
-
- find_program(MAKEINFO makeinfo)
diff --git a/cad/gmsh/files/patch-Common::StringUtils.cpp b/cad/gmsh/files/patch-Common::StringUtils.cpp
deleted file mode 100644
index 41875a388ad1..000000000000
--- a/cad/gmsh/files/patch-Common::StringUtils.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- Common/StringUtils.cpp-xxx 2009-07-20 16:49:34.000000000 -0500
-+++ Common/StringUtils.cpp 2009-07-20 16:49:53.000000000 -0500
-@@ -9,6 +9,7 @@
-
- #include "StringUtils.h"
- #include "GmshMessage.h"
-+#include <cstdio>
-
- void SwapBytes(char *array, int size, int n)
- {
diff --git a/cad/gmsh/files/patch-Fltk::aboutWindow.cpp b/cad/gmsh/files/patch-Fltk::aboutWindow.cpp
deleted file mode 100644
index ead078b73046..000000000000
--- a/cad/gmsh/files/patch-Fltk::aboutWindow.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- Fltk/aboutWindow.cpp-xxx 2009-07-20 16:56:09.000000000 -0500
-+++ Fltk/aboutWindow.cpp 2009-07-20 16:56:21.000000000 -0500
-@@ -13,6 +13,7 @@
- #include "StringUtils.h"
- #include "OS.h"
- #include "Context.h"
-+#include <cstdio>
-
- static void help_license_cb(Fl_Widget *w, void *data)
- {
diff --git a/cad/gmsh/files/patch-Fltk::messageWindow.cpp b/cad/gmsh/files/patch-Fltk::messageWindow.cpp
deleted file mode 100644
index a4f8bf636f3d..000000000000
--- a/cad/gmsh/files/patch-Fltk::messageWindow.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- Fltk/messageWindow.cpp-xxx 2009-07-20 16:50:18.000000000 -0500
-+++ Fltk/messageWindow.cpp 2009-07-20 16:50:28.000000000 -0500
-@@ -4,6 +4,7 @@
- // bugs and problems to <gmsh@geuz.org>.
-
- #include <string.h>
-+#include <cstdio>
- #include <FL/Fl_Box.H>
- #include <FL/Fl_Return_Button.H>
- #include <FL/fl_ask.H>
diff --git a/cad/gmsh/files/patch-Geo::GModelIO_CGNS.cpp b/cad/gmsh/files/patch-Geo::GModelIO_CGNS.cpp
deleted file mode 100644
index 383b5d518561..000000000000
--- a/cad/gmsh/files/patch-Geo::GModelIO_CGNS.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- Geo/GModelIO_CGNS.cpp-xxx 2009-07-20 16:54:23.000000000 -0500
-+++ Geo/GModelIO_CGNS.cpp 2009-07-20 16:55:01.000000000 -0500
-@@ -24,6 +24,7 @@
- #define omp_destroy_lock(x)
- #endif
-
-+#include <cstdio>
- #include <cstring>
- #include <iostream> // DBG
- #include <map>
diff --git a/cad/gmsh/files/patch-Geo_MZoneBoundary.h b/cad/gmsh/files/patch-Geo_MZoneBoundary.h
new file mode 100644
index 000000000000..47b467ad8e5a
--- /dev/null
+++ b/cad/gmsh/files/patch-Geo_MZoneBoundary.h
@@ -0,0 +1,18 @@
+--- Geo/MZoneBoundary.h-orig 2010-10-15 13:35:00.000000000 +0000
++++ Geo/MZoneBoundary.h 2011-07-25 03:22:05.000000000 +0000
+@@ -317,12 +317,12 @@
+ {
+ // NBN: using FaceT* so need to dealloc:
+ int icount = 0;
+- GlobalBoVertexMap::iterator itEnd = globalBoVertMap.end();
+- for (GlobalBoVertexMap::iterator itBoV = globalBoVertMap.begin();
++ typename GlobalBoVertexMap::iterator itEnd = globalBoVertMap.end();
++ for (typename GlobalBoVertexMap::iterator itBoV = globalBoVertMap.begin();
+ itBoV != itEnd; ++itBoV)
+ {
+ // ... clear the faces
+- typename GlobalVertexData<FaceT>& ref = itBoV->second;
++ GlobalVertexData<FaceT>& ref = itBoV->second;
+ size_t nf = ref.faces.size();
+ for (int i=0; i<nf; ++i) {
+ ++ icount;
diff --git a/cad/gmsh/files/patch-Post::PViewDataIO.cpp b/cad/gmsh/files/patch-Post::PViewDataIO.cpp
deleted file mode 100644
index 1ba6307ccd92..000000000000
--- a/cad/gmsh/files/patch-Post::PViewDataIO.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- Post/PViewDataIO.cpp-xxx 2009-07-20 16:53:25.000000000 -0500
-+++ Post/PViewDataIO.cpp 2009-07-20 16:53:37.000000000 -0500
-@@ -4,6 +4,7 @@
- // bugs and problems to <gmsh@geuz.org>.
-
- #include <string.h>
-+#include <cstdio>
- #include "GmshMessage.h"
- #include "Numeric.h"
- #include "PViewData.h"
diff --git a/cad/gmsh/files/patch-Solver::linearSystemCSR.cpp b/cad/gmsh/files/patch-Solver::linearSystemCSR.cpp
deleted file mode 100644
index 20a278b2dcb6..000000000000
--- a/cad/gmsh/files/patch-Solver::linearSystemCSR.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- Solver/linearSystemCSR.cpp.orig 2010-01-02 16:10:27.000000000 -0600
-+++ Solver/linearSystemCSR.cpp 2010-01-02 16:10:40.000000000 -0600
-@@ -245,7 +245,7 @@
- }
-
- template <class scalar>
--static void sortColumns(int NbLines,
-+void sortColumns(int NbLines,
- int nnz,
- INDEX_TYPE *ptr,
- INDEX_TYPE *jptr,
diff --git a/cad/gmsh/files/patch-contrib::Chaco::main::Gmsh_printf.cpp b/cad/gmsh/files/patch-contrib::Chaco::main::Gmsh_printf.cpp
deleted file mode 100644
index e64cab811bcb..000000000000
--- a/cad/gmsh/files/patch-contrib::Chaco::main::Gmsh_printf.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- contrib/Chaco/main/Gmsh_printf.cpp-xxx 2009-07-20 16:52:04.000000000 -0500
-+++ contrib/Chaco/main/Gmsh_printf.cpp 2009-07-20 16:52:15.000000000 -0500
-@@ -4,6 +4,7 @@
- // bugs and problems to <gmsh@geuz.org>.
-
- #include <cstring>
-+#include <cstdio>
- #include "GmshMessage.h"
-
- // Overload the printf statements in Chaco to write using Msg::Direct in gmsh
diff --git a/cad/gmsh/pkg-plist b/cad/gmsh/pkg-plist
index f45753a25309..e95397549092 100644
--- a/cad/gmsh/pkg-plist
+++ b/cad/gmsh/pkg-plist
@@ -2,6 +2,7 @@ bin/gmsh
%%STATIC_LIB%%lib/libGmsh.a
%%SHARED_LIB%%lib/libGmsh.so
%%SHARED_LIB%%lib/libGmsh.so.0
+include/gmsh/Cell.h
include/gmsh/CellComplex.h
include/gmsh/ChainComplex.h
include/gmsh/DILevelset.h
@@ -22,6 +23,8 @@ include/gmsh/GmshConfig.h
include/gmsh/GmshDefines.h
include/gmsh/GmshMessage.h
include/gmsh/GmshVersion.h
+include/gmsh/Homology.h
+include/gmsh/JacobianBasis.h
include/gmsh/MEdge.h
include/gmsh/MElement.h
include/gmsh/MElementCut.h
@@ -48,27 +51,33 @@ include/gmsh/SPoint3.h
include/gmsh/STensor3.h
include/gmsh/SVector3.h
include/gmsh/VertexArray.h
+include/gmsh/cartesian.h
+include/gmsh/crossConfTerm.h
include/gmsh/discreteEdge.h
include/gmsh/discreteFace.h
include/gmsh/discreteRegion.h
include/gmsh/discreteVertex.h
include/gmsh/dofManager.h
include/gmsh/drawContext.h
+include/gmsh/elasticitySolver.h
include/gmsh/elasticityTerm.h
include/gmsh/femTerm.h
include/gmsh/fullMatrix.h
-include/gmsh/functionSpace.h
include/gmsh/gmp_blas.h
include/gmsh/gmp_matrix.h
include/gmsh/gmp_normal_form.h
include/gmsh/laplaceTerm.h
include/gmsh/linearSystem.h
+include/gmsh/linearSystemCSR.h
include/gmsh/linearSystemFull.h
include/gmsh/linearSystemGMM.h
include/gmsh/meshGEdge.h
include/gmsh/meshGFace.h
include/gmsh/meshGFaceDelaunayInsertion.h
include/gmsh/meshGFaceOptimize.h
+include/gmsh/mpz.h
+include/gmsh/orthogonalTerm.h
+include/gmsh/polynomialBasis.h
include/gmsh/simpleFunction.h
%%PORTDOCS%%%%DOCSDIR%%/CREDITS.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
@@ -120,6 +129,7 @@ include/gmsh/simpleFunction.h
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t8.geo
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t8.par
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t9.geo
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/t10.geo
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view1.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view2.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view3.pos