aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 22:27:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 22:27:05 +0000
commit9ff06b3cbf038359059e40e0db31ba0cbe996d0f (patch)
tree8583dfe71adaea6ce266633e1799cd602516b801 /cad
parent25c4307da135103ea810d65f96f2f1c21e0547b4 (diff)
downloadports-9ff06b3cbf038359059e40e0db31ba0cbe996d0f.tar.gz
ports-9ff06b3cbf038359059e40e0db31ba0cbe996d0f.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/geda-gattrib/Makefile10
-rw-r--r--cad/geda-gschem/Makefile10
-rw-r--r--cad/kicad/Makefile14
-rw-r--r--cad/libgeda/Makefile4
-rw-r--r--cad/repsnapper/Makefile12
5 files changed, 23 insertions, 27 deletions
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
index d88b63969d50..14e969cf6b8f 100644
--- a/cad/geda-gattrib/Makefile
+++ b/cad/geda-gattrib/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: geda-gattrib
-# Date created: 26 June 2006
-# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
-#
+# Created by: Stanislav Sedov <ssedov@mbsd.msk.ru>
# $FreeBSD$
-#
PORTNAME= gattrib
PORTVERSION= 1.4.3
@@ -33,7 +29,9 @@ CONFIGURE_ARGS= --with-docdir="${DOCSDIR}" --disable-update-mime-database \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/cad/geda-gschem/Makefile b/cad/geda-gschem/Makefile
index dcce41c40c69..c951ca46c11c 100644
--- a/cad/geda-gschem/Makefile
+++ b/cad/geda-gschem/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: geda
-# Date created: 4 April 2001
-# Whom: bruno schwander <bruno@tinkerbox.org>
-#
+# Created by: bruno schwander <bruno@tinkerbox.org>
# $FreeBSD$
-#
PORTNAME= gschem
PORTVERSION= 1.4.3
@@ -36,7 +32,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gschem.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index aec7adb6bfb3..96e5e097c30b 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -38,11 +38,13 @@ WRKSRC= ${WRKDIR}/${SFNAME}
PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S|^${PREFIX}/||}
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
SFNAME= ${PORTNAME}-sources-${DISTVERSION}
@@ -59,7 +61,7 @@ RUN_DEPENDS+= konqueror:${PORTSDIR}/x11/kdebase3
RUN_DEPENDS+= xpdf:${PORTSDIR}/graphics/xpdf
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-extract:
cd ${WRKSRC} && ${TAR} -xf ${DISTDIR}/${DFNAME}.tgz
.endif
@@ -72,14 +74,14 @@ pre-configure:
${WRKSRC}/common/gestfich.cpp
post-install:
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
${MKDIR} ${DATADIR}/internat
(cd ${WRKSRC}/internat && \
${COPYTREE_SHARE} \* ${DATADIR}/internat)
${RM} ${DATADIR}/internat/CMakeLists.txt
${FIND} ${DATADIR}/internat -name kicad.po -delete
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
@${ECHO_MSG}
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
index eb597f48c8e8..7d539f2d8f5b 100644
--- a/cad/libgeda/Makefile
+++ b/cad/libgeda/Makefile
@@ -25,7 +25,9 @@ CONFIGURE_ARGS= --disable-update-mime-database \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index 5199d489ab87..bb00b4c319d8 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -45,7 +45,9 @@ USE_GMAKE= yes
USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xmu xrandr xrender xt xxf86vm
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -75,10 +77,4 @@ post-install:
${PREFIX}/etc/xdg/repsnapper/repsnapper.conf ; \
fi
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800000
-IGNORE= needs acosl(3) function to compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>