aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /cad
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
downloadports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.tar.gz
ports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/gmsh/Makefile2
-rw-r--r--cad/gtkwave/Makefile2
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--cad/opencascade/Makefile1
-rw-r--r--cad/qelectrotech/Makefile2
-rw-r--r--cad/tkgate/Makefile2
6 files changed, 7 insertions, 4 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 5a0baad082c8..07c16038ceff 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -37,7 +37,7 @@ MAKE_JOBS_UNSAFE= yes
CMAKE_ARGS= -DCMAKE_SKIP_RPATH:BOOL=YES
-OPTIONS_DEFINE= CGNS MED OCC SHARED STATIC
+OPTIONS_DEFINE= CGNS DOCS MED OCC SHARED STATIC
OPTIONS_DEFAULT= MED
CGNS_DESC= Enable experimental CGNS mesh support
diff --git a/cad/gtkwave/Makefile b/cad/gtkwave/Makefile
index a566c1036546..8e03642b6c68 100644
--- a/cad/gtkwave/Makefile
+++ b/cad/gtkwave/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ARGS= --disable-mime-update
USE_GNOME= cairo gtk20
INSTALLS_ICONS= yes
-OPTIONS_DEFINE= TCL GCONF EXAMPLES
+OPTIONS_DEFINE= TCL GCONF DOCS EXAMPLES
TCL_DESC= Enable support for TCL/TK
TCL_USES= tcl tk
TCL_CONFIGURE_ON= --with-tcl=${TCL_LIBDIR} \
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 94e830788f99..5e7c94824884 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -36,7 +36,7 @@ USE_XORG+= ice pixman x11 xext
BROKEN_aarch64= Fails to compile: use of undeclared identifier builtin_ia32_emms
-#OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS
PLIST_SUB= OPSYS=${OPSYS} \
DESKTOPDIR=${DESKTOPDIR:S|^${PREFIX}/||}
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index af4cf242de2b..afaf6f740abc 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -74,6 +74,7 @@ VIS_LIB_DEPENDS= libftgl.so:graphics/ftgl \
VIS_CMAKE_ON= -D3RDPARTY_FREETYPE_DIR=${LOCALBASE}
+DOXYGEN_IMPLIES= DOCS
DOXYGEN_USE= TEX=latex:build
DOXYGEN_BUILD_DEPENDS= bash:shells/bash \
doxygen:devel/doxygen \
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
index 5cf260e55698..bbb2b802857e 100644
--- a/cad/qelectrotech/Makefile
+++ b/cad/qelectrotech/Makefile
@@ -19,7 +19,7 @@ USES= compiler:c++11-lib desktop-file-utils qmake qt:5 shared-mime-info
USE_QT= buildtools_build gui network printsupport \
sql-sqlite3 svg xml
-OPTIONS_DEFINE= DEBUG
+OPTIONS_DEFINE= DEBUG DOCS
DEBUG_VARS= BUILD_TYPE=debug
DEBUG_VARS_OFF= BUILD_TYPE=release
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
index a3023fef7d72..fe120ff24498 100644
--- a/cad/tkgate/Makefile
+++ b/cad/tkgate/Makefile
@@ -16,6 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
USES+= iconv:translit tk:build,run
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/wish|${WISH}|g' ${WRKSRC}/scripts/tree.tcl
@${REINPLACE_CMD} -e \