aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-10-15 04:41:00 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-10-15 08:28:15 +0000
commit5f682b0ef389d0e6b2d8dafe522721d933234612 (patch)
tree5dce7678570c49d3e76e8e185df75e89ad068e26 /cad
parent9a220b100573bb2e7b79177fdf9012625b9f272e (diff)
downloadports-5f682b0ef389d0e6b2d8dafe522721d933234612.tar.gz
ports-5f682b0ef389d0e6b2d8dafe522721d933234612.zip
Diffstat (limited to 'cad')
-rw-r--r--cad/gdstk/Makefile6
-rw-r--r--cad/gdstk/distinfo6
-rw-r--r--cad/gdstk/files/patch-CMakeLists.txt11
-rw-r--r--cad/gdstk/pkg-plist55
-rw-r--r--cad/py-gdstk/Makefile15
-rw-r--r--cad/py-gdstk/distinfo6
6 files changed, 51 insertions, 48 deletions
diff --git a/cad/gdstk/Makefile b/cad/gdstk/Makefile
index c505a5c14bc7..66860b40d7d2 100644
--- a/cad/gdstk/Makefile
+++ b/cad/gdstk/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gdstk
DISTVERSIONPREFIX= v
-DISTVERSION= 0.9.42
+DISTVERSION= 0.9.46
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
@@ -10,6 +10,8 @@ WWW= https://heitzmann.github.io/gdstk/
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE
+LIB_DEPENDS= libqhull_r.so:math/qhull
+
USES= cmake compiler:c++11-lang
USE_GITHUB= yes
@@ -17,4 +19,6 @@ GH_ACCOUNT= heitzmann
CMAKE_ON= BUILD_SHARED_LIBS
+CONFLICTS_INSTALL= misc/vxl # both install lib/libclipper.so
+
.include <bsd.port.mk>
diff --git a/cad/gdstk/distinfo b/cad/gdstk/distinfo
index 3771818e5ad2..aa8b239be848 100644
--- a/cad/gdstk/distinfo
+++ b/cad/gdstk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1693211997
-SHA256 (heitzmann-gdstk-v0.9.42_GH0.tar.gz) = 303c6fc4b1de91091c776da928ae71ef0fcfc1b86ed1d1aacae4e2339968d5b4
-SIZE (heitzmann-gdstk-v0.9.42_GH0.tar.gz) = 629280
+TIMESTAMP = 1697306396
+SHA256 (heitzmann-gdstk-v0.9.46_GH0.tar.gz) = 3a2538e0a530a6bd112b528fd436807091335d21fdfde718cd08583052793e3a
+SIZE (heitzmann-gdstk-v0.9.46_GH0.tar.gz) = 363141
diff --git a/cad/gdstk/files/patch-CMakeLists.txt b/cad/gdstk/files/patch-CMakeLists.txt
deleted file mode 100644
index 98f04cb62ae5..000000000000
--- a/cad/gdstk/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2023-08-28 08:41:29 UTC
-+++ CMakeLists.txt
-@@ -50,7 +50,7 @@ foreach(IT ${ZLIB_LIBRARIES})
- set(PRIVATE_LIBS "${PRIVATE_LIBS} ${IT}")
- endforeach()
-
--add_library(gdstk STATIC
-+add_library(gdstk
- src/cell.cpp
- src/clipper_tools.cpp
- src/curve.cpp
diff --git a/cad/gdstk/pkg-plist b/cad/gdstk/pkg-plist
index 7d972a760a47..269be7208980 100644
--- a/cad/gdstk/pkg-plist
+++ b/cad/gdstk/pkg-plist
@@ -1,28 +1,31 @@
-include/gdstk.h
-include/gdstk/allocator.h
-include/gdstk/array.h
-include/gdstk/cell.h
-include/gdstk/clipper_tools.h
-include/gdstk/curve.h
-include/gdstk/flexpath.h
-include/gdstk/font.h
-include/gdstk/gdsii.h
-include/gdstk/gdswriter.h
-include/gdstk/label.h
-include/gdstk/library.h
-include/gdstk/map.h
-include/gdstk/oasis.h
-include/gdstk/pathcommon.h
-include/gdstk/polygon.h
-include/gdstk/property.h
-include/gdstk/rawcell.h
-include/gdstk/reference.h
-include/gdstk/repetition.h
-include/gdstk/robustpath.h
-include/gdstk/set.h
-include/gdstk/sort.h
-include/gdstk/style.h
-include/gdstk/utils.h
-include/gdstk/vec.h
+include/clipper/clipper.hpp
+include/gdstk/allocator.hpp
+include/gdstk/array.hpp
+include/gdstk/cell.hpp
+include/gdstk/clipper_tools.hpp
+include/gdstk/curve.hpp
+include/gdstk/flexpath.hpp
+include/gdstk/font.hpp
+include/gdstk/gdsii.hpp
+include/gdstk/gdstk.hpp
+include/gdstk/gdswriter.hpp
+include/gdstk/label.hpp
+include/gdstk/library.hpp
+include/gdstk/map.hpp
+include/gdstk/oasis.hpp
+include/gdstk/pathcommon.hpp
+include/gdstk/polygon.hpp
+include/gdstk/property.hpp
+include/gdstk/rawcell.hpp
+include/gdstk/reference.hpp
+include/gdstk/repetition.hpp
+include/gdstk/robustpath.hpp
+include/gdstk/set.hpp
+include/gdstk/sort.hpp
+include/gdstk/style.hpp
+include/gdstk/tagmap.hpp
+include/gdstk/utils.hpp
+include/gdstk/vec.hpp
+lib/libclipper.so
lib/libgdstk.so
libdata/pkgconfig/gdstk.pc
diff --git a/cad/py-gdstk/Makefile b/cad/py-gdstk/Makefile
index 9aed69397199..47339d89dbb0 100644
--- a/cad/py-gdstk/Makefile
+++ b/cad/py-gdstk/Makefile
@@ -1,7 +1,8 @@
PORTNAME= gdstk
-DISTVERSION= 0.9.42
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9.46
CATEGORIES= cad
-MASTER_SITES= PYPI
+#MASTER_SITES= PYPI # build fails from PYPI: https://github.com/heitzmann/gdspy/issues/236
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
@@ -15,11 +16,17 @@ BUILD_DEPENDS= cmake:devel/cmake-core \
${PY_SETUPTOOLS} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR} \
${PYNUMPY}
+LIB_DEPENDS= libqhull_r.so:math/qhull
USES= compiler:c++11-lang python
-USE_PYTHON= pep517 autoplist
+USE_PYTHON= pep517 autoplist pytest # tests fail to run, see https://github.com/heitzmann/gdspy/issues/237
+
+USE_GITHUB= yes
+GH_ACCOUNT= heitzmann
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/gdstk${PYTHON_EXT_SUFFIX}.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/gdstk/gdstk${PYTHON_EXT_SUFFIX}.so
.include <bsd.port.mk>
diff --git a/cad/py-gdstk/distinfo b/cad/py-gdstk/distinfo
index 60456b065423..033436cf4892 100644
--- a/cad/py-gdstk/distinfo
+++ b/cad/py-gdstk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1693240074
-SHA256 (gdstk-0.9.42.tar.gz) = bd7ab2f72e50df3ca396e94b82c202a4dfbef1e1206ab6d371d961ab12edfa97
-SIZE (gdstk-0.9.42.tar.gz) = 513544
+TIMESTAMP = 1697344042
+SHA256 (heitzmann-gdstk-v0.9.46_GH0.tar.gz) = 3a2538e0a530a6bd112b528fd436807091335d21fdfde718cd08583052793e3a
+SIZE (heitzmann-gdstk-v0.9.46_GH0.tar.gz) = 363141