aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-21 21:55:08 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-21 21:55:08 +0000
commitfa7459871993c1b82be45b128cb6cc16d6d6097b (patch)
treef3de3615c4398425cec6e6c4d1a630f701a34d2d /cad
parenta379971cffb802fce69885970f1184f7228beb86 (diff)
downloadports-fa7459871993c1b82be45b128cb6cc16d6d6097b.tar.gz
ports-fa7459871993c1b82be45b128cb6cc16d6d6097b.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket) Reported by: swills
Notes
Notes: svn path=/head/; revision=441429
Diffstat (limited to 'cad')
-rw-r--r--cad/cider/Makefile3
-rw-r--r--cad/libopencad/Makefile3
-rw-r--r--cad/solvespace/Makefile2
-rw-r--r--cad/stepcode/Makefile2
4 files changed, 9 insertions, 1 deletions
diff --git a/cad/cider/Makefile b/cad/cider/Makefile
index 045935993f70..4ce01ee9e530 100644
--- a/cad/cider/Makefile
+++ b/cad/cider/Makefile
@@ -11,7 +11,8 @@ DISTNAME= cider1b1
MAINTAINER= ports@FreeBSD.org
COMMENT= Mixed-level circuit and device simulator (includes SPICE3)
-BROKEN_aarch64= Fails to link: missing sbrk
+BROKEN_aarch64= fails to link: missing sbrk
+BROKEN_powerpc64= fails to compile: ccache: cc: FreeBSD: No such file or directory
CONFLICTS= spice-[0-9]*
WRKSRC= ${WRKDIR}/sim
diff --git a/cad/libopencad/Makefile b/cad/libopencad/Makefile
index 4778aaeb3bf8..438ac7621580 100644
--- a/cad/libopencad/Makefile
+++ b/cad/libopencad/Makefile
@@ -12,6 +12,9 @@ COMMENT= Library which provides a way to read/write CAD (DWG/DXF/DXFB) files
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_armv6= fails to compile: cadheader.cpp: ambiguous conversion for functional-style cast from 'time_t' to 'CADVariant'
+BROKEN_powerpc64= fails to compile: r2000.cpp: 'to_string' was not declared in this scope
+
USE_GITHUB= yes
GH_ACCOUNT= sandyre
diff --git a/cad/solvespace/Makefile b/cad/solvespace/Makefile
index 852ab3a1c464..10a6d1768824 100644
--- a/cad/solvespace/Makefile
+++ b/cad/solvespace/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libgtkmm-2.4.so:x11-toolkits/gtkmm24
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
USE_GITHUB= yes
GH_PROJECT= libdxfrw:libdxfrw
GH_TAGNAME= 8f95895:libdxfrw
diff --git a/cad/stepcode/Makefile b/cad/stepcode/Makefile
index 81ed95373505..ee9d3d37369e 100644
--- a/cad/stepcode/Makefile
+++ b/cad/stepcode/Makefile
@@ -13,6 +13,8 @@ COMMENT= Generates C++ and Python from ISO10303 files
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: Schema scan for 15926-0002-lifecycle_integration.exp exited with error code 1
+
USE_GITHUB= yes
USE_LDCONFIG= yes