aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-16 03:47:12 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-16 03:47:12 +0000
commit80470c34c5b3f024ff807d1d3a5e19575a407a22 (patch)
treef177b108f1df4947a3fe07f5da81fb4a16f2772d /cad
parent87179c9d15d87d787221a534426758b207496a52 (diff)
downloadports-80470c34c5b3f024ff807d1d3a5e19575a407a22.tar.gz
ports-80470c34c5b3f024ff807d1d3a5e19575a407a22.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/geda-gattrib/Makefile20
-rw-r--r--cad/geda-gattrib/files/patch-configure11
-rw-r--r--cad/geda-gattrib/pkg-plist4
3 files changed, 29 insertions, 6 deletions
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
index a94123b72014..f682af97fe28 100644
--- a/cad/geda-gattrib/Makefile
+++ b/cad/geda-gattrib/Makefile
@@ -7,21 +7,33 @@
PORTNAME= gattrib
PORTVERSION= 20060123
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/devel/${PORTVERSION}/ \
http://geda.seul.org/devel/${PORTVERSION}/ \
http://www.tinkerbox.org/projects/files/gEDA/
-DISTNAME= geda-${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= geda-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= ssedov@mbsd.msk.ru
-COMMENT= GEDA's attribute editor
+COMMENT= The gEDA's attribute editor
-RUN_DEPENDS= ${LOCALBASE}/share/gEDA/sym:${PORTSDIR}/cad/geda-symbols
+RUN_DEPENDS= ${LOCALBASE}/share/geda/sym:${PORTSDIR}/cad/geda-symbols
LIB_DEPENDS= geda.25:${PORTSDIR}/cad/libgeda
+DATADIR= ${PREFIX}/share/geda
+DOCSDIR= ${PREFIX}/share/doc/geda
+
GNU_CONFIGURE= yes
USE_GNOME= gtk20
+CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/cad/geda-gattrib/files/patch-configure b/cad/geda-gattrib/files/patch-configure
new file mode 100644
index 000000000000..16b4e1c44957
--- /dev/null
+++ b/cad/geda-gattrib/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Thu Jul 13 20:40:21 2006
++++ configure Thu Jul 13 20:40:31 2006
+@@ -5384,7 +5384,7 @@
+ # gEDA/gaf specify setup start
+ #
+
+-DATADIR=gEDA
++DATADIR=geda
+ GEDADATADIR=$datadir/$DATADIR
+
+ if eval "test x$opt_rcdir = x"; then
diff --git a/cad/geda-gattrib/pkg-plist b/cad/geda-gattrib/pkg-plist
index 66a96e35532e..c3ae43065542 100644
--- a/cad/geda-gattrib/pkg-plist
+++ b/cad/geda-gattrib/pkg-plist
@@ -1,3 +1,3 @@
bin/gattrib
-share/gEDA/system-gattribrc
-@dirrmtry share/gEDA
+%%DATADIR%%/system-gattribrc
+@dirrmtry %%DATADIR%%