aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-12 03:26:56 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-12 03:26:56 +0000
commitc3d8037aeba75366ed06e02fbc981e15b46e7d0a (patch)
tree6074bae79118b7d7d4d3d3a8ac0a4dcd65f18f8b /cad
parentb286f01b6c3af5d674e10da33f8eda0c2011007b (diff)
downloadports-c3d8037aeba75366ed06e02fbc981e15b46e7d0a.tar.gz
ports-c3d8037aeba75366ed06e02fbc981e15b46e7d0a.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/gmsh/Makefile2
-rw-r--r--cad/gtkwave/Makefile2
-rw-r--r--cad/qfsm/Makefile2
-rw-r--r--cad/xcircuit/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 919edab7ded4..5003028699a0 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -32,7 +32,7 @@ TRIANGLE_PORTDIR= ${PORTSDIR}/math/triangle
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fltk-prefix=${X11BASE} \
--with-gsl-prefix=${LOCALBASE} \
--with-jpeg-prefix=${LOCALBASE} \
diff --git a/cad/gtkwave/Makefile b/cad/gtkwave/Makefile
index 86f060175e2c..9f1813c3cf85 100644
--- a/cad/gtkwave/Makefile
+++ b/cad/gtkwave/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
USE_GNOME= gtk12
USE_REINPLACE= yes
USE_LIBTOOL_VER= 13
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${PREFIX}/lib/gtkwave
diff --git a/cad/qfsm/Makefile b/cad/qfsm/Makefile
index 04f373d1bb55..4f49aa9098da 100644
--- a/cad/qfsm/Makefile
+++ b/cad/qfsm/Makefile
@@ -19,7 +19,7 @@ USE_QT_VER= 3
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
post-extract:
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index 3a3dea93cd1c..11fd8086dab7 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -21,7 +21,7 @@ USE_GHOSTSCRIPT_RUN= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"