aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-16 19:24:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-16 19:25:47 +0000
commit15328c5dfa085018b5980eb1e7959b9f50fca41d (patch)
tree27393dd22a80f3c40be38f0b949eee6d04737501 /cad
parent35d001e92a4bd8153af6a506e64da70d61d543f6 (diff)
downloadports-15328c5dfa085018b5980eb1e7959b9f50fca41d.tar.gz
ports-15328c5dfa085018b5980eb1e7959b9f50fca41d.zip
cad/horizon-eda: Add back the workaround for clang crash that was mistakenly removed earlier
Reported by: fallout
Diffstat (limited to 'cad')
-rw-r--r--cad/horizon-eda/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/cad/horizon-eda/Makefile b/cad/horizon-eda/Makefile
index 6d8fae5f75b5..571d745251da 100644
--- a/cad/horizon-eda/Makefile
+++ b/cad/horizon-eda/Makefile
@@ -1,6 +1,7 @@
PORTNAME= horizon-eda
DISTVERSIONPREFIX= v
DISTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
@@ -34,6 +35,12 @@ BINARY_ALIAS= python3=${PYTHON_CMD}
INSTALLS_ICONS= yes
+LLVM_VER= 10 # workaround for bug#253551
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CPP= clang-cpp${LLVM_VER}
+CC= clang${LLVM_VER}
+CXX= clang++${LLVM_VER}
+
post-install: # https://github.com/horizon-eda/horizon/issues/558
cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} horizon-eda