aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-19 08:15:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-19 08:46:10 +0000
commit78701c99c11a8ab41f6826bb871259b874ab553f (patch)
tree5da6b6032e82a21ce896be9d8ce4b47baba15b87 /cad
parent3375c7e1c8055768381e0bdce9373f4ee354da4f (diff)
downloadports-78701c99c11a8ab41f6826bb871259b874ab553f.tar.gz
ports-78701c99c11a8ab41f6826bb871259b874ab553f.zip
cad/csxcad: Change to vtk8 because the app using this library doesn't support vtk9
Diffstat (limited to 'cad')
-rw-r--r--cad/csxcad/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/cad/csxcad/Makefile b/cad/csxcad/Makefile
index a4a96f5c2c21..806fe096b694 100644
--- a/cad/csxcad/Makefile
+++ b/cad/csxcad/Makefile
@@ -2,6 +2,7 @@ PORTNAME= csxcad
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.2-103
DISTVERSIONSUFFIX= -g3c4fb66
+PORTREVISION= 1
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
@@ -11,22 +12,26 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= cgal>0:math/cgal
+# many dependencies below are induced by vtk8, but not vtk9
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfparser-4.5.so:math/fparser \
libgmp.so:math/gmp \
libhdf5.so:science/hdf5 \
libmpfr.so:math/mpfr \
+ libpng16.so:graphics/png \
libsz.so:science/szip \
+ libtiff.so:graphics/tiff \
libtinyxml.so:textproc/tinyxml \
- libvtkCommonMath-9.0.so:math/vtk9
+ libvtkCommonCore-8.2.so:math/vtk8 # some related packages don't support vtk9 yet, see https://github.com/thliebig/QCSXCAD/issues/6#issuecomment-901633240
-USES= cmake pkgconfig
+USES= cmake jpeg pkgconfig
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= thliebig
GH_PROJECT= ${PORTNAME:tu}
-CMAKE_ARGS= -DFPARSER_ROOT_DIR=${LOCALBASE}
+CMAKE_ARGS= -DFPARSER_ROOT_DIR=${LOCALBASE} \
+ -DVTK_DIR=${LOCALBASE}/lib/vtk-8.2/cmake/vtk-8.2
.include <bsd.port.mk>