aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2020-11-28 12:14:26 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2020-11-28 12:14:26 +0000
commitaf23a1452a7977e10224dcc78bd70685b4a13f25 (patch)
tree952d07b27a946e44b1ed110c7d797151a8005a53 /cad
parentdf9a983ca0c3dafd8388af565387c39abebebced (diff)
downloadports-af23a1452a7977e10224dcc78bd70685b4a13f25.tar.gz
ports-af23a1452a7977e10224dcc78bd70685b4a13f25.zip
update freecad to 0.18.5
this intends to fix the addon manager after github infrastructure changes: https://github.com/FreeCAD/FreeCAD/releases/tag/0.18.5
Notes
Notes: svn path=/head/; revision=556488
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile5
-rw-r--r--cad/freecad/distinfo6
-rw-r--r--cad/freecad/files/patch-src_3rdParty_salomesmesh_inc_Rn.h17
-rw-r--r--cad/freecad/files/patch-src_Mod_Part_App_Geometry.cpp165
-rw-r--r--cad/freecad/files/patch-src_Mod_Part_App_PropertyTopoShape.cpp14
5 files changed, 4 insertions, 203 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index d63f01405478..aaa341f5e2b2 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= FreeCAD
-DISTVERSION= 0.18.4
-PORTREVISION= 11
+DISTVERSION= 0.18.5
# use these for bugfixes/snapshots
# DISTVERSION= 0.18-16093 # git rev-list --count
# DISTVERSIONSUFFIX= -g690774c0e
@@ -73,8 +72,6 @@ DESKTOP_ENTRIES=${PORTNAME} "" "${PREFIX}/FreeCAD/data/freecad.svg" \
${PORTNAME} "Graphics;Engineering;" false
post-patch:
- @${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' \
- ${WRKSRC}/src/Gui/CMakeLists.txt
@${REINPLACE_CMD} -e '/self\.rev/s/Unknown/${DISTVERSION:C/.*-//}/' \
${WRKSRC}/src/Tools/SubWCRev.py
diff --git a/cad/freecad/distinfo b/cad/freecad/distinfo
index 74a63535b510..6d4b3ea73ceb 100644
--- a/cad/freecad/distinfo
+++ b/cad/freecad/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1595364680
-SHA256 (FreeCAD-FreeCAD-0.18.4_GH0.tar.gz) = 4e0cce447b31b8989a00cf68c49ae012ce8e5546a56c6e0874fbd8f7ddedffd2
-SIZE (FreeCAD-FreeCAD-0.18.4_GH0.tar.gz) = 219759477
+TIMESTAMP = 1606511424
+SHA256 (FreeCAD-FreeCAD-0.18.5_GH0.tar.gz) = 592c552237effc7a658730718a7f5a94b3819cd7a2f1476a9858c2752a98540a
+SIZE (FreeCAD-FreeCAD-0.18.5_GH0.tar.gz) = 219762319
SHA256 (6eacb17b3e03d20.patch) = 3d2570c143825acd01b8eeb645fc450566e9ac20d6333de9e17cbc10fb5a13e0
SIZE (6eacb17b3e03d20.patch) = 1023
diff --git a/cad/freecad/files/patch-src_3rdParty_salomesmesh_inc_Rn.h b/cad/freecad/files/patch-src_3rdParty_salomesmesh_inc_Rn.h
deleted file mode 100644
index 76c68fcd9419..000000000000
--- a/cad/freecad/files/patch-src_3rdParty_salomesmesh_inc_Rn.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/3rdParty/salomesmesh/inc/Rn.h.orig 2019-10-04 10:14:23 UTC
-+++ src/3rdParty/salomesmesh/inc/Rn.h
-@@ -180,12 +180,12 @@ class R4: public R3
- {
- friend std::ostream& operator <<(std::ostream& f, const R4 & P )
- { f << P.x << ' ' << P.y << ' ' << P.z << ' ' << P.omega; return f; }
-- friend istream& operator >>(istream& f, R4 & P)
-+ friend std::istream& operator >>(std::istream& f, R4 & P)
- { f >> P.x >> P.y >> P.z >> P.omega ; return f; }
-
- friend std::ostream& operator <<(std::ostream& f, const R4 * P )
- { f << P->x << ' ' << P->y << ' ' << P->z << ' ' << P->omega; return f; }
-- friend istream& operator >>(istream& f, R4 * P)
-+ friend std::istream& operator >>(std::istream& f, R4 * P)
- { f >> P->x >> P->y >> P->z >> P->omega ; return f; }
-
- public:
diff --git a/cad/freecad/files/patch-src_Mod_Part_App_Geometry.cpp b/cad/freecad/files/patch-src_Mod_Part_App_Geometry.cpp
deleted file mode 100644
index 2e01b035e612..000000000000
--- a/cad/freecad/files/patch-src_Mod_Part_App_Geometry.cpp
+++ /dev/null
@@ -1,165 +0,0 @@
---- src/Mod/Part/App/Geometry.cpp.orig 2019-10-04 10:23:58 UTC
-+++ src/Mod/Part/App/Geometry.cpp
-@@ -203,7 +203,7 @@ unsigned int Geometry::getMemSize (void) const
- void Geometry::Save(Base::Writer &writer) const
- {
- const char c = Construction?'1':'0';
-- writer.Stream() << writer.ind() << "<Construction value=\"" << c << "\"/>" << endl;
-+ writer.Stream() << writer.ind() << "<Construction value=\"" << c << "\"/>" << std::endl;
- }
-
- void Geometry::Restore(Base::XMLReader &reader)
-@@ -323,7 +323,7 @@ void GeomPoint::Save(Base::Writer &writer) const
- << "X=\"" << Point.x <<
- "\" Y=\"" << Point.y <<
- "\" Z=\"" << Point.z <<
-- "\"/>" << endl;
-+ "\"/>" << std::endl;
- }
-
- void GeomPoint::Restore(Base::XMLReader &reader)
-@@ -793,7 +793,7 @@ void GeomBezierCurve::Save(Base::Writer& writer) const
- << writer.ind()
- << "<BezierCurve "
- << "PolesCount=\"" << poles.size() <<
-- "\">" << endl;
-+ "\">" << std::endl;
-
- writer.incInd();
-
-@@ -808,11 +808,11 @@ void GeomBezierCurve::Save(Base::Writer& writer) const
- "\" Y=\"" << (*itp).y <<
- "\" Z=\"" << (*itp).z <<
- "\" Weight=\"" << (*itw) <<
-- "\"/>" << endl;
-+ "\"/>" << std::endl;
- }
-
- writer.decInd();
-- writer.Stream() << writer.ind() << "</BezierCurve>" << endl ;
-+ writer.Stream() << writer.ind() << "</BezierCurve>" << std::endl ;
- }
-
- void GeomBezierCurve::Restore(Base::XMLReader& reader)
-@@ -1270,7 +1270,7 @@ void GeomBSplineCurve::Save(Base::Writer& writer) cons
- "\" KnotsCount=\"" << knots.size() <<
- "\" Degree=\"" << degree <<
- "\" IsPeriodic=\"" << (int) isperiodic <<
-- "\">" << endl;
-+ "\">" << std::endl;
-
- writer.incInd();
-
-@@ -1285,7 +1285,7 @@ void GeomBSplineCurve::Save(Base::Writer& writer) cons
- "\" Y=\"" << (*itp).y <<
- "\" Z=\"" << (*itp).z <<
- "\" Weight=\"" << (*itw) <<
-- "\"/>" << endl;
-+ "\"/>" << std::endl;
- }
-
- std::vector<double>::const_iterator itk;
-@@ -1297,11 +1297,11 @@ void GeomBSplineCurve::Save(Base::Writer& writer) cons
- << "<Knot "
- << "Value=\"" << (*itk)
- << "\" Mult=\"" << (*itm) <<
-- "\"/>" << endl;
-+ "\"/>" << std::endl;
- }
-
- writer.decInd();
-- writer.Stream() << writer.ind() << "</BSplineCurve>" << endl ;
-+ writer.Stream() << writer.ind() << "</BSplineCurve>" << std::endl ;
- }
-
- void GeomBSplineCurve::Restore(Base::XMLReader& reader)
-@@ -1903,7 +1903,7 @@ void GeomCircle::Save(Base::Writer& writer) const
- "\" NormalZ=\"" << normal.Z() <<
- "\" AngleXU=\"" << AngleXU <<
- "\" Radius=\"" << this->myCurve->Radius() <<
-- "\"/>" << endl;
-+ "\"/>" << std::endl;
- }
-
- void GeomCircle::Restore(Base::XMLReader& reader)
-@@ -2132,7 +2132,7 @@ void GeomArcOfCircle::Save(Base::Writer &writer) const
- "\" Radius=\"" << circle->Radius() <<
- "\" StartAngle=\"" << this->myCurve->FirstParameter() <<
- "\" EndAngle=\"" << this->myCurve->LastParameter() <<
-- "\"/>" << endl;
-+ "\"/>" << std::endl;
- }
-
- void GeomArcOfCircle::Restore(Base::XMLReader &reader)
-@@ -2383,7 +2383,7 @@ void GeomEllipse::Save(Base::Writer& writer) const
- << "MajorRadius=\"" << this->myCurve->MajorRadius() << "\" "
- << "MinorRadius=\"" << this->myCurve->MinorRadius() << "\" "
- << "AngleXU=\"" << AngleXU << "\" "
-- << "/>" << endl;
-+ << "/>" << std::endl;
- }
-
- void GeomEllipse::Restore(Base::XMLReader& reader)
-@@ -2653,7 +2653,7 @@ void GeomArcOfEllipse::Save(Base::Writer &writer) cons
- << "AngleXU=\"" << AngleXU << "\" "
- << "StartAngle=\"" << this->myCurve->FirstParameter() << "\" "
- << "EndAngle=\"" << this->myCurve->LastParameter() << "\" "
-- << "/>" << endl;
-+ << "/>" << std::endl;
- }
-
- void GeomArcOfEllipse::Restore(Base::XMLReader &reader)
-@@ -2826,7 +2826,7 @@ void GeomHyperbola::Save(Base::Writer& writer) const
- << "MajorRadius=\"" << this->myCurve->MajorRadius() << "\" "
- << "MinorRadius=\"" << this->myCurve->MinorRadius() << "\" "
- << "AngleXU=\"" << AngleXU << "\" "
-- << "/>" << endl;
-+ << "/>" << std::endl;
- }
-
- void GeomHyperbola::Restore(Base::XMLReader& reader)
-@@ -3083,7 +3083,7 @@ void GeomArcOfHyperbola::Save(Base::Writer &writer) co
- << "AngleXU=\"" << AngleXU << "\" "
- << "StartAngle=\"" << this->myCurve->FirstParameter() << "\" "
- << "EndAngle=\"" << this->myCurve->LastParameter() << "\" "
-- << "/>" << endl;
-+ << "/>" << std::endl;
- }
-
- void GeomArcOfHyperbola::Restore(Base::XMLReader &reader)
-@@ -3236,7 +3236,7 @@ void GeomParabola::Save(Base::Writer& writer) const
- << "NormalZ=\"" << normal.Z() << "\" "
- << "Focal=\"" << this->myCurve->Focal() << "\" "
- << "AngleXU=\"" << AngleXU << "\" "
-- << "/>" << endl;
-+ << "/>" << std::endl;
- }
-
- void GeomParabola::Restore(Base::XMLReader& reader)
-@@ -3436,7 +3436,7 @@ void GeomArcOfParabola::Save(Base::Writer &writer) con
- << "AngleXU=\"" << AngleXU << "\" "
- << "StartAngle=\"" << this->myCurve->FirstParameter() << "\" "
- << "EndAngle=\"" << this->myCurve->LastParameter() << "\" "
-- << "/>" << endl;
-+ << "/>" << std::endl;
- }
-
- void GeomArcOfParabola::Restore(Base::XMLReader &reader)
-@@ -3581,7 +3581,7 @@ void GeomLine::Save(Base::Writer &writer) const
- "\" DirX=\"" << Dir.x <<
- "\" DirY=\"" << Dir.y <<
- "\" DirZ=\"" << Dir.z <<
-- "\"/>" << endl;
-+ "\"/>" << std::endl;
- }
- void GeomLine::Restore(Base::XMLReader &reader)
- {
-@@ -3722,7 +3722,7 @@ void GeomLineSegment::Save (Base::Writer &writer
- "\" EndX=\"" << End.x <<
- "\" EndY=\"" << End.y <<
- "\" EndZ=\"" << End.z <<
-- "\"/>" << endl;
-+ "\"/>" << std::endl;
- }
-
- void GeomLineSegment::Restore (Base::XMLReader &reader)
diff --git a/cad/freecad/files/patch-src_Mod_Part_App_PropertyTopoShape.cpp b/cad/freecad/files/patch-src_Mod_Part_App_PropertyTopoShape.cpp
deleted file mode 100644
index 7ee47384c839..000000000000
--- a/cad/freecad/files/patch-src_Mod_Part_App_PropertyTopoShape.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/Mod/Part/App/PropertyTopoShape.cpp.orig 2019-10-04 10:26:07 UTC
-+++ src/Mod/Part/App/PropertyTopoShape.cpp
-@@ -281,9 +281,9 @@ static void BRepTools_Write(const TopoDS_Shape& Sh, St
- static Standard_Boolean BRepTools_Write(const TopoDS_Shape& Sh,
- const Standard_CString File)
- {
-- ofstream os;
-+ std::ofstream os;
- #if OCC_VERSION_HEX >= 0x060800
-- OSD_OpenStream(os, File, ios::out);
-+ OSD_OpenStream(os, File, std::ios::out);
- #else
- os.open(File, ios::out);
- #endif