aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /cad
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/geda-gattrib/Makefile2
-rw-r--r--cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c28
2 files changed, 29 insertions, 1 deletions
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
index fd903e379cac..16a6e27adad4 100644
--- a/cad/geda-gattrib/Makefile
+++ b/cad/geda-gattrib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gattrib
PORTVERSION= 1.4.3
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
diff --git a/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c b/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c
new file mode 100644
index 000000000000..29d2ae56b635
--- /dev/null
+++ b/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c
@@ -0,0 +1,28 @@
+--- src/gtkitementry_2_2.c.orig 2010-10-29 19:10:42.000000000 +0200
++++ src/gtkitementry_2_2.c 2010-10-29 19:11:29.000000000 +0200
+@@ -156,7 +156,7 @@ static void gtk_entry_draw_curso
+ static PangoLayout *gtk_entry_ensure_layout (GtkEntry *entry,
+ gboolean include_preedit);
+ static void gtk_entry_queue_draw (GtkEntry *entry);
+-static void gtk_entry_reset_im_context (GtkEntry *entry);
++//static void gtk_entry_reset_im_context (GtkEntry *entry);
+ static void gtk_entry_recompute (GtkEntry *entry);
+ static void gtk_entry_get_cursor_locations (GtkEntry *entry,
+ CursorType type,
+@@ -1830,16 +1830,6 @@ gtk_entry_queue_draw (GtkEntry *entry)
+ }
+
+ static void
+-gtk_entry_reset_im_context (GtkEntry *entry)
+-{
+- if (entry->need_im_reset)
+- {
+- entry->need_im_reset = 0;
+- gtk_im_context_reset (entry->im_context);
+- }
+-}
+-
+-static void
+ gtk_entry_get_cursor_locations (GtkEntry *entry,
+ CursorType type,
+ gint *strong_x,