aboutsummaryrefslogtreecommitdiff
path: root/chinese/CJKUnifonts/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-02-19 13:51:50 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-02-19 13:51:50 +0000
commitaadd0f3a5f2ad007d555aacb1928190b7589aaaf (patch)
tree104a3c7a9e42ff9be3b7e0939521876cfb8f9126 /chinese/CJKUnifonts/Makefile
parentdb1ca4d8d20ce4e16ed1c65f240f10e76fc1ab9c (diff)
downloadports-aadd0f3a5f2ad007d555aacb1928190b7589aaaf.tar.gz
ports-aadd0f3a5f2ad007d555aacb1928190b7589aaaf.zip
Notes
Diffstat (limited to 'chinese/CJKUnifonts/Makefile')
-rw-r--r--chinese/CJKUnifonts/Makefile23
1 files changed, 6 insertions, 17 deletions
diff --git a/chinese/CJKUnifonts/Makefile b/chinese/CJKUnifonts/Makefile
index f335dbe372ad..a89673a132bd 100644
--- a/chinese/CJKUnifonts/Makefile
+++ b/chinese/CJKUnifonts/Makefile
@@ -16,27 +16,16 @@ DISTFILES= ttf-arphic-uming_0.0.20041031-1.tar.gz \
MAINTAINER= statue@freebsd.netlab.cse.yzu.edu.tw
COMMENT= Arne TrueType Font is combine of arphic ming and kai fonts
-BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- ttfm.sh:${PORTSDIR}/chinese/ttfm
-RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- ttfm.sh:${PORTSDIR}/chinese/ttfm
-
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_XLIB= yes
-FONTDIR= ${PREFIX}/share/fonts/TrueType
-XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
-.include <bsd.port.pre.mk>
+TTF= ukai.ttf uming.ttf
do-install:
- @${MKDIR} ${FONTDIR}
- @${INSTALL_DATA} ${WRKSRC}/ttf-arphic-ukai-0.0.20041031/ukai.ttf ${FONTDIR}
- @${INSTALL_DATA} ${WRKSRC}/ttf-arphic-uming-0.0.20041031/uming.ttf ${FONTDIR}
- @${ECHO_MSG} "===> Running ttfm.sh"
- -@${PREFIX}/bin/ttfm.sh --add xttfm ukai.ttf
- -@${PREFIX}/bin/ttfm.sh --add xttfm uming.ttf
- @${ECHO_MSG} "===> Running fc-cache"
- -@${X11BASE}/bin/fc-cache -f -v ${XFONTDIR}
+ @${MKDIR} ${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ttf-arphic-ukai-0.0.20041031/ukai.ttf ${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ttf-arphic-uming-0.0.20041031/uming.ttf ${FONTSDIR}
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/chinese/ttfm/Makefile.ttf"
.include <bsd.port.post.mk>