aboutsummaryrefslogtreecommitdiff
path: root/chinese/XFree86-aoutlibs
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2000-11-02 06:59:37 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2000-11-02 06:59:37 +0000
commit84fe7cc5aca35f4dd933b91dce1752f415e6f908 (patch)
tree41549401c90dcf33b10c3734675f1e48b9b0743d /chinese/XFree86-aoutlibs
parent33c487216376b6926ccfc5aeaa337a608eae292b (diff)
downloadports-84fe7cc5aca35f4dd933b91dce1752f415e6f908.tar.gz
ports-84fe7cc5aca35f4dd933b91dce1752f415e6f908.zip
Notes
Diffstat (limited to 'chinese/XFree86-aoutlibs')
-rw-r--r--chinese/XFree86-aoutlibs/Makefile47
-rw-r--r--chinese/XFree86-aoutlibs/distinfo1
-rw-r--r--chinese/XFree86-aoutlibs/files/INSTALL.in17
-rw-r--r--chinese/XFree86-aoutlibs/pkg-comment1
-rw-r--r--chinese/XFree86-aoutlibs/pkg-descr5
-rw-r--r--chinese/XFree86-aoutlibs/pkg-plist16
-rw-r--r--chinese/XFree86-aoutlibs/pkg-req22
7 files changed, 109 insertions, 0 deletions
diff --git a/chinese/XFree86-aoutlibs/Makefile b/chinese/XFree86-aoutlibs/Makefile
new file mode 100644
index 000000000000..2bac8d2e96b5
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: XFree86 3.3.6 aout libs
+# Date created: 31 Oct 2000
+# Whom: Jing-Tang Keith Jang <keith@freebsd.sinica.edu.tw>
+#
+# $FreeBSD: /tmp/pcvs/ports/chinese/XFree86-aoutlibs/Attic/Makefile,v 1.1 2000-11-02 06:59:33 foxfair Exp $
+#
+
+# The file is identical to
+# ftp://ftp.xfree86.org/pub/XFree86/3.3.6/binaries/FreeBSD-2.2.x/Xbin.tgz
+# Renamed to avoid distfiles conflict with x11/XFree86-aoutlibs.
+
+PORTNAME= XFree86-aoutlibs
+PORTVERSION= 3.3.6
+CATEGORIES= x11
+MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
+DISTNAME= Xbin336aout
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= keith@freebsd.sinica.edu.tw
+
+ONLY_FOR_ARCHS= i386
+
+WRKSRC= ${WRKDIR}/lib
+NO_BUILD= yes
+PORTOBJFORMAT= aout
+
+USE_X_PREFIX= yes
+PKGINSTALL= ${WRKDIR}/pkg-install
+
+pre-configure:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
+ @${SED} -e "s;@PREFIX@;${PREFIX};g" ${FILESDIR}/INSTALL.in > ${WRKDIR}/pkg-install
+
+pre-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/aout
+ cd ${WRKSRC}; \
+ for l in $$(ls lib*); do \
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} \
+ ${INSTALL_PROGRAM} $$l ${PREFIX}/lib/aout; \
+ done
+ ${TOUCH} ${PREFIX}/lib/aout/zh-XFree86-aoutlibs-3.3.6
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib/aout
+
+.include <bsd.port.mk>
diff --git a/chinese/XFree86-aoutlibs/distinfo b/chinese/XFree86-aoutlibs/distinfo
new file mode 100644
index 000000000000..11d33628b4d1
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/distinfo
@@ -0,0 +1 @@
+MD5 (Xbin336aout.tgz) = a788bf7af2732eaf2a4a71550680f590
diff --git a/chinese/XFree86-aoutlibs/files/INSTALL.in b/chinese/XFree86-aoutlibs/files/INSTALL.in
new file mode 100644
index 000000000000..9af384c65b2f
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/files/INSTALL.in
@@ -0,0 +1,17 @@
+#!/bin/sh
+# an installation script for zh-XFree86-aoutlibs
+
+if [ "$2" != "PRE-INSTALL" ]; then
+ exit 0
+fi
+
+if [ ! -f @PREFIX@/lib/aout/zh-XFree86-aoutlibs-3.3.6 ] && \
+ [ -f @PREFIX@/lib/aout/libX11.so.6.1 ]; then
+ echo ----------------------------------------------------
+ echo You have XFree86-aoutlibs installed!
+ echo Please remove it before install zh-XFree86-aoutlibs.
+ echo ----------------------------------------------------
+ exit 1
+fi
+
+exit 0
diff --git a/chinese/XFree86-aoutlibs/pkg-comment b/chinese/XFree86-aoutlibs/pkg-comment
new file mode 100644
index 000000000000..0f6809217769
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/pkg-comment
@@ -0,0 +1 @@
+Chinese XFree86 a.out compatability libraries
diff --git a/chinese/XFree86-aoutlibs/pkg-descr b/chinese/XFree86-aoutlibs/pkg-descr
new file mode 100644
index 000000000000..cc3729bf95c3
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/pkg-descr
@@ -0,0 +1,5 @@
+This is a compatability package for the XFree86 a.out format libraries,
+especially for Chinese application.
+
+It is only needed for ports which use X and are compiled in a.out format,
+such as Nescape. Long live Mozilla...
diff --git a/chinese/XFree86-aoutlibs/pkg-plist b/chinese/XFree86-aoutlibs/pkg-plist
new file mode 100644
index 000000000000..402784dc0f76
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/pkg-plist
@@ -0,0 +1,16 @@
+lib/aout/libX11.so.6.1
+lib/aout/liboldX.so.6.0
+lib/aout/libICE.so.6.3
+lib/aout/libSM.so.6.0
+lib/aout/libXext.so.6.3
+lib/aout/libXt.so.6.0
+lib/aout/libXmu.so.6.0
+lib/aout/libXaw.so.6.1
+lib/aout/libXIE.so.6.0
+lib/aout/libXi.so.6.0
+lib/aout/libXtst.so.6.1
+lib/aout/libPEX5.so.6.0
+lib/aout/libXp.so.6.2
+lib/aout/zh-XFree86-aoutlibs-3.3.6
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
diff --git a/chinese/XFree86-aoutlibs/pkg-req b/chinese/XFree86-aoutlibs/pkg-req
new file mode 100644
index 000000000000..aabd9bc76fbe
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/pkg-req
@@ -0,0 +1,22 @@
+#!/bin/sh
+env=/usr/bin/env
+fgrep=/usr/bin/fgrep
+ldconfig=/sbin/ldconfig
+ld_so=/usr/libexec/ld.so
+if [ x$2 = xINSTALL ]; then
+ $env OBJFORMAT=aout $ldconfig -r | $fgrep -q -e '-lc.3'
+ if [ $? -ne 0 -o ! -x $ld_so ]; then
+ cat <<END
+*********************************************************************
+
+ There do not appear to be any a.out libraries on this
+ machine. Please install the compat22 distribution (via
+ /stand/sysinstall) or build it as part of your 'make world'
+ (see /etc/make.conf).
+
+*********************************************************************
+END
+ exit 1
+ fi
+fi
+exit 0;