aboutsummaryrefslogtreecommitdiff
path: root/chinese/arphicttf/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-04-01 01:47:09 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-04-01 01:47:09 +0000
commitada2c72a1253d23fb9adf561cbd09dd5be94377d (patch)
tree574e1b3af7d7ce567e718b52956392dccd7b7602 /chinese/arphicttf/Makefile
parent27f31dd7eee7acd9b885975a6fb2bf5ad380bc65 (diff)
downloadports-ada2c72a1253d23fb9adf561cbd09dd5be94377d.tar.gz
ports-ada2c72a1253d23fb9adf561cbd09dd5be94377d.zip
Notes
Diffstat (limited to 'chinese/arphicttf/Makefile')
-rw-r--r--chinese/arphicttf/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/chinese/arphicttf/Makefile b/chinese/arphicttf/Makefile
index 299f0bac4f52..51ca0429c148 100644
--- a/chinese/arphicttf/Makefile
+++ b/chinese/arphicttf/Makefile
@@ -24,14 +24,10 @@ USE_XLIB= yes
FONTDIR= ${PREFIX}/share/fonts/TrueType
XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
INSTALL_ENV= PKG_PREFIX=${PREFIX} XFREE86_VERSION=${XFREE86_VERSION} \
- WANT_CJK=${WANT_CJK} WANT_GS=${WANT_GS} \
- WITHOUT_X=${WITHOUT_X}
+ WANT_GS=${WANT_GS} WITHOUT_X=${WITHOUT_X}
.include <bsd.port.pre.mk>
-.if defined(WANT_CJK)
-RUN_DEPENDS+= bg5latex:${PORTSDIR}/chinese/CJK
-.endif
.if defined(WANT_GS)
RUN_DEPENDS+= ${LOCALBASE}/share/ghostscript/Resource/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps
.endif
@@ -40,18 +36,14 @@ RUN_DEPENDS+= mkfontdir.pl:${PORTSDIR}/x11-servers/XttXF86srv-common
.endif
pre-fetch:
-.if defined(WANT_CJK)
- @${ECHO} "CJK support will be added."
-.endif
.if defined(WANT_GS)
@${ECHO} "Ghostscript support will be added."
.endif
.if defined(WITHOUT_X)
@${ECHO} "X Window support will NOT be added."
.endif
-.if !defined(WANT_CJK) && !defined(WANT_GS) && !defined(WITHOUT_X)
+.if !defined(WANT_GS) && !defined(WITHOUT_X)
@${ECHO} --
- @${ECHO} "Type \"make WANT_CJK=yes\" if you want CJK support."
@${ECHO} "Type \"make WANT_GS=yes\" if you want Ghostscript support."
@${ECHO} "Type \"make WITHOUT_X=yes\" if you DONT want X Window support."
@${ECHO} "You can use them in combinations."
@@ -59,9 +51,7 @@ pre-fetch:
.endif
do-install:
-.if !exists(${FONTDIR})
@${MKDIR} ${FONTDIR}
-.endif
@${INSTALL_DATA} ${WRKSRC}/font/bkai00mp.ttf ${FONTDIR}
@${INSTALL_DATA} ${WRKSRC}/font/bsmi00lp.ttf ${FONTDIR}
@${INSTALL_DATA} ${WRKSRC}/font/gbsn00lp.ttf ${FONTDIR}