aboutsummaryrefslogtreecommitdiff
path: root/chinese/autoconvert
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-09-27 12:33:07 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-09-27 12:33:07 +0000
commita669028f9db41c6d39f70c2081b5ae28aa84f8c5 (patch)
tree03ffd4f181901ad6c3673e7126e8e6990776731a /chinese/autoconvert
parent2282dc8a52363dde64f0919a23c24a0bda56c190 (diff)
downloadports-a669028f9db41c6d39f70c2081b5ae28aa84f8c5.tar.gz
ports-a669028f9db41c6d39f70c2081b5ae28aa84f8c5.zip
Notes
Diffstat (limited to 'chinese/autoconvert')
-rw-r--r--chinese/autoconvert/Makefile5
-rw-r--r--chinese/autoconvert/files/patch-Makefile25
-rw-r--r--chinese/autoconvert/files/patch-autogb.c16
3 files changed, 32 insertions, 14 deletions
diff --git a/chinese/autoconvert/Makefile b/chinese/autoconvert/Makefile
index 418bbcbaaa50..9cbbb1cd24cc 100644
--- a/chinese/autoconvert/Makefile
+++ b/chinese/autoconvert/Makefile
@@ -24,7 +24,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PROJECTHOST= libhz
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -32,8 +31,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ChangeLog Readme TODO Thanks Version ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ChangeLog Readme TODO Thanks Version ${STAGEDIR}/${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/chinese/autoconvert/files/patch-Makefile b/chinese/autoconvert/files/patch-Makefile
index 7a9835ec224b..ef3da271cf9f 100644
--- a/chinese/autoconvert/files/patch-Makefile
+++ b/chinese/autoconvert/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig 2001-04-28 09:45:46.000000000 +0800
-+++ Makefile 2010-06-30 10:13:29.000000000 +0800
-@@ -1,7 +1,6 @@
++++ Makefile 2013-09-27 20:16:44.000000000 +0800
+@@ -1,11 +1,10 @@
-CC=gcc
-CFLAG=-O2 -g -Wall -Iinclude
@@ -10,7 +10,12 @@
.PHONY: all hzlib clean install-home install
-@@ -30,12 +29,11 @@ install-home:
+-all: autob5 autogb hzlib xchat-plugins
++all: autob5 autogb hzlib
+
+ autob5: autogb
+ rm -f autob5;ln -s autogb autob5
+@@ -30,12 +29,9 @@ install-home:
ln -s $(HOME)/bin/autogb $(HOME)/bin/autob5
chmod 755 $(HOME)/bin/autogb
install:
@@ -23,11 +28,9 @@
- install -m 755 contrib/xchat-plugins/xchat-autob5.so $(DESTDIR)/usr/share/zh-autoconvert
- install -m 644 include/*.h $(DESTDIR)/usr/include
- ln -s autogb $(DESTDIR)/usr/bin/autob5
-+ ${BSD_INSTALL_PROGRAM} autogb $(PREFIX)/bin
-+ ${BSD_INSTALL_PROGRAM} lib/libhz.so.0.0 $(PREFIX)/lib/libhz.so.0
-+ cd $(PREFIX)/lib;ln -s libhz.so.0 libhz.so
-+ ${BSD_INSTALL_PROGRAM} lib/libhz.a $(PREFIX)/lib
-+ #${BSD_INSTALL_PROGRAM} contrib/xchat-plugins/xchat-autogb.so $(PREFIX)/share/autoconvert
-+ #${BSD_INSTALL_PROGRAM} contrib/xchat-plugins/xchat-autob5.so $(PREFIX)/share/autoconvert
-+ ${BSD_INSTALL_DATA} include/*.h $(PREFIX)/include
-+ ln -s autogb $(PREFIX)/bin/autob5
++ ${BSD_INSTALL_PROGRAM} autogb $(DESTDIR)/$(PREFIX)/bin
++ ${BSD_INSTALL_PROGRAM} lib/libhz.so.0.0 $(DESTDIR)/$(PREFIX)/lib/libhz.so.0
++ ln -sf libhz.so.0 $(DESTDIR)/$(PREFIX)//lib/libhz.so
++ ${BSD_INSTALL_PROGRAM} lib/libhz.a $(DESTDIR)/$(PREFIX)/lib
++ ${BSD_INSTALL_DATA} include/*.h $(DESTDIR)/$(PREFIX)/include
++ ln -sf autogb $(DESTDIR)/$(PREFIX)/bin/autob5
diff --git a/chinese/autoconvert/files/patch-autogb.c b/chinese/autoconvert/files/patch-autogb.c
new file mode 100644
index 000000000000..87c2b617d718
--- /dev/null
+++ b/chinese/autoconvert/files/patch-autogb.c
@@ -0,0 +1,16 @@
+--- autogb.c.orig 2013-09-27 20:12:01.000000000 +0800
++++ autogb.c 2013-09-27 20:13:53.000000000 +0800
+@@ -26,9 +26,13 @@ Boston, MA 02111-1307, USA.
+ //$Header: /home/prog/autoconvert/autogb.c,v 1.7 2001/04/23 14:18:06 ygh Exp $
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <string.h>
+ #include <getopt.h>
+ #include "hz.h"
+
++extern int conv_str(char *);
+
+ /* Print help and exit */
+ void print_help(char* filename){