aboutsummaryrefslogtreecommitdiff
path: root/chinese/bg5ps/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-11-03 12:26:53 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-11-03 12:26:53 +0000
commit61e8aea7691cb1dcfb502d98852f4fc16476ee38 (patch)
tree4587cd1f447c5fd2b3e3074834d86eaad89f12b3 /chinese/bg5ps/Makefile
parentea54652533c7b2d5f3c338e7f28a621f7b7d4afa (diff)
Notes
Diffstat (limited to 'chinese/bg5ps/Makefile')
-rw-r--r--chinese/bg5ps/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/chinese/bg5ps/Makefile b/chinese/bg5ps/Makefile
index d60eefae2a6e..c2ac33a85e31 100644
--- a/chinese/bg5ps/Makefile
+++ b/chinese/bg5ps/Makefile
@@ -1,23 +1,21 @@
# New ports collection makefile for: bg5ps
# Date created: 17 June 1998
-# Whom: J.T. Jang (keith@freebsd.sinica.edu.tw)
+# Whom: Jing-Tang Keith Jang <keith@freebsd.sinica.edu.tw>
#
# $FreeBSD$
#
PORTNAME= bg5ps
-PORTVERSION= 1.1b2
+PORTVERSION= 1.3.0p3
CATEGORIES= chinese print
-MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/ \
- http://students.washington.edu/~cschin/bg5ps/bg5ps-1.1b2/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
+DISTNAME= bg5ps-1.3.0
MAINTAINER= keith@freebsd.sinica.edu.tw
-RUN_DEPENDS= python:${PORTSDIR}/lang/python \
- ${X11BASE}/lib/X11/fonts/TrueType/moe_kai.ttf:${PORTSDIR}/chinese/moettf
-
-NO_WRKSUBDIR= yes
+USE_GMAKE= yes
+USE_FREETYPE= yes
+USE_PYTHON= yes
do-install:
@${MKDIR} ${PREFIX}/share/doc/bg5ps
@@ -25,10 +23,11 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bg5ps ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/ttf2psm ${PREFIX}/bin
${CP} -R ${WRKSRC}/doc/* ${PREFIX}/share/doc/bg5ps
- ${RM} ${PREFIX}/share/doc/bg5ps/COPYING.txt
- ${INSTALL_DATA} ${WRKSRC}/bg5ps.conf ${PREFIX}/share/doc/bg5ps/bg5ps.conf
+ ${INSTALL_DATA} ${WRKSRC}/bg5ps.conf ${PREFIX}/etc/bg5ps.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/gb2312-bg5ps.conf ${PREFIX}/etc/gb2312-bg5ps.conf.sample
${INSTALL_DATA} ${WRKSRC}/examples/netscape.ps ${PREFIX}/share/examples/bg5ps
${INSTALL_DATA} ${WRKSRC}/examples/test.big5 ${PREFIX}/share/examples/bg5ps
+ ${INSTALL_DATA} ${WRKSRC}/examples/test.gb2312 ${PREFIX}/share/examples/bg5ps
${INSTALL_SCRIPT} ${WRKSRC}/examples/test.sh ${PREFIX}/share/examples/bg5ps
post-install: