aboutsummaryrefslogtreecommitdiff
path: root/chinese/cless
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1996-10-26 23:20:37 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1996-10-26 23:20:37 +0000
commitb96fdde46afdfd1d96d4ac0a38aec91dc4f8f2be (patch)
tree00dd2044d56853aff785354c8100ef34f29c8f7b /chinese/cless
parent7716a3131dfa814dec09d9647eed25b1a043ca79 (diff)
downloadports-b96fdde46afdfd1d96d4ac0a38aec91dc4f8f2be.tar.gz
ports-b96fdde46afdfd1d96d4ac0a38aec91dc4f8f2be.zip
The less pager capable of Chinese.
Submitted by: David O'Brien (obrien@cs.ucdavis.edu) (Closing PR #1620.)
Notes
Notes: svn path=/head/; revision=4165
Diffstat (limited to 'chinese/cless')
-rw-r--r--chinese/cless/Makefile32
-rw-r--r--chinese/cless/distinfo1
-rw-r--r--chinese/cless/files/patch-aa38
-rw-r--r--chinese/cless/files/patch-ab13
-rw-r--r--chinese/cless/files/patch-ac433
-rw-r--r--chinese/cless/files/patch-ad103
-rw-r--r--chinese/cless/pkg-comment1
-rw-r--r--chinese/cless/pkg-descr15
-rw-r--r--chinese/cless/pkg-plist8
9 files changed, 644 insertions, 0 deletions
diff --git a/chinese/cless/Makefile b/chinese/cless/Makefile
new file mode 100644
index 000000000000..0d242cd8904b
--- /dev/null
+++ b/chinese/cless/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: cless
+# Version required: 2.90
+# Date created: Sat Aug 10, 1996
+# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+#
+# $Id: Makefile,v 1.1.1.1 1996/08/09 04:17:16 asami Exp $
+#
+
+DISTNAME= cless-290
+CATEGORIES+= chinese misc
+MASTER_SITES= ftp://ftp.ifcss.org/pub/software/unix/c-utils/ \
+ ftp://ftp.cuhk.hk/pub/chinese/ifcss/software/unix/c-utils/ \
+ ftp://ftp.edu.tw/Chinese/ifcss/software/unix/c-utils/ \
+ ftp://ftp.mpi-sb.mpg.de/pub/chinese/mirror/ftp.ifcss.org/software/unix/c-utils/
+
+MAINTAINER= obrien@cs.ucdavis.edu
+
+GNU_CONFIGURE= yes
+CFLAGS+= -DHANZI # LDFLAGS=-s datadir=/usr/local/lib/less
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+.for mp in cless clesskey
+ gzip -9nf ${PREFIX}/man/man1/${mp}.1
+.endfor
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} -p ${PREFIX}/share/doc/cless
+ ${INSTALL_DATA} ${WRKSRC}/README.CLESS ${PREFIX}/share/doc/cless
+.endif
+
+.include <bsd.port.mk>
diff --git a/chinese/cless/distinfo b/chinese/cless/distinfo
new file mode 100644
index 000000000000..fa829919e6bc
--- /dev/null
+++ b/chinese/cless/distinfo
@@ -0,0 +1 @@
+MD5 (cless-290.tar.gz) = 6d0bc5915da08c7f81bf650f59f54697
diff --git a/chinese/cless/files/patch-aa b/chinese/cless/files/patch-aa
new file mode 100644
index 000000000000..9a51393614e6
--- /dev/null
+++ b/chinese/cless/files/patch-aa
@@ -0,0 +1,38 @@
+--- Makefile.in.orig Mon Apr 24 19:41:39 1995
++++ Makefile.in Sun Sep 15 22:55:52 1996
+@@ -73,24 +73,24 @@
+ ${OBJ}: less.h defines.h funcs.h
+
+ filename.${O}: filename.c
+- ${CC} -c -DHELPFILE=\"${datadir}/less.hlp\" -I. ${CPPFLAGS} ${CFLAGS} ${srcdir}/filename.c
++ ${CC} -c -DHELPFILE=\"${datadir}/cless.gb\" -I. ${CPPFLAGS} ${CFLAGS} ${srcdir}/filename.c
+
+ install: all less.hlp less.bg5 less.gb less.nro installdirs
+- ${INSTALL_PROGRAM} less ${bindir}/${binprefix}less
+- ${INSTALL_PROGRAM} lesskey ${bindir}/${binprefix}lesskey
+- ${INSTALL_DATA} ${srcdir}/less.hlp ${datadir}/less.hlp
+- ${INSTALL_DATA} ${srcdir}/less.bg5 ${datadir}/less.bg5
+- ${INSTALL_DATA} ${srcdir}/less.gb ${datadir}/less.gb
+- ${INSTALL_DATA} ${srcdir}/less.nro ${mandir}/${manprefix}less.${manext}
+- ${INSTALL_DATA} ${srcdir}/lesskey.nro ${mandir}/${manprefix}lesskey.${manext}
++ ${INSTALL_PROGRAM} less ${bindir}/${binprefix}cless
++ ${INSTALL_PROGRAM} lesskey ${bindir}/${binprefix}clesskey
++ ${INSTALL_DATA} ${srcdir}/less.hlp ${datadir}/cless.hlp
++ ${INSTALL_DATA} ${srcdir}/less.bg5 ${datadir}/cless.bg5
++ ${INSTALL_DATA} ${srcdir}/less.gb ${datadir}/cless.gb
++ ${INSTALL_DATA} ${srcdir}/less.nro ${mandir}/${manprefix}cless.${manext}
++ ${INSTALL_DATA} ${srcdir}/lesskey.nro ${mandir}/${manprefix}clesskey.${manext}
+
+ installdirs: mkinstalldirs
+ ${srcdir}/mkinstalldirs ${bindir} ${datadir} ${mandir}
+
+ uninstall:
+- rm -f ${bindir}/${binprefix}less ${bindir}/${binprefix}lesskey
+- rm -f ${datadir}/less.hlp ${datadir}/less.bg5 ${datadir}/less.gb
+- rm -f ${mandir}/less.${manext} ${mandir}/lesskey.${manext}
++ rm -f ${bindir}/${binprefix}cless ${bindir}/${binprefix}clesskey
++ rm -f ${datadir}/cless.hlp ${datadir}/cless.bg5 ${datadir}/cless.gb
++ rm -f ${mandir}/cless.${manext} ${mandir}/clesskey.${manext}
+
+ info:
+ install-info:
diff --git a/chinese/cless/files/patch-ab b/chinese/cless/files/patch-ab
new file mode 100644
index 000000000000..a0a2546b730e
--- /dev/null
+++ b/chinese/cless/files/patch-ab
@@ -0,0 +1,13 @@
+--- defines.h.in.orig Sun Sep 15 22:58:20 1996
++++ defines.h.in Sun Sep 15 22:58:27 1996
+@@ -104,8 +104,8 @@
+ * DEF_LESSKEYINFILE is the filename of the default lesskey input
+ * (in the HOME directory).
+ */
+-#define LESSKEYFILE ".less"
+-#define DEF_LESSKEYINFILE ".lesskey"
++#define LESSKEYFILE ".cless"
++#define DEF_LESSKEYINFILE ".clesskey"
+
+
+ /* Settings always true on Unix. */
diff --git a/chinese/cless/files/patch-ac b/chinese/cless/files/patch-ac
new file mode 100644
index 000000000000..a856abf073d1
--- /dev/null
+++ b/chinese/cless/files/patch-ac
@@ -0,0 +1,433 @@
+--- less.nro.orig Sun Sep 15 23:00:49 1996
++++ less.nro Sun Sep 15 23:06:46 1996
+@@ -1,12 +1,12 @@
+ .TH LESS 1
+ .SH NAME
+-less \- opposite of more
++cless \- opposite of more
+ .SH SYNOPSIS
+-.B "less -?"
++.B "cless -?"
+ .br
+-.B "less -V"
++.B "cless -V"
+ .br
+-.B "less [-[+]aBcCdeEfgGiImMnNqQrsSuUVwX]"
++.B "cless [-[+]aBcCdeEfgGiImMnNqQrsSuUVwX]"
+ .br
+ .B " [-b \fIbufs\fP] [-h \fIlines\fP] [-j \fIline\fP] [-k \fIkeyfile\fP]"
+ .br
+@@ -23,7 +23,7 @@
+ (1), but which allows backward movement
+ in the file as well as forward movement.
+ Also,
+-.I less
++.I cless
+ does not have to read the entire input file before starting,
+ so with large input files it starts up faster than text editors like
+ .I vi
+@@ -114,7 +114,7 @@
+ Go to a position N percent into the file.
+ N should be between 0 and 100.
+ (This works if standard input is being read, but only if
+-.I less
++.I cless
+ has already read to the end of the file.
+ It is always fast, but not always useful.)
+ .PP
+@@ -329,18 +329,18 @@
+ .IP +cmd
+ Causes the specified cmd to be executed each time a new file is examined.
+ For example, +G causes
+-.I less
++.I cless
+ to initially display each file starting at the end
+ rather than the beginning.
+ .PP
+ .IP V
+ Prints the version number of
+-.I less
++.I cless
+ being run.
+ .PP
+ .IP "q or :q or :Q or ZZ"
+ Exits
+-.I less.
++.I cless.
+ .PP
+ The following
+ three
+@@ -374,13 +374,13 @@
+ .SH OPTIONS
+ Command line options are described below.
+ Most options may be changed while
+-.I less
++.I cless
+ is running, via the "\-" command.
+ .PP
+ Options are also taken from the environment variable "LESS".
+ For example,
+-to avoid typing "less -options ..." each time
+-.I less
++to avoid typing "cless -options ..." each time
++.I cless
+ is invoked, you might tell
+ .I csh:
+ .sp
+@@ -402,10 +402,10 @@
+ following string.
+ .IP -?
+ This option displays a summary of the commands accepted by
+-.I less
++.I cless
+ (the same as the h command).
+ If this option is given, all other options are ignored, and
+-.I less
++.I cless
+ exits after the help screen is viewed.
+ (Depending on how your shell interprets the question mark,
+ it may be necessary to quote the question mark, thus: "-\\?".)
+@@ -417,7 +417,7 @@
+ (or after the last found line; see the -j option).
+ .IP -b\fIn\fP
+ Specifies the number of buffers
+-.I less
++.I cless
+ will use for each file.
+ Buffers are 1K, and by default 10 buffers are used for each file
+ (except if the file is a pipe; see the -B option).
+@@ -444,7 +444,7 @@
+ that is, lacks some important capability,
+ such as the ability to clear the screen or scroll backward.
+ The -d option does not otherwise change the behavior of
+-.I less
++.I cless
+ on a dumb terminal).
+ .IP -D\fBx\fP\fIcolor\fP
+ [MS-DOS only]
+@@ -457,31 +457,31 @@
+ A single number \fIN\fP is the same as \fIN.0\fP.
+ .IP -e
+ Causes
+-.I less
++.I cless
+ to automatically exit
+ the second time it reaches end-of-file.
+ By default, the only way to exit
+-.I less
++.I cless
+ is via the "q" command.
+ .IP -E
+ Causes
+-.I less
++.I cless
+ to automatically exit the first time it reaches end-of-file.
+ .IP -f
+ Forces non-regular files to be opened.
+ (A non-regular file is a directory or a device special file.)
+ Also suppresses the warning message when a binary file is opened.
+ By default,
+-.I less
++.I cless
+ will refuse to open non-regular files.
+ .IP -g
+ Normally,
+-.I less
++.I cless
+ will highlight ALL strings which match the last search command.
+ The -g flag changes this behavior to highlight only the particular string
+ which was found by the last search command.
+ This can cause
+-.I less
++.I cless
+ to run somewhat faster than the default.
+ .IP -G
+ The -G flag suppresses all highlighting of strings found by search commands.
+@@ -519,32 +519,32 @@
+ on the screen.
+ .IP -k\fIfilename\fP
+ Causes
+-.I less
++.I cless
+ to open and interpret the named file as a
+-.I lesskey
++.I clesskey
+ (1) file.
+ Multiple -k options may be specified.
+-If a file called .less exists in the user's home directory, this
++If a file called .cless exists in the user's home directory, this
+ file is also used as a
+-.I lesskey
++.I clesskey
+ file.
+ .IP -m
+ Causes
+-.I less
++.I cless
+ to prompt verbosely (like \fImore\fP),
+ with the percent into the file.
+ By default,
+-.I less
++.I cless
+ prompts with a colon.
+ .IP -M
+ Causes
+-.I less
++.I cless
+ to prompt even more verbosely than
+ .I more.
+ .IP -n
+ Suppresses line numbers.
+ The default (to use line numbers) may cause
+-.I less
++.I cless
+ to run more slowly in some cases, especially with a very large input file.
+ Suppressing line numbers with the -n flag will avoid this problem.
+ Using line numbers means: the line number will be displayed in the verbose
+@@ -556,12 +556,12 @@
+ each line in the display.
+ .IP -o\fIfilename\fP
+ Causes
+-.I less
++.I cless
+ to copy its input to the named file as it is being viewed.
+ This applies only when the input file is a pipe,
+ not an ordinary file.
+ If the file already exists,
+-.I less
++.I cless
+ will ask for confirmation before overwriting it.
+ .IP -O\fIfilename\fP
+ The -O option is like -o, but it will overwrite an existing
+@@ -569,23 +569,23 @@
+ .sp
+ If no log file has been specified,
+ the -o and -O options can be used from within
+-.I less
++.I cless
+ to specify a log file.
+ Without a file name, they will simply report the name of the log file.
+ The "s" command is equivalent to specifying -o from within
+-.I less.
++.I cless.
+ .IP -p\fIpattern\fP
+ The -p option on the command line is equivalent to
+ specifying +/\fIpattern\fP;
+ that is, it tells
+-.I less
++.I cless
+ to start at the first occurrence of \fIpattern\fP in the file.
+ .IP -P\fIprompt\fP
+ Provides a way to tailor the three prompt
+ styles to your own preference.
+ This option would normally be put in the LESS environment
+ variable, rather than being typed in with each
+-.I less
++.I cless
+ command.
+ Such an option must either be the last option in the LESS variable,
+ or be terminated by a dollar sign.
+@@ -613,7 +613,7 @@
+ The default is to display control characters using the caret notation;
+ for example, a control-A (octal 001) is displayed as "^A".
+ Warning: when the -r flag is used,
+-.I less
++.I cless
+ cannot keep track of the actual appearance of the screen
+ (since this depends on how the screen responds to
+ each type of control character).
+@@ -638,10 +638,10 @@
+ .I ctags
+ (1) command.
+ This option may also be specified from within
+-.I less
++.I cless
+ (using the \- command) as a way of examining a new file.
+ The command ":t" is equivalent to specifying -t from within
+-.I less.
++.I cless.
+ .IP -T\fItagsfile\fP
+ Specifies a tags file to be used instead of "tags".
+ .IP -u
+@@ -667,7 +667,7 @@
+ if neither -u nor -U is in effect.
+ .IP -V
+ Displays the version number of
+-.I less.
++.I cless.
+ .IP -w
+ Causes blank lines to be used to represent lines
+ past the end of the file.
+@@ -705,9 +705,9 @@
+ .IP +
+ If a command line option begins with \fB+\fP,
+ the remainder of that option is taken to be an initial command to
+-.I less.
++.I cless.
+ For example, +G tells
+-.I less
++.I cless
+ to start at the end of the file rather than the beginning,
+ and +/xyz tells it to start at the first occurrence of "xyz" in the file.
+ As a special case, +<number> acts like +<number>g;
+@@ -777,25 +777,25 @@
+
+ .SH "KEY BINDINGS"
+ You may define your own
+-.I less
++.I cless
+ commands by using the program
+-.I lesskey
++.I clesskey
+ (1)
+-to create a file called ".less" in your home directory.
++to create a file called ".cless" in your home directory.
+ This file specifies a set of command keys and an action
+ associated with each key.
+ You may also use
+-.I lesskey
++.I clesskey
+ to change the line-editing keys (see LINE EDITING).
+ See the
+-.I lesskey
++.I clesskey
+ manual page for more details.
+
+ .SH "INPUT PREPROCESSOR"
+ You may define an "input preprocessor" for
+-.I less.
++.I cless.
+ Before
+-.I less
++.I cless
+ opens a file, it first gives your input preprocessor a chance to modify the
+ way the contents of the file are displayed.
+ An input preprocessor is simply an executable program (or shell script),
+@@ -805,7 +805,7 @@
+ in place of the contents of the original file.
+ However, it will appear to the user as if the original file is opened;
+ that is,
+-.I less
++.I cless
+ will display the original filename as the name of the current file.
+ .PP
+ An input preprocessor receives one command line argument, the original filename,
+@@ -813,7 +813,7 @@
+ It should create the replacement file, and when finished,
+ print the name of the replacement file to its standard output.
+ If the input preprocessor does not output a replacement filename,
+-.I less
++.I cless
+ uses the original file, as normal.
+ The input preprocessor is not called when viewing standard input.
+ To set up an input preprocessor, set the LESSOPEN environment variable
+@@ -823,7 +823,7 @@
+ when the input preprocessor command is invoked.
+ .PP
+ When
+-.I less
++.I cless
+ closes a file opened in such a way, it will call another program,
+ called the input postprocessor,
+ which may perform any desired clean-up action (such as deleting the
+@@ -839,24 +839,24 @@
+ .PP
+ For example, on many Unix systems, these two scripts will allow you
+ to keep files in compressed format, but still let
+-.I less
++.I cless
+ view them directly:
+ .PP
+-lessopen.sh:
++clessopen.sh:
+ .br
+ #! /bin/sh
+ .br
+ case "$1" in
+ .br
+- *.Z) uncompress -c $1 >/tmp/less.$$ 2>/dev/null
++ *.Z) uncompress -c $1 >/tmp/cless.$$ 2>/dev/null
+ .br
+- if [ -s /tmp/less.$$ ]; then
++ if [ -s /tmp/cless.$$ ]; then
+ .br
+- echo /tmp/less.$$
++ echo /tmp/cless.$$
+ .br
+ else
+ .br
+- rm -f /tmp/less.$$
++ rm -f /tmp/cless.$$
+ .br
+ fi
+ .br
+@@ -878,7 +878,7 @@
+ .PP
+ It is also possible to set up an input preprocessor to
+ pipe the file data directly to
+-.I less,
++.I cless,
+ rather than putting the data into a replacement file.
+ This avoids the need to decompress the entire file before
+ starting to view it.
+@@ -888,7 +888,7 @@
+ writes the entire contents of the replacement file on its standard output.
+ If the input pipe does not write any characters on its standard output,
+ then there is no replacement file and
+-.I less
++.I cless
+ uses the original file, as normal.
+ To use an input pipe,
+ make the first character in the LESSOPEN environment variable a
+@@ -950,7 +950,7 @@
+ Selects a character set appropriate for NeXT computers.
+ .PP
+ In special cases, it may be desired to tailor
+-.I less
++.I cless
+ to use a character set other than the ones definable by LESSCHARSET.
+ In this case, the environment variable LESSCHARDEF can be used
+ to define a character set.
+@@ -983,7 +983,7 @@
+ but your system supports the
+ .I setlocale
+ interface,
+-.I less
++.I cless
+ will use setlocale to determine the character set.
+ setlocale is controlled by setting the LANG or LC_CTYPE environment variables.
+ .PP
+@@ -1173,14 +1173,14 @@
+ .IP EDITOR
+ The name of the editor (used for the v command).
+ .IP HOME
+-Name of the user's home directory (used to find a .less file).
++Name of the user's home directory (used to find a .cless file).
+ .IP LANG
+ Language for determining the character set.
+ .IP LC_CTYPE
+ Language for determining the character set.
+ .IP LESS
+ Flags which are passed to
+-.I less
++.I cless
+ automatically.
+ .IP LESSBINFMT
+ Format for displaying non-printable, non-control characters.
+@@ -1204,13 +1204,14 @@
+ The shell used to execute the ! command, as well as to expand filenames.
+ .IP TERM
+ The type of terminal on which
+-.I less
++.I cless
+ is being run.
+ .IP VISUAL
+ The name of the editor (used for the v command).
+
+ .SH "SEE ALSO"
+-lesskey(1)
++clesskey(1)
++less(1)
+
+ .SH WARNINGS
+ The = command and prompts (unless changed by -P)
diff --git a/chinese/cless/files/patch-ad b/chinese/cless/files/patch-ad
new file mode 100644
index 000000000000..eb3291d6103d
--- /dev/null
+++ b/chinese/cless/files/patch-ad
@@ -0,0 +1,103 @@
+--- lesskey.nro.orig Sun Sep 15 23:00:54 1996
++++ lesskey.nro Sun Sep 15 23:03:28 1996
+@@ -1,22 +1,22 @@
+ .TH LESSKEY 1
+ .SH NAME
+-lesskey \- specify key bindings for less
++clesskey \- specify key bindings for cless
+ .SH SYNOPSIS
+-.B "lesskey [-o output] [input]"
++.B "clesskey [-o output] [input]"
+ .br
+-.B "lesskey -V"
++.B "clesskey -V"
+ .SH DESCRIPTION
+ .I Lesskey
+ is used to specify a set of key bindings to be used by
+-.I less.
++.I cless.
+ The input file is a text file which describes the key bindings,
+ If the input file is "-", standard input is read.
+-If no input file is specified, $HOME/.lesskey is read.
++If no input file is specified, $HOME/.clesskey is read.
+ The output file is a binary file which is used by
+-.I less.
+-If no output file is specified, $HOME/.less is written.
++.I cless.
++If no output file is specified, $HOME/.cless is written.
+ If the output file already exists,
+-.I lesskey
++.I clesskey
+ will overwrite it.
+ .PP
+ The input file consists of lines of the form:
+@@ -26,7 +26,7 @@
+ Whitespace is any sequence of one or more spaces and/or tabs.
+ The \fIstring\fP is the command key(s) which invoke the action.
+ The \fIstring\fP may be a single command key, or a sequence of up to 15 keys.
+-The \fIaction\fP is the name of the less action, from the list below.
++The \fIaction\fP is the name of the cless action, from the list below.
+ The characters in the \fIstring\fP may appear literally, or be
+ prefixed by a caret to indicate a control key.
+ A backslash followed by one to three octal digits may be used to
+@@ -41,22 +41,22 @@
+ .PP
+ An action may be followed by an "extra" string.
+ When such a command is entered while running
+-.I less,
++.I cless,
+ the action is performed, and then the extra
+ string is parsed, just as if it were typed in to
+-.I less.
++.I cless.
+ This feature can be used in certain cases to extend
+ the functionality of a command.
+ For example, see the "{" and ":t" commands in the example below.
+ .PP
+ The -V flag causes
+-.I lesskey
++.I clesskey
+ to print its version number and immediately exit.
+ Other flags and arguments are ignored.
+
+ .SH EXAMPLE
+ The following input file describes the set of
+-default command keys used by less:
++default command keys used by cless:
+ .sp
+ .nf
+ \er forw-line
+@@ -147,14 +147,14 @@
+ .sp
+ .SH PRECEDENCE
+ Commands specified by
+-.I lesskey
++.I clesskey
+ take precedence over the default commands.
+ A default command key may be disabled by including it in the
+ input file with the action "invalid".
+ Alternatively, a key may be defined
+ to do nothing by using the action "noaction".
+ "noaction" is similar to "invalid", but
+-.I less
++.I cless
+ will give an error beep for an "invalid" command,
+ but not for a "noaction" command.
+ In addition, ALL default commands may be disabled by
+@@ -185,7 +185,7 @@
+
+ .SH EXAMPLE
+ The following input file describes the set of
+-default line-editing keys used by less:
++default line-editing keys used by cless:
+ .sp
+ .nf
+ #line-edit
+@@ -210,6 +210,7 @@
+ .sp
+
+ .SH "SEE ALSO"
++cless(1)
+ less(1)
+
+ .SH COPYRIGHT
diff --git a/chinese/cless/pkg-comment b/chinese/cless/pkg-comment
new file mode 100644
index 000000000000..17c1aeaf796c
--- /dev/null
+++ b/chinese/cless/pkg-comment
@@ -0,0 +1 @@
+A better pager utility (and it speaks Chinese)
diff --git a/chinese/cless/pkg-descr b/chinese/cless/pkg-descr
new file mode 100644
index 000000000000..41dc62eabe48
--- /dev/null
+++ b/chinese/cless/pkg-descr
@@ -0,0 +1,15 @@
+A paginator similar to "more" or "pg", but much more powerful and
+speaks Chinese.
+
+Cless is a port of GNU's less version 290 that suports the display of files
+written in the Chinese language using the GB (simple) or Big5 (complex)
+encodings. You can switch to reading of normal ASCII text by setting the
+environment LESSCHARSET to 'ascii'.
+
+Also, the help can be displayed in either Simple Chinese, Complex Chinese,
+or English by setting the LESSHELP environmental variable to the correct
+helpfile. Cless should be run w/in a CXterm or simular terminal emulator
+supporting Chinese language encodings.
+
+David O'Brien
+obrien@cs.ucdavis.edu
diff --git a/chinese/cless/pkg-plist b/chinese/cless/pkg-plist
new file mode 100644
index 000000000000..3eecdf566ac5
--- /dev/null
+++ b/chinese/cless/pkg-plist
@@ -0,0 +1,8 @@
+bin/cless
+bin/clesskey
+man/man1/cless.1
+man/man1/clesskey.1
+share/cless.hlp
+share/cless.bg5
+share/cless.gb
+share/doc/cless/README.CLESS