aboutsummaryrefslogtreecommitdiff
path: root/chinese/emacs20/Makefile
diff options
context:
space:
mode:
authorJing-Tang Keith Jang <keith@FreeBSD.org>2000-12-01 04:49:28 +0000
committerJing-Tang Keith Jang <keith@FreeBSD.org>2000-12-01 04:49:28 +0000
commit13004b54a2083501565e500a4962cad443550ddb (patch)
tree95d5d5323039d4f890d68418ec9e1fd8047852e7 /chinese/emacs20/Makefile
parente7bf354fcc21c6efea79829674728a0b04ab0a44 (diff)
downloadports-13004b54a2083501565e500a4962cad443550ddb.tar.gz
ports-13004b54a2083501565e500a4962cad443550ddb.zip
Notes
Diffstat (limited to 'chinese/emacs20/Makefile')
-rw-r--r--chinese/emacs20/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/chinese/emacs20/Makefile b/chinese/emacs20/Makefile
new file mode 100644
index 000000000000..a8b5afe4ebbc
--- /dev/null
+++ b/chinese/emacs20/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: emacs20 with XIM and a little zh-l10n
+# Date created: Sat Nov 11, 2000
+# Whom: Clive Lin <clive@CirX.ORG>
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../../editors/emacs20
+
+MAINTAINER= clive@CirX.ORG
+
+.if !defined(WITHOUT_X11)
+RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/local/kc15f.pcf.gz:${PORTSDIR}/chinese/kcfonts \
+ xcin2.5:${PORTSDIR}/chinese/xcin25
+.endif
+
+WITH_XPG4= yes
+
+PKGMESSAGE= ${.CURDIR}/pkg-message
+
+PLIST= ${WRKDIR}/pkg-plist
+
+pre-patch:
+ @( cd ${WRKSRC}; \
+ ${PATCH} -sp1 < ${.CURDIR}/files/emacs20-xim-20000713.diff ; )
+
+post-patch:
+ @${ECHO} "share/emacs/%%EMACS_VER%%/etc/Emacs" >> ${WRKDIR}/pkg-plist
+ @${ECHO} "share/emacs/%%EMACS_VER%%/etc/dot.emacs" >> ${WRKDIR}/pkg-plist
+ @${CAT} ${MASTERDIR}/pkg-plist >> ${WRKDIR}/pkg-plist
+
+post-install:
+ ${INSTALL} -c ${.CURDIR}/files/Emacs ${PREFIX}/share/emacs/${PORTVERSION}/etc
+ ${INSTALL} -c ${.CURDIR}/files/dot.emacs ${PREFIX}/share/emacs/${PORTVERSION}/etc
+ @${CAT} ${PKGMESSAGE}
+
+.include "${MASTERDIR}/Makefile"