aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx-configtool/Makefile
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2012-02-07 20:57:08 +0000
committerXin LI <delphij@FreeBSD.org>2012-02-07 20:57:08 +0000
commit3390f7060e630b0f7e13ba19350cd65380b88cfe (patch)
tree5cd4bc1e8584a97698efa13cf8b94b990f901179 /chinese/fcitx-configtool/Makefile
parent86d3a677657db88b4c3b497f0e2fa33833199deb (diff)
downloadports-3390f7060e630b0f7e13ba19350cd65380b88cfe.tar.gz
ports-3390f7060e630b0f7e13ba19350cd65380b88cfe.zip
Notes
Diffstat (limited to 'chinese/fcitx-configtool/Makefile')
-rw-r--r--chinese/fcitx-configtool/Makefile33
1 files changed, 28 insertions, 5 deletions
diff --git a/chinese/fcitx-configtool/Makefile b/chinese/fcitx-configtool/Makefile
index 4ce8af2f2681..a6391441a6a9 100644
--- a/chinese/fcitx-configtool/Makefile
+++ b/chinese/fcitx-configtool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fcitx-configtool
-PORTVERSION= 0.3.1
+PORTVERSION= 0.4.0
CATEGORIES= chinese x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
@@ -14,16 +14,39 @@ DIST_SUBDIR= fcitx
MAINTAINER= lichray@gmail.com
COMMENT= Fcitx IM configure tool
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx
USE_BZIP2= yes
-USE_GNOME= gtk20 intltool gnomehack
+USE_GNOME= intltool gnomehack
USE_GETTEXT= yes
USE_CMAKE= yes
-PROJECTHOST= fcitx
+OPTIONS= GTK2 "Enable Gtk2 Version" on \
+ GTK3 "Enable Gtk3 Version" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
+PLIST_SUB+= GTK2=""
+.else
+CMAKE_ARGS+= -DENABLE_GTK2=OFF
+PLIST_SUB+= GTK2="@comment "
+.endif
-PLIST_FILES= bin/fcitx-config-gtk \
- share/locale/zh_CN/LC_MESSAGES/fcitx-configtool.mo
+.if defined(WITH_GTK3)
+USE_GNOME+= gtk30
+CMAKE_ARGS+= -DENABLE_GTK3=ON
+PLIST_SUB+= GTK3=""
+.else
+PLIST_SUB+= GTK3="@comment "
+.endif
+
+.if defined(WITHOUT_GTK2) && defined(WITHOUT_GTK3)
+IGNORE= a GUI is required
+.endif
+
+PROJECTHOST= fcitx
.include <bsd.port.mk>