aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx-configtool
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-05-25 07:35:58 +0000
committerWen Heping <wen@FreeBSD.org>2012-05-25 07:35:58 +0000
commit4264c827f0fac24fee4393656d5464d84083674c (patch)
tree2b5caef19128e3c22d24c5b85d7ab27476ff0902 /chinese/fcitx-configtool
parentcb665d036826a5606deedd0a0c69a0c8fa1c22b3 (diff)
downloadports-4264c827f0fac24fee4393656d5464d84083674c.tar.gz
ports-4264c827f0fac24fee4393656d5464d84083674c.zip
Notes
Diffstat (limited to 'chinese/fcitx-configtool')
-rw-r--r--chinese/fcitx-configtool/Makefile5
-rw-r--r--chinese/fcitx-configtool/distinfo4
-rw-r--r--chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt11
-rw-r--r--chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt12
4 files changed, 16 insertions, 16 deletions
diff --git a/chinese/fcitx-configtool/Makefile b/chinese/fcitx-configtool/Makefile
index 7e505d8854b7..10e6124dde2e 100644
--- a/chinese/fcitx-configtool/Makefile
+++ b/chinese/fcitx-configtool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fcitx-configtool
-PORTVERSION= 0.4.2
+PORTVERSION= 0.4.3
CATEGORIES= chinese x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
@@ -14,7 +14,8 @@ DIST_SUBDIR= fcitx
MAINTAINER= lichray@gmail.com
COMMENT= Fcitx IM framework configure tool
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
+ ${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx
USE_XZ= yes
diff --git a/chinese/fcitx-configtool/distinfo b/chinese/fcitx-configtool/distinfo
index 40b7b8dd5bf2..e655d6dead07 100644
--- a/chinese/fcitx-configtool/distinfo
+++ b/chinese/fcitx-configtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fcitx/fcitx-configtool-0.4.2.tar.xz) = 98e1c14c3737e13a6340eb093f7f5391e4cd973e147aec8c9e49f41b3a1904b7
-SIZE (fcitx/fcitx-configtool-0.4.2.tar.xz) = 33724
+SHA256 (fcitx/fcitx-configtool-0.4.3.tar.xz) = 0b8722da441acd3deb841f6b389b02499bc99f61a711ce57ad0cccae359a53b9
+SIZE (fcitx/fcitx-configtool-0.4.3.tar.xz) = 34792
diff --git a/chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt b/chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt
index 6b48a776937a..f6bd6b8a683b 100644
--- a/chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt
+++ b/chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt
@@ -1,10 +1,9 @@
---- gtk3/CMakeLists.txt~ 2012-01-30 04:51:25.000000000 -0600
-+++ gtk3/CMakeLists.txt 2012-02-06 03:22:50.184481579 -0600
-@@ -45,6 +45,7 @@ target_link_libraries (fcitx-config-gtk3
- ${FCITX4_FCITX_CONFIG_LIBRARIES}
+--- gtk3/CMakeLists.txt~ 2012-05-03 01:21:57.000000000 -0500
++++ gtk3/CMakeLists.txt 2012-05-14 01:55:09.806098826 -0500
+@@ -42,5 +42,6 @@ target_link_libraries (fcitx-config-gtk3
${FCITX4_FCITX_LIBRARIES}
+ ${GLIB2_LIBRARIES}
${GIO2_LIBRARIES}
-+ -lintl
++ -lintl
)
- if (UNIQUE3_FOUND)
diff --git a/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt b/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
index 8da38911f18b..411973106999 100644
--- a/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
+++ b/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
@@ -1,10 +1,10 @@
---- gtk/CMakeLists.txt~ 2012-01-30 04:51:25.000000000 -0600
-+++ gtk/CMakeLists.txt 2012-02-06 03:19:28.808521532 -0600
-@@ -44,6 +44,7 @@ target_link_libraries (fcitx-config-gtk
- ${FCITX4_FCITX_CONFIG_LIBRARIES}
+--- gtk/CMakeLists.txt~ 2012-05-03 01:21:57.000000000 -0500
++++ gtk/CMakeLists.txt 2012-05-14 01:56:06.761294523 -0500
+@@ -49,6 +49,7 @@ target_link_libraries (fcitx-config-gtk
${FCITX4_FCITX_LIBRARIES}
- ${GIO2_LIBRARIES}
-+ -lintl
+ ${GLIB2_LIBRARIES}
+ ${DBUS_GLIB_LIBRARIES}
++ -lintl
)
if (UNIQUE_FOUND)