aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx-configtool
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-07-25 18:10:40 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-07-25 18:10:40 +0000
commit47a32988e55e1924df8e9b4962c9b095833e8cbb (patch)
treee20bc37590648220a8262213f03b698895eccb26 /chinese/fcitx-configtool
parent6dbd6baa2a3c1a2e309790688ff547d20c911273 (diff)
downloadports-47a32988e55e1924df8e9b4962c9b095833e8cbb.tar.gz
ports-47a32988e55e1924df8e9b4962c9b095833e8cbb.zip
Notes
Diffstat (limited to 'chinese/fcitx-configtool')
-rw-r--r--chinese/fcitx-configtool/Makefile9
-rw-r--r--chinese/fcitx-configtool/distinfo4
-rw-r--r--chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt11
3 files changed, 14 insertions, 10 deletions
diff --git a/chinese/fcitx-configtool/Makefile b/chinese/fcitx-configtool/Makefile
index c51cb8b44ffe..2dbc21f35075 100644
--- a/chinese/fcitx-configtool/Makefile
+++ b/chinese/fcitx-configtool/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fcitx-configtool
-PORTVERSION= 0.4.3
-PORTREVISION= 1
+PORTVERSION= 0.4.4
CATEGORIES= chinese x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
@@ -17,7 +16,7 @@ COMMENT= Fcitx IM framework configure tool
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
-LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx
+LIB_DEPENDS= fcitx-config:${PORTSDIR}/chinese/fcitx
USE_XZ= yes
USE_GNOME= intltool gnomehack
@@ -30,18 +29,18 @@ OPTIONS= GTK2 "Enable Gtk2 Version" on \
.include <bsd.port.options.mk>
.if defined(WITH_GTK2)
+CMAKE_ARGS+= -DENABLE_GTK2=ON
USE_GNOME+= gtk20
PLIST_SUB+= GTK2=""
.else
-CMAKE_ARGS+= -DENABLE_GTK2=OFF
PLIST_SUB+= GTK2="@comment "
.endif
.if defined(WITH_GTK3)
USE_GNOME+= gtk30
-CMAKE_ARGS+= -DENABLE_GTK3=ON
PLIST_SUB+= GTK3=""
.else
+CMAKE_ARGS+= -DENABLE_GTK3=OFF
PLIST_SUB+= GTK3="@comment "
.endif
diff --git a/chinese/fcitx-configtool/distinfo b/chinese/fcitx-configtool/distinfo
index e655d6dead07..3d42fd83c811 100644
--- a/chinese/fcitx-configtool/distinfo
+++ b/chinese/fcitx-configtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fcitx/fcitx-configtool-0.4.3.tar.xz) = 0b8722da441acd3deb841f6b389b02499bc99f61a711ce57ad0cccae359a53b9
-SIZE (fcitx/fcitx-configtool-0.4.3.tar.xz) = 34792
+SHA256 (fcitx/fcitx-configtool-0.4.4.tar.xz) = 66cae23c1e1555a5e8e8cb8696e562b0b58d28e16d2f0b9c64a0f274a6c06745
+SIZE (fcitx/fcitx-configtool-0.4.4.tar.xz) = 37764
diff --git a/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt b/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
index 411973106999..c607574e386e 100644
--- a/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
+++ b/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
@@ -1,6 +1,11 @@
---- gtk/CMakeLists.txt~ 2012-05-03 01:21:57.000000000 -0500
-+++ gtk/CMakeLists.txt 2012-05-14 01:56:06.761294523 -0500
-@@ -49,6 +49,7 @@ target_link_libraries (fcitx-config-gtk
+--- gtk/CMakeLists.txt.orig 2012-06-02 11:14:45.000000000 -0500
++++ gtk/CMakeLists.txt 2012-07-18 02:00:53.555897529 -0500
+@@ -1,3 +1,4 @@
++PKG_CHECK_MODULES (GTK2 "gtk+-2.0 >= 2.22" REQUIRED)
+ PKG_CHECK_MODULES (DBUS_GLIB "dbus-glib-1" REQUIRED)
+ PKG_CHECK_MODULES (UNIQUE "unique-1.0")
+
+@@ -49,6 +50,7 @@ target_link_libraries (fcitx-config-gtk
${FCITX4_FCITX_LIBRARIES}
${GLIB2_LIBRARIES}
${DBUS_GLIB_LIBRARIES}