aboutsummaryrefslogtreecommitdiff
path: root/chinese/fireflyttf
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-02-19 13:51:50 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-02-19 13:51:50 +0000
commitaadd0f3a5f2ad007d555aacb1928190b7589aaaf (patch)
tree104a3c7a9e42ff9be3b7e0939521876cfb8f9126 /chinese/fireflyttf
parentdb1ca4d8d20ce4e16ed1c65f240f10e76fc1ab9c (diff)
downloadports-aadd0f3a5f2ad007d555aacb1928190b7589aaaf.tar.gz
ports-aadd0f3a5f2ad007d555aacb1928190b7589aaaf.zip
Notes
Diffstat (limited to 'chinese/fireflyttf')
-rw-r--r--chinese/fireflyttf/Makefile34
-rw-r--r--chinese/fireflyttf/pkg-plist13
2 files changed, 19 insertions, 28 deletions
diff --git a/chinese/fireflyttf/Makefile b/chinese/fireflyttf/Makefile
index ee7a4eee8332..4a27ba8012de 100644
--- a/chinese/fireflyttf/Makefile
+++ b/chinese/fireflyttf/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= fireflyttf
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.2.6
+PORTREVISION= 0
CATEGORIES= chinese x11-fonts
MASTER_SITES= http://www.study-area.org/apt/firefly-font/
DISTNAME= fireflysung.ttf
@@ -16,28 +16,26 @@ EXTRACT_SUFX= .gz
MAINTAINER= statue@freebsd.sinica.edu.tw
COMMENT= Firefly TrueType Font is combine of two arphic sung fonts
-BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- ttfm.sh:${PORTSDIR}/chinese/ttfm
-RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- ttfm.sh:${PORTSDIR}/chinese/ttfm
-
NO_BUILD= yes
WRKSRC= ${WRKDIR}
-USE_XLIB= yes
-FONTDIR= ${PREFIX}/share/fonts/TrueType
-XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
EXTRACT_AFTER_ARGS= > ${DISTNAME}
-.include <bsd.port.pre.mk>
+TTF= ${DISTNAME}
+
+.if !defined(WITHOUT_X11)
+PLIST_SUB+= X11=""
+.else
+PLIST_SUB+= X11="@comment "
+.endif
do-install:
- @${MKDIR} ${FONTDIR}
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME} ${FONTDIR}
- @${ECHO_MSG} "===> Running ttfm.sh"
- -@${PREFIX}/bin/ttfm.sh --add xttfm ${DISTNAME}
- @${ECHO_MSG} "===> Running fc-cache"
- -@${X11BASE}/bin/fc-cache -f -v ${XFONTDIR}
- ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTDIR}
+ ${MKDIR} ${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${TTF} ${FONTSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTSDIR}
+.if !defined(WITHOUT_X11)
${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${X11BASE}/etc/fonts/local.conf
+.endif
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/chinese/ttfm/Makefile.ttf"
.include <bsd.port.post.mk>
diff --git a/chinese/fireflyttf/pkg-plist b/chinese/fireflyttf/pkg-plist
index 87aa373d2879..51ad1ebac38c 100644
--- a/chinese/fireflyttf/pkg-plist
+++ b/chinese/fireflyttf/pkg-plist
@@ -1,10 +1,3 @@
-@unexec if cmp -s %%X11BASE%%/etc/fonts/local.conf %D/share/fonts/TrueType/local.conf-sung; then rm -f %%X11BASE%%/etc/fonts/local.conf; fi
-share/fonts/TrueType/local.conf-sung
-@exec cp %D/share/fonts/TrueType/local.conf-sung %%X11BASE%%/etc/fonts/local.conf
-@unexec %D/bin/ttfm.sh --remove xttfm %D/share/fonts/TrueType/fireflysung.ttf || true
-share/fonts/TrueType/fireflysung.ttf
-@exec %D/bin/ttfm.sh --add xttfm %D/share/fonts/TrueType/fireflysung.ttf || true
-@unexec %%X11BASE%%/bin/fc-cache -f -v %%X11BASE%%/lib/X11/fonts/TrueType || true
-@exec %%X11BASE%%/bin/fc-cache -f -v %%X11BASE%%/lib/X11/fonts/TrueType || true
-@unexec rmdir %D/share/fonts/TrueType 2>/dev/null || true
-@unexec rmdir %D/share/fonts 2>/dev/null || true
+%%X11%%@unexec if cmp -s %%X11BASE%%/etc/fonts/local.conf %D/%%FONTSDIR%%/local.conf-sung; then rm -f %%X11BASE%%/etc/fonts/local.conf; fi
+%%FONTSDIR%%/local.conf-sung
+%%X11%%@exec cp %D/%%FONTSDIR%%/local.conf-sung %%X11BASE%%/etc/fonts/local.conf