aboutsummaryrefslogtreecommitdiff
path: root/chinese/gcin/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2012-07-16 03:08:56 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2012-07-16 03:08:56 +0000
commit31d85562a3bc80753759dc9f73ba57f28514cd2b (patch)
tree80cc43716dea8c883af0ec9934685f832901905c /chinese/gcin/Makefile
parent62263e4b4701214bd4310077d04c062588a5ba32 (diff)
Notes
Diffstat (limited to 'chinese/gcin/Makefile')
-rw-r--r--chinese/gcin/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index 52d50cf6075d..9a44e07a6fa4 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= gcin
-PORTVERSION= 2.7.6.1
-PORTREVISION= 1
+PORTVERSION= 2.7.8
+PORTREVISION= 0
CATEGORIES= chinese textproc gnome
MASTER_SITES= http://www.csie.nctu.edu.tw/~cp76/gcin/download/:main
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:main
@@ -26,9 +26,10 @@ USE_GMAKE= YES
USE_XORG= x11 xtst xext
INSTALLS_ICONS= YES
USE_LDCONFIG= YES
-OPTIONS= ANTHY "enable Japanese anthy IM module" off \
- CHEWING "enable Chewing IM module" off \
- QT_IM_MODULE "enable QT IM module" off
+OPTIONS_DEFINE= ANTHY CHEWING QT_IM_MODULE
+ANTHY_DESC= Japanese anthy IM module
+CHEWING_DESC= Chewing IM module
+QT_IM_MODULE_DESC= QT IM module
MAN1= gcin.1 gcin-exit.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
gcin-message.1 gcin-tools.1 gtab-merge.1 juyin-learn.1 \
@@ -37,7 +38,7 @@ MAN1= gcin.1 gcin-exit.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
.include <bsd.port.options.mk>
-.if defined(WITH_QT_IM_MODULE)
+.if ${PORT_OPTIONS:MQT_IM_MODULE}
USE_QT4= inputmethods qmake_build moc_build corelib gui
LIB_DEPENDS+= mng:${PORTSDIR}/graphics/libmng
PLIST_SUB+= QT_IM_MODULE=""
@@ -52,18 +53,18 @@ PLIST_SUB+= QT_IM_MODULE="@comment "
BROKEN= does not compile
.endif
-.if defined(WITH_ANTHY)
+.if ${PORT_OPTIONS:MANTHY}
BUILD_DEPENDS+= ${LOCALBASE}/include/anthy/anthy.h:${PORTSDIR}/japanese/anthy
-LIB_DEPENDS+= anthy.1:${PORTSDIR}/japanese/anthy
+LIB_DEPENDS+= anthy:${PORTSDIR}/japanese/anthy
PLIST_SUB+= ANTHY_MODULE=""
.else
CONFIGURE_ARGS+= --use_anthy=N
PLIST_SUB+= ANTHY_MODULE="@comment "
.endif
-.if defined(WITH_CHEWING)
+.if ${PORT_OPTIONS:MCHEWING}
BUILD_DEPENDS+= ${LOCALBASE}/include/chewing/chewing.h:${PORTSDIR}/chinese/libchewing
-LIB_DEPENDS+= chewing.3:${PORTSDIR}/chinese/libchewing
+LIB_DEPENDS+= chewing:${PORTSDIR}/chinese/libchewing
PLIST_SUB+= CHEWING_MODULE=""
.else
CONFIGURE_ARGS+= --use_chewing=N