aboutsummaryrefslogtreecommitdiff
path: root/chinese/gcin/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2018-05-21 15:36:12 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2018-05-21 15:36:12 +0000
commitf039ebaccbc2ad4d239f01e695680bf79e5eba58 (patch)
tree65174638e1996cdfa0a0f6f797483ce132337c3d /chinese/gcin/Makefile
parent0215275bb80478b0d0ebb815d7af360ecdab4ec6 (diff)
downloadports-f039ebaccbc2ad4d239f01e695680bf79e5eba58.tar.gz
ports-f039ebaccbc2ad4d239f01e695680bf79e5eba58.zip
Notes
Diffstat (limited to 'chinese/gcin/Makefile')
-rw-r--r--chinese/gcin/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index 62cab418b823..57ae270765d7 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gcin
-PORTVERSION= 2.8.5
-PORTREVISION= 1
+PORTVERSION= 2.8.6
CATEGORIES= chinese textproc gnome
MASTER_SITES= http://hyperrate.com/gcin-source/
EXTRACT_ONLY= gcin-${PORTVERSION}.tar.xz
@@ -13,15 +12,17 @@ COMMENT= Traditional Chinese input utility in X
LICENSE= LGPL21
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+USES= gmake pkgconfig tar:xz
HAS_CONFIGURE= YES
CONFIGURE_ARGS+= --use_gtk3=N --use_qt3=N --use_qt4=N --use_qt5=N
USE_GNOME= gtk20
-USES= gmake pkgconfig tar:xz
USE_XORG= x11 xtst xext
INSTALLS_ICONS= YES
USE_LDCONFIG= ${PREFIX}/lib/gcin
-OPTIONS_DEFINE= ANTHY DOCS
+OPTIONS_DEFINE= ANTHY
OPTIONS_SUB= yes
ANTHY_DESC= Japanese anthy IM module
@@ -39,7 +40,6 @@ post-patch:
@${REINPLACE_CMD} -e 's,\/usr\/share,$$(prefix)\/share,; \
s,%%PREFIX%%,${PREFIX},;' \
${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e '94 s/gcin/gcin-setup/' ${WRKSRC}/gcin-common.cpp
@${REINPLACE_CMD} -e 's,/usr/local,/usr,g' \
${WRKSRC}/gtk-im/Makefile ${WRKSRC}/menu/Makefile
@${REINPLACE_CMD} -e 's,modify-XIM ,,; 8,10 d' \
@@ -61,9 +61,6 @@ post-patch:
@${REINPLACE_CMD} -e '/make/ d' ${WRKSRC}/IMdkit/lib/Makefile
@${REINPLACE_CMD} -e 's,/usr/X11R6/lib,${LOCALBASE}/lib,' ${WRKSRC}/im-client/Makefile
-post-patch-DOCS-off:
- @${REINPLACE_CMD} '/install.*DOC_DIR/d' ${WRKSRC}/Makefile
-
post-build:
.if !defined(DEBUG_FLAGS)
@${FIND} ${WRKSRC} -name "*.so*" | ${XARGS} ${STRIP_CMD}