aboutsummaryrefslogtreecommitdiff
path: root/chinese/gcin
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2012-07-16 03:08:56 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2012-07-16 03:08:56 +0000
commit31d85562a3bc80753759dc9f73ba57f28514cd2b (patch)
tree80cc43716dea8c883af0ec9934685f832901905c /chinese/gcin
parent62263e4b4701214bd4310077d04c062588a5ba32 (diff)
downloadports-31d85562a3bc80753759dc9f73ba57f28514cd2b.tar.gz
ports-31d85562a3bc80753759dc9f73ba57f28514cd2b.zip
Upgrade to 2.7.8, and make portlint happy.
Notes
Notes: svn path=/head/; revision=300919
Diffstat (limited to 'chinese/gcin')
-rw-r--r--chinese/gcin/Makefile21
-rw-r--r--chinese/gcin/distinfo4
-rw-r--r--chinese/gcin/files/patch-gcin-exit.cpp11
-rw-r--r--chinese/gcin/files/patch-pho-play.cpp11
-rw-r--r--chinese/gcin/pkg-plist2
5 files changed, 15 insertions, 34 deletions
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index 52d50cf6075d..9a44e07a6fa4 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= gcin
-PORTVERSION= 2.7.6.1
-PORTREVISION= 1
+PORTVERSION= 2.7.8
+PORTREVISION= 0
CATEGORIES= chinese textproc gnome
MASTER_SITES= http://www.csie.nctu.edu.tw/~cp76/gcin/download/:main
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:main
@@ -26,9 +26,10 @@ USE_GMAKE= YES
USE_XORG= x11 xtst xext
INSTALLS_ICONS= YES
USE_LDCONFIG= YES
-OPTIONS= ANTHY "enable Japanese anthy IM module" off \
- CHEWING "enable Chewing IM module" off \
- QT_IM_MODULE "enable QT IM module" off
+OPTIONS_DEFINE= ANTHY CHEWING QT_IM_MODULE
+ANTHY_DESC= Japanese anthy IM module
+CHEWING_DESC= Chewing IM module
+QT_IM_MODULE_DESC= QT IM module
MAN1= gcin.1 gcin-exit.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
gcin-message.1 gcin-tools.1 gtab-merge.1 juyin-learn.1 \
@@ -37,7 +38,7 @@ MAN1= gcin.1 gcin-exit.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
.include <bsd.port.options.mk>
-.if defined(WITH_QT_IM_MODULE)
+.if ${PORT_OPTIONS:MQT_IM_MODULE}
USE_QT4= inputmethods qmake_build moc_build corelib gui
LIB_DEPENDS+= mng:${PORTSDIR}/graphics/libmng
PLIST_SUB+= QT_IM_MODULE=""
@@ -52,18 +53,18 @@ PLIST_SUB+= QT_IM_MODULE="@comment "
BROKEN= does not compile
.endif
-.if defined(WITH_ANTHY)
+.if ${PORT_OPTIONS:MANTHY}
BUILD_DEPENDS+= ${LOCALBASE}/include/anthy/anthy.h:${PORTSDIR}/japanese/anthy
-LIB_DEPENDS+= anthy.1:${PORTSDIR}/japanese/anthy
+LIB_DEPENDS+= anthy:${PORTSDIR}/japanese/anthy
PLIST_SUB+= ANTHY_MODULE=""
.else
CONFIGURE_ARGS+= --use_anthy=N
PLIST_SUB+= ANTHY_MODULE="@comment "
.endif
-.if defined(WITH_CHEWING)
+.if ${PORT_OPTIONS:MCHEWING}
BUILD_DEPENDS+= ${LOCALBASE}/include/chewing/chewing.h:${PORTSDIR}/chinese/libchewing
-LIB_DEPENDS+= chewing.3:${PORTSDIR}/chinese/libchewing
+LIB_DEPENDS+= chewing:${PORTSDIR}/chinese/libchewing
PLIST_SUB+= CHEWING_MODULE=""
.else
CONFIGURE_ARGS+= --use_chewing=N
diff --git a/chinese/gcin/distinfo b/chinese/gcin/distinfo
index bfb2a98170ba..2cf1611b516d 100644
--- a/chinese/gcin/distinfo
+++ b/chinese/gcin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcin-2.7.6.1.tar.xz) = a682d8c602bba178329b1992b1e82c9dff596dd1d36fb1e9030956aab2106795
-SIZE (gcin-2.7.6.1.tar.xz) = 3041956
+SHA256 (gcin-2.7.8.tar.xz) = 708411e5d74aff8d40e338c27b6c008c47abf79c6c2f37b4f8b02308bb28392e
+SIZE (gcin-2.7.8.tar.xz) = 3705868
diff --git a/chinese/gcin/files/patch-gcin-exit.cpp b/chinese/gcin/files/patch-gcin-exit.cpp
deleted file mode 100644
index bd1fd9bee91f..000000000000
--- a/chinese/gcin/files/patch-gcin-exit.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcin-exit.cpp.orig 2012-01-25 19:29:28.000000000 +0800
-+++ gcin-exit.cpp 2012-01-25 19:29:38.000000000 +0800
-@@ -12,7 +12,7 @@ int main()
- #if UNIX
- Display *dpy = GDK_DISPLAY();
- if (find_gcin_window(dpy)==None)
-- return;
-+ return 0;
- send_gcin_message(dpy, GCIN_EXIT_MESSAGE);
- #else
- if (!find_gcin_window())
diff --git a/chinese/gcin/files/patch-pho-play.cpp b/chinese/gcin/files/patch-pho-play.cpp
deleted file mode 100644
index eac63a6344b3..000000000000
--- a/chinese/gcin/files/patch-pho-play.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- pho-play.cpp.orig 2012-01-25 19:26:50.000000000 +0800
-+++ pho-play.cpp 2012-01-25 19:27:29.000000000 +0800
-@@ -12,7 +12,7 @@ int pho_play(phokey_t key)
- if (!phonetic_speak)
- return 0;
- if (test_mode)
-- return;
-+ return 0;
-
- static int pid;
- static time_t last_time;
diff --git a/chinese/gcin/pkg-plist b/chinese/gcin/pkg-plist
index d1bccc92e7d9..c6b0fd29a026 100644
--- a/chinese/gcin/pkg-plist
+++ b/chinese/gcin/pkg-plist
@@ -17,6 +17,7 @@ bin/tsa2d32
bin/tsd2a32
bin/tsin2gtab-phrase
bin/tslearn
+bin/txt2gtab-phrase
lib/gtk-2.0/immodules/im-gcin.so
%%QT_IM_MODULE%%lib/qt4/plugins/inputmethods/im-gcin.so
%%ANTHY_MODULE%%lib/gcin/anthy-module.so
@@ -50,6 +51,7 @@ lib/gcin/libgcin-im-client.so.1
%%DATADIR%%/table/greek.gtab
%%DATADIR%%/table/gtab.list
%%DATADIR%%/table/hangul.gtab
+%%DATADIR%%/table/hangul-phrase.txt
%%DATADIR%%/table/hsu.kbm
%%DATADIR%%/table/ibm.kbm
%%DATADIR%%/table/jyutping.gtab