aboutsummaryrefslogtreecommitdiff
path: root/chinese/ibus-array/Makefile
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2017-11-23 16:51:13 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2017-11-23 16:51:13 +0000
commit2967c3ae6ee916ed50ae23ee63489bdac69323fb (patch)
tree8b908bb5e6feda1577b8d8034a56b84b65106e3b /chinese/ibus-array/Makefile
parent2d26a9955400deaa5c04b3d1d0cb55c52ab271cc (diff)
downloadports-2967c3ae6ee916ed50ae23ee63489bdac69323fb.tar.gz
ports-2967c3ae6ee916ed50ae23ee63489bdac69323fb.zip
New port: chinese/ibus-array: Array 30 input method for IBus
Implementation of fully functional Array 30 input method engine for iBus. Array 30 is a traditional Chinese input method used in Taiwan. WWW: https://github.com/lexical/ibus-array/ PR: 212527 Submitted by: Jia-Shiun Li <jiashiun@gmail.com>
Notes
Notes: svn path=/head/; revision=454767
Diffstat (limited to 'chinese/ibus-array/Makefile')
-rw-r--r--chinese/ibus-array/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/chinese/ibus-array/Makefile b/chinese/ibus-array/Makefile
new file mode 100644
index 000000000000..46e2f59da52f
--- /dev/null
+++ b/chinese/ibus-array/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= ibus-array
+PORTVERSION= 0.1.0
+CATEGORIES= chinese
+
+MAINTAINER= jiashiun@gmail.com
+COMMENT= Array 30 input method for IBus
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ibus-daemon:textproc/ibus
+RUN_DEPENDS= ibus-daemon:textproc/ibus
+
+GNU_CONFIGURE= yes
+
+USES= autoreconf gettext gmake libtool pkgconfig sqlite
+USE_GNOME+= glib20
+
+USE_GITHUB= yes
+GH_ACCOUNT= lexical
+GH_TAGNAME= release-0.1.0
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+pre-configure:
+ cd ${WRKSRC} && ./autogen.sh
+
+.include <bsd.port.mk>