aboutsummaryrefslogtreecommitdiff
path: root/chinese/libtabe
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2002-08-22 19:13:46 +0000
committerAde Lovett <ade@FreeBSD.org>2002-08-22 19:13:46 +0000
commit76d6ac6122a05c3551580945d540f2f8e1e4c85a (patch)
tree1ac1f3067b29ba7cf054151113186d5959189940 /chinese/libtabe
parent91f316e522763596bca3cb4343e77f9c2296c078 (diff)
downloadports-76d6ac6122a05c3551580945d540f2f8e1e4c85a.tar.gz
ports-76d6ac6122a05c3551580945d540f2f8e1e4c85a.zip
BerkeleyDB cleanup - stage 2
Update databases/db3 to 3.3.11, and fix the few ports that need sorting after the shlib version update, and a slight API change from 3.2.x->3.3.x
Notes
Notes: svn path=/head/; revision=64836
Diffstat (limited to 'chinese/libtabe')
-rw-r--r--chinese/libtabe/Makefile3
-rw-r--r--chinese/libtabe/files/patch-src::tabe_tsidbint.c10
-rw-r--r--chinese/libtabe/files/patch-src::tabe_tsiyindbint.c10
3 files changed, 22 insertions, 1 deletions
diff --git a/chinese/libtabe/Makefile b/chinese/libtabe/Makefile
index 971f6d776700..9197bf65f6b7 100644
--- a/chinese/libtabe/Makefile
+++ b/chinese/libtabe/Makefile
@@ -7,13 +7,14 @@
PORTNAME= libtabe
PORTVERSION= 0.2.5
+PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= ftp://xcin.linux.org.tw/pub/xcin/libtabe/devel/
MAINTAINER= kcwu@ck.tp.edu.tw
.if !defined(USE_DB2)
-LIB_DEPENDS= db3.2:${PORTSDIR}/databases/db3
+LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
.else
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db
.endif
diff --git a/chinese/libtabe/files/patch-src::tabe_tsidbint.c b/chinese/libtabe/files/patch-src::tabe_tsidbint.c
new file mode 100644
index 000000000000..9bb3c612b45b
--- /dev/null
+++ b/chinese/libtabe/files/patch-src::tabe_tsidbint.c
@@ -0,0 +1,10 @@
+--- src/tabe_tsidbint.c.orig Sun Nov 11 12:33:07 2001
++++ src/tabe_tsidbint.c Thu Aug 22 02:14:53 2002
+@@ -267,3 +267,7 @@
+ dbp = (DB *)tsidb->dbp;
++#ifndef HAVE_DB3
+ errno = dbp->stat(dbp, &sp, NULL, 0);
++#else
++ errno = dbp->stat(dbp, &sp, 0);
++#endif
+ if (!errno) {
diff --git a/chinese/libtabe/files/patch-src::tabe_tsiyindbint.c b/chinese/libtabe/files/patch-src::tabe_tsiyindbint.c
new file mode 100644
index 000000000000..57e27d85288d
--- /dev/null
+++ b/chinese/libtabe/files/patch-src::tabe_tsiyindbint.c
@@ -0,0 +1,10 @@
+--- src/tabe_tsiyindbint.c.orig Sun Nov 11 12:33:08 2001
++++ src/tabe_tsiyindbint.c Thu Aug 22 02:16:00 2002
+@@ -270,3 +270,7 @@
+ dbp = (DB *)tsiyindb->dbp;
++#ifndef HAVE_DB3
+ errno = dbp->stat(dbp, &sp, NULL, 0);
++#else
++ errno = dbp->stat(dbp, &sp, 0);
++#endif
+ if (!errno) {