aboutsummaryrefslogtreecommitdiff
path: root/chinese/pcmanx/Makefile
diff options
context:
space:
mode:
authorPo-Chien Lin <pclin@FreeBSD.org>2013-02-23 07:21:57 +0000
committerPo-Chien Lin <pclin@FreeBSD.org>2013-02-23 07:21:57 +0000
commitc417b6f10d59733f3984b0ab4bb24f1850fb663a (patch)
treef0212e4be80374cec60f46c597a6411daa6d4a4e /chinese/pcmanx/Makefile
parent53bda2f119c78e6581ed771eac5737d725a87155 (diff)
Notes
Diffstat (limited to 'chinese/pcmanx/Makefile')
-rw-r--r--chinese/pcmanx/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index bf61c2884f2b..78d2267d386d 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pcmanx
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= chinese net gnome
MASTER_SITES= http://pcmanx-gtk2.googlecode.com/files/
DISTNAME= ${PORTNAME}-gtk2-${PORTVERSION}
@@ -18,7 +17,6 @@ USE_GNOME= gtk20 intlhack
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
OPTIONS_DEFINE= NLS DEBUG DOCKLET NOTIFIER LIBNOTIFY NANCY MOUSE EXTERNAL IPLOOKUP PROXY
OPTIONS_DEFAULT= DOCKLET NOTIFIER NANCY MOUSE EXTERNAL
@@ -60,7 +58,7 @@ CONFIGURE_ARGS+=--disable-notifier
.if ${PORT_OPTIONS:MLIBNOTIFY}
CONFIGURE_ARGS+=--enable-libnotify
-BUILD_DEPENDS= libnotify>0:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
.endif
.if empty(PORT_OPTIONS:MNANCY)
@@ -83,4 +81,8 @@ CONFIGURE_ARGS+=--enable-iplookup
CONFIGURE_ARGS+=--enable-proxy
.endif
+post-install:
+ @# create directory for user friendly
+ ${MKDIR} ${DATADIR}/script/
+
.include <bsd.port.mk>