aboutsummaryrefslogtreecommitdiff
path: root/chinese/pcmanx/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
commitbb271f0bf7b513a23a31da4ec8819b113ebf4587 (patch)
treeac5a462edc3d85d5f0b20a594802ce4b12f0bf9f /chinese/pcmanx/Makefile
parent29879aded766da253313579a3503ff5e15026355 (diff)
downloadports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.tar.gz
ports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.zip
Notes
Diffstat (limited to 'chinese/pcmanx/Makefile')
-rw-r--r--chinese/pcmanx/Makefile66
1 files changed, 17 insertions, 49 deletions
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index 136169491be5..af17c4a1573d 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -19,6 +19,7 @@ GNU_CONFIGURE= yes
OPTIONS_DEFINE= NLS DEBUG DOCKLET NOTIFIER LIBNOTIFY NANCY MOUSE EXTERNAL IPLOOKUP PROXY
OPTIONS_DEFAULT= DOCKLET NOTIFIER NANCY MOUSE EXTERNAL
+OPTIONS_SUB= yes
DOCKLET_DESC= Docklet / system tray support
NOTIFIER_DESC= Popup notifier support
@@ -29,55 +30,22 @@ EXTERNAL_DESC= External SSH/Telnet support
IPLOOKUP_DESC= IP location lookup support
PROXY_DESC= Proxy support
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-USES+= gettext
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+=--enable-debug
-.endif
-
-.if empty(PORT_OPTIONS:MDOCKLET)
-CONFIGURE_ARGS+=--disable-docklet
-.endif
-
-.if empty(PORT_OPTIONS:MNOTIFIER)
-CONFIGURE_ARGS+=--disable-notifier
-.endif
-
-.if ${PORT_OPTIONS:MLIBNOTIFY}
-CONFIGURE_ARGS+=--enable-libnotify
-LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
-.endif
-
-.if empty(PORT_OPTIONS:MNANCY)
-CONFIGURE_ARGS+=--disable-nancy
-.endif
-
-.if empty(PORT_OPTIONS:MMOUSE)
-CONFIGURE_ARGS+=--disable-mouse
-.endif
-
-.if empty(PORT_OPTIONS:MEXTERNAL)
-CONFIGURE_ARGS+=--disable-external
-.endif
-
-.if ${PORT_OPTIONS:MIPLOOKUP}
-CONFIGURE_ARGS+=--enable-iplookup
-.endif
-
-.if ${PORT_OPTIONS:MPROXY}
-CONFIGURE_ARGS+=--enable-proxy
-.endif
+NLS_USES= gettext
+NLS_USES_OFF= gettext-tools
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
+NLS_CONFIGURE_ENABLE=nls
+
+DEBUG_CONFIGURE_ENABLE= debug
+DOCKLET_CONFIGURE_ENABLE= docklet
+NOTIFIER_CONFIGURE_ENABLE= notifier
+LIBNOTIFY_CONFIGURE_ENABLE= libnotify
+LIBNOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
+NANCY_CONFIGURE_ENABLE= nancy
+MOUSE_CONFIGURE_ENABLE= mouse
+EXTERNAL_CONFIGURE_ENABLE= external
+IPLOOKUP_CONFIGURE_ENABLE= iplookup
+PROXY_CONFIGURE_ENABLE= proxy
post-install:
@# create directory for user friendly