aboutsummaryrefslogtreecommitdiff
path: root/chinese/pcmanx
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-07-19 15:44:19 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-07-19 15:44:19 +0000
commit050d74a67ac72f2fc4b17c411517e1a842d03839 (patch)
tree551c54cb8d03e1205381f5db91decd2170dc0aa6 /chinese/pcmanx
parentfa4e659e45cb64d623e89383201fad66ca426eff (diff)
downloadports-050d74a67ac72f2fc4b17c411517e1a842d03839.tar.gz
ports-050d74a67ac72f2fc4b17c411517e1a842d03839.zip
Notes
Diffstat (limited to 'chinese/pcmanx')
-rw-r--r--chinese/pcmanx/Makefile40
-rw-r--r--chinese/pcmanx/distinfo2
-rw-r--r--chinese/pcmanx/pkg-descr3
-rw-r--r--chinese/pcmanx/pkg-plist8
4 files changed, 53 insertions, 0 deletions
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
new file mode 100644
index 000000000000..9a84974ab468
--- /dev/null
+++ b/chinese/pcmanx/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pcmanx
+# Date created: 2005/07/16
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcmanx
+PORTVERSION= 0.1.7
+CATEGORIES= chinese net
+MASTER_SITES= http://pcmanx.csie.net/release/ \
+ http://bbs.ilc.edu.tw/~chinsan/pcmanx/
+DISTNAME= pcmanx-pure-gtk2-${PORTVERSION}
+
+# Maintainership available: drop me a line if interested :p
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= PCManX is a BBS client using GTK+ 2.x
+
+USE_GNOME= gtk20 intlhack
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|--tag=CXX||g' ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/chinese/pcmanx/distinfo b/chinese/pcmanx/distinfo
new file mode 100644
index 000000000000..312cf31db9be
--- /dev/null
+++ b/chinese/pcmanx/distinfo
@@ -0,0 +1,2 @@
+MD5 (pcmanx-pure-gtk2-0.1.7.tar.gz) = b39d8254598a665b49e743200763fd96
+SIZE (pcmanx-pure-gtk2-0.1.7.tar.gz) = 502471
diff --git a/chinese/pcmanx/pkg-descr b/chinese/pcmanx/pkg-descr
new file mode 100644
index 000000000000..df59ed86bb67
--- /dev/null
+++ b/chinese/pcmanx/pkg-descr
@@ -0,0 +1,3 @@
+PCManX is a BBS client for X Window System using GTK+ 2.x.
+
+WWW: http://pcmanx.csie.net/
diff --git a/chinese/pcmanx/pkg-plist b/chinese/pcmanx/pkg-plist
new file mode 100644
index 000000000000..fb8dc14aa50a
--- /dev/null
+++ b/chinese/pcmanx/pkg-plist
@@ -0,0 +1,8 @@
+bin/pcmanx
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/pcmanx.mo
+%%DATADIR%%/emoticons
+%%DATADIR%%/sitelist
+share/applications/pcmanx.desktop
+share/pixmaps/pcmanx.png
+@unexec rmdir %D/share/applications 2>/dev/null || true
+@dirrm %%DATADIR%%