aboutsummaryrefslogtreecommitdiff
path: root/chinese/php-cconv
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-29 20:35:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-29 20:35:32 +0000
commit086314be3ae5c7e1bbaf7b33151416d10ea7fc68 (patch)
tree3647ded972a64a3faa6a268ab378e197c7040c59 /chinese/php-cconv
parent53117d9c4391cc5224e2d2429e44aa9918310962 (diff)
Notes
Diffstat (limited to 'chinese/php-cconv')
-rw-r--r--chinese/php-cconv/Makefile25
-rw-r--r--chinese/php-cconv/distinfo2
-rw-r--r--chinese/php-cconv/pkg-descr15
3 files changed, 42 insertions, 0 deletions
diff --git a/chinese/php-cconv/Makefile b/chinese/php-cconv/Makefile
new file mode 100644
index 000000000000..5e98e6c84faa
--- /dev/null
+++ b/chinese/php-cconv/Makefile
@@ -0,0 +1,25 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cconv
+PORTVERSION= 0.6.4
+CATEGORIES= chinese converters
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= php-
+DISTNAME= ${PORTNAME}-php-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= PHP wrapper for chinese/cconv
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcconv.so:${PORTSDIR}/chinese/cconv
+
+CONFIGURE_ARGS= --with-cconv-dir=${LOCALBASE}
+USE_PHP= yes
+USE_PHPEXT= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's| function_entry| zend_function_entry|' ${WRKSRC}/php_cconv.c
+
+.include <bsd.port.mk>
diff --git a/chinese/php-cconv/distinfo b/chinese/php-cconv/distinfo
new file mode 100644
index 000000000000..61779bfdbae4
--- /dev/null
+++ b/chinese/php-cconv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cconv-php-0.6.4.tar.gz) = 213e56b072627a42d38fdfa7eebfcf58db55054af7ef554f9263c0af3e537628
+SIZE (cconv-php-0.6.4.tar.gz) = 2533
diff --git a/chinese/php-cconv/pkg-descr b/chinese/php-cconv/pkg-descr
new file mode 100644
index 000000000000..70178749c38f
--- /dev/null
+++ b/chinese/php-cconv/pkg-descr
@@ -0,0 +1,15 @@
+This port is the PHP wrapper of cconv (chinese/cconv).
+
+cconv (pronunciation: see-conv) is an iconv-based Simplified-Traditional Chinese
+conversion tool. It is NOT only a transcoding program, but also a TRANSLATE tool
+between Simplified Chinese and Traditional Chinese.
+
+We stand on the shoulders of giants. cconv source code is based on iconv, an
+excellent program which converts text from one encoding to another.
+
+Features:
+- iconv-like usage.
+- language-level Simplified-Traditional Chinese conversion.
+- idioms can be translated.
+
+WWW: http://code.google.com/p/cconv/