aboutsummaryrefslogtreecommitdiff
path: root/chinese/py-cconv/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-05-09 07:40:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-05-09 07:40:22 +0000
commitfbdf4bfea0f619fd03c98a04a597b3f4af481e4d (patch)
tree07c0f783933d7a1d8390252ab80f7c7864efa1d3 /chinese/py-cconv/Makefile
parent34a39744345808a8d053c01fbfd3b26ccaa36806 (diff)
downloadports-fbdf4bfea0f619fd03c98a04a597b3f4af481e4d.tar.gz
ports-fbdf4bfea0f619fd03c98a04a597b3f4af481e4d.zip
Notes
Diffstat (limited to 'chinese/py-cconv/Makefile')
-rw-r--r--chinese/py-cconv/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/chinese/py-cconv/Makefile b/chinese/py-cconv/Makefile
new file mode 100644
index 000000000000..61cb5363d79e
--- /dev/null
+++ b/chinese/py-cconv/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-cconv
+# Date created: 2011-04-28
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cconv
+PORTVERSION= 0.5.0
+CATEGORIES= chinese converters python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-python-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python wrapper for chinese/cconv
+
+LIB_DEPENDS= cconv.0:${PORTSDIR}/chinese/cconv
+
+CFLAGS+= -I${LOCALBASE}/include
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PORTNAME}.so
+
+.include <bsd.port.mk>