aboutsummaryrefslogtreecommitdiff
path: root/chinese/qterm
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-01 12:19:05 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-01 12:19:05 +0000
commit39761517a6d2d759a1b25f22a8f6c1b7bb85c3cf (patch)
tree143adf02917bf4d60557835658046f9d1e5e8f1f /chinese/qterm
parent4cba9d96bfe0f6a197e10b78f3d7233336e720d4 (diff)
downloadports-39761517a6d2d759a1b25f22a8f6c1b7bb85c3cf.tar.gz
ports-39761517a6d2d759a1b25f22a8f6c1b7bb85c3cf.zip
Notes
Diffstat (limited to 'chinese/qterm')
-rw-r--r--chinese/qterm/Makefile11
-rw-r--r--chinese/qterm/distinfo6
-rw-r--r--chinese/qterm/files/patch-qterm-main.cpp18
-rw-r--r--chinese/qterm/files/patch-qterm-qtermwindow.h17
-rw-r--r--chinese/qterm/files/patch-qterm_qtermcanvas.cpp11
-rw-r--r--chinese/qterm/files/patch-qterm_qtermiplocation.cpp28
-rw-r--r--chinese/qterm/files/patch-qterm_qtermtextline.cpp11
-rw-r--r--chinese/qterm/pkg-descr12
-rw-r--r--chinese/qterm/pkg-message9
-rw-r--r--chinese/qterm/pkg-plist8
10 files changed, 65 insertions, 66 deletions
diff --git a/chinese/qterm/Makefile b/chinese/qterm/Makefile
index 949a1dad2728..d924d31e7bc7 100644
--- a/chinese/qterm/Makefile
+++ b/chinese/qterm/Makefile
@@ -6,20 +6,19 @@
#
PORTNAME= qterm
-PORTVERSION= 0.4.0.p2
+PORTVERSION= 0.4.0
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-0.4.0pre2
-MAINTAINER= gavin@FreeBSDChina.org
-COMMENT= QTerm is a BBS client in Unix
+MAINTAINER= yuanjue@yuanjue.net
+COMMENT= QTerm is a BBS client for BSD/Linux
+USE_BZIP2= yes
USE_QT_VER= 3
-USE_AUTOTOOLS= libtool:15
HAS_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-mt --prefix=${PREFIX} \
+CONFIGURE_ARGS= --enable-mt --prefix=${PREFIX} \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
.if !defined(WITHOUT_PYTHON)
diff --git a/chinese/qterm/distinfo b/chinese/qterm/distinfo
index d881747220f5..7dc0beab8304 100644
--- a/chinese/qterm/distinfo
+++ b/chinese/qterm/distinfo
@@ -1,3 +1,3 @@
-MD5 (qterm-0.4.0pre2.tar.gz) = 379a5932ee282bedcfa70d3f16e3e91e
-SHA256 (qterm-0.4.0pre2.tar.gz) = 82f1697c867ae6037df1390b60793e7641b94a396eaca625b7b689fd09924e92
-SIZE (qterm-0.4.0pre2.tar.gz) = 895907
+MD5 (qterm-0.4.0.tar.bz2) = e948e6cda99f518881f3d241ab092d99
+SHA256 (qterm-0.4.0.tar.bz2) = b79cd26eb57d9abc1e2eb530d5fb42f9fdcff86d544466596674273e3571156a
+SIZE (qterm-0.4.0.tar.bz2) = 805526
diff --git a/chinese/qterm/files/patch-qterm-main.cpp b/chinese/qterm/files/patch-qterm-main.cpp
new file mode 100644
index 000000000000..e79a27296798
--- /dev/null
+++ b/chinese/qterm/files/patch-qterm-main.cpp
@@ -0,0 +1,18 @@
+--- qterm/main.cpp.orig Mon Jul 10 15:36:13 2006
++++ qterm/main.cpp Thu Jul 27 17:55:53 2006
+@@ -16,6 +16,15 @@
+ #ifdef HAVE_PYTHON
+ #include <Python.h>
+ #endif
++
++#undef isalnum
++#undef isalpha
++#undef islower
++#undef isspace
++#undef isupper
++#undef tolower
++#undef toupper
++
+ #include <qpixmap.h>
+ #include <qstringlist.h>
+ #include <qapplication.h>
diff --git a/chinese/qterm/files/patch-qterm-qtermwindow.h b/chinese/qterm/files/patch-qterm-qtermwindow.h
new file mode 100644
index 000000000000..470b66f3d2b6
--- /dev/null
+++ b/chinese/qterm/files/patch-qterm-qtermwindow.h
@@ -0,0 +1,17 @@
+--- qterm/qtermwindow.h.orig Mon Jul 10 15:36:12 2006
++++ qterm/qtermwindow.h Thu Jul 27 17:39:46 2006
+@@ -10,6 +10,14 @@
+ #include <Python.h>
+ #endif
+
++#undef isalnum
++#undef isalpha
++#undef islower
++#undef isspace
++#undef isupper
++#undef tolower
++#undef toupper
++
+ #include <qmainwindow.h>
+ #include <qcursor.h>
+
diff --git a/chinese/qterm/files/patch-qterm_qtermcanvas.cpp b/chinese/qterm/files/patch-qterm_qtermcanvas.cpp
deleted file mode 100644
index 0c9ac95396f1..000000000000
--- a/chinese/qterm/files/patch-qterm_qtermcanvas.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- qterm/qtermcanvas.cpp.orig Fri Dec 17 19:26:35 2004
-+++ qterm/qtermcanvas.cpp Fri Dec 17 19:26:39 2004
-@@ -238,7 +238,7 @@
- if(strSave.isEmpty())
- return;
- QString fmt = fi.extension(false).upper();
-- if(!pxm.save(strSave, fmt=="JPG"?"JPEG":fmt))
-+ if(!pxm.save(strSave, fmt=="JPG"?QString("JPEG"):fmt))
- QMessageBox::warning(this, "Failed to save file", "Cant save file, maybe format not supported");
- }
-
diff --git a/chinese/qterm/files/patch-qterm_qtermiplocation.cpp b/chinese/qterm/files/patch-qterm_qtermiplocation.cpp
deleted file mode 100644
index bce5d4e6ffe6..000000000000
--- a/chinese/qterm/files/patch-qterm_qtermiplocation.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- qterm/qtermiplocation.cpp.orig Tue Dec 7 03:23:24 2004
-+++ qterm/qtermiplocation.cpp Fri Dec 17 19:24:22 2004
-@@ -9,8 +9,8 @@
- #ifdef Q_OS_WIN32
- #include <winsock2.h>
- #else
--#include <netinet/in.h>
- #include <arpa/inet.h>
-+#include <netinet/in.h>
- #endif
-
- #include <qstring.h>
-@@ -79,13 +79,13 @@
- if( fseek( fp, (long)offset, SEEK_SET ) ==-1 )
- {
- qDebug( " readLineFrom error 1 " );
-- ret_str = QCString(NULL);
-+ ret_str = QCString();
- return -1;
- }
- if( fgets( (char *) str, 512, fp ) == NULL )
- {
- qDebug( " readLineFrom error 2 " );
-- ret_str = QCString(NULL);
-+ ret_str = QCString();
- return -1;
- }
- ret_str = str;
diff --git a/chinese/qterm/files/patch-qterm_qtermtextline.cpp b/chinese/qterm/files/patch-qterm_qtermtextline.cpp
deleted file mode 100644
index 1a5a0a6c2217..000000000000
--- a/chinese/qterm/files/patch-qterm_qtermtextline.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- qterm/qtermtextline.cpp.orig Sat Nov 13 15:26:48 2004
-+++ qterm/qtermtextline.cpp Sat Nov 13 15:27:41 2004
-@@ -235,7 +235,7 @@
-
-
- if(index>=m_length)
-- return NULL;
-+ return QCString();
-
- printf("index=%d len=%d m_length=%d\n", index, len, m_length);
-
diff --git a/chinese/qterm/pkg-descr b/chinese/qterm/pkg-descr
index 9a75828f06b3..827bfb66c50c 100644
--- a/chinese/qterm/pkg-descr
+++ b/chinese/qterm/pkg-descr
@@ -1,12 +1,14 @@
-QTerm is a BBS client for X Window System. The goal is to make a client
-similar to Sterm and CTerm in MS Windows.
+QTerm is a BBS client for X Window System. The goal is
+to make a client similar to Fterm and CTerm in MS Windows.
Features:
-1.support mouse in Firebird BBS
+1.mouse support
2.copy and paste
3.article download
4.address book
+5.anti-idle
+6.converting between GB and BIG5
-WWW: http://qterm.sourceforge.net
+WWW: http://qterm.sourceforge.net/wiki/
-- Gavin Mu <gavin@FreeBSDChina.org>
+- Yuan, Jue <yuanjue@yuanjue.net>
diff --git a/chinese/qterm/pkg-message b/chinese/qterm/pkg-message
index d899cb265257..cb06c54f96e4 100644
--- a/chinese/qterm/pkg-message
+++ b/chinese/qterm/pkg-message
@@ -4,3 +4,12 @@ QTerm's config file privilege in your ~/.qterm directory to 0755 at least
To display IP location when using QTerm
you must get file "QQWry.dat" and put it into your ~/.qterm directory
*************************************************************************
+
+*************************************************************************
+Unfortunately there is an anonying bug in the release of QTerm 0.4.0. If
+your language setting is NOT English, you might experience some hang up
+when connecting to a site.
+
+A simple workaround is to use the English interface. This bug will be fixed
+in the next minor release.
+*************************************************************************
diff --git a/chinese/qterm/pkg-plist b/chinese/qterm/pkg-plist
index 4020bc98b731..40926bec3c84 100644
--- a/chinese/qterm/pkg-plist
+++ b/chinese/qterm/pkg-plist
@@ -24,6 +24,9 @@ share/icons/qterm.png
%%DATADIR%%/pic/fonts.png
%%DATADIR%%/pic/keys.png
%%DATADIR%%/pic/message.png
+%%DATADIR%%/pic/messagebox_critical.png
+%%DATADIR%%/pic/messagebox_info.png
+%%DATADIR%%/pic/messagebox_warning.png
%%DATADIR%%/pic/mouse.png
%%DATADIR%%/pic/paste.png
%%DATADIR%%/pic/popwidget.png
@@ -35,6 +38,7 @@ share/icons/qterm.png
%%DATADIR%%/pic/reconnect.png
%%DATADIR%%/pic/rect.png
%%DATADIR%%/pic/refresh.png
+%%DATADIR%%/pic/shadow.png
%%DATADIR%%/pic/sound.png
%%DATADIR%%/pic/tabpad.png
%%DATADIR%%/po/qterm_chs.qm
@@ -56,5 +60,5 @@ share/icons/qterm.png
@dirrm %%DATADIR%%/pic
@dirrm %%DATADIR%%/cursor
@dirrm %%DATADIR%%
-@dirrm share/icons
-@dirrm share/applications
+@dirrmtry share/icons
+@dirrmtry share/applications