aboutsummaryrefslogtreecommitdiff
path: root/chinese/sourcehansans-sc-otf
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-03-13 16:27:39 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-03-13 16:27:39 +0000
commitd53ae6f27e99ef57b54ddf1d39f88d31c4daa35e (patch)
treeccf0bd993813db6313de167ea2348c883bcd73e4 /chinese/sourcehansans-sc-otf
parent62241438ae63a34ab6c629162c006978b7a21a28 (diff)
downloadports-d53ae6f27e99ef57b54ddf1d39f88d31c4daa35e.tar.gz
ports-d53ae6f27e99ef57b54ddf1d39f88d31c4daa35e.zip
Notes
Diffstat (limited to 'chinese/sourcehansans-sc-otf')
-rw-r--r--chinese/sourcehansans-sc-otf/Makefile49
-rw-r--r--chinese/sourcehansans-sc-otf/distinfo3
-rw-r--r--chinese/sourcehansans-sc-otf/files/pkg-message.in7
-rw-r--r--chinese/sourcehansans-sc-otf/pkg-descr14
-rw-r--r--chinese/sourcehansans-sc-otf/pkg-plist16
5 files changed, 89 insertions, 0 deletions
diff --git a/chinese/sourcehansans-sc-otf/Makefile b/chinese/sourcehansans-sc-otf/Makefile
new file mode 100644
index 000000000000..1e9c2f8ddaa5
--- /dev/null
+++ b/chinese/sourcehansans-sc-otf/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= sourcehansans
+PORTVERSION= 2.000
+DISTVERSIONSUFFIX= R
+CATEGORIES= chinese x11-fonts
+PKGNAMESUFFIX= -sc-otf
+# Note: the following PKGNAMEPREFIX is here only for self-documenting purpose;
+# actual prefixing is done by the `chinese' category itself.
+#PKGNAMEPREFIX= zh-
+
+MAINTAINER= hyun@caffeinated.codes
+COMMENT= Simplified Chinese font by Adobe designed for user interfaces
+
+LICENSE= OFL11
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= fonts
+USE_GITHUB= yes
+GH_ACCOUNT= adobe-fonts
+GH_PROJECT= source-han-sans
+
+NO_ARCH= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= HW
+OPTIONS_SINGLE= TYPE
+OPTIONS_SINGLE_TYPE= FULL SUBSET
+OPTIONS_DEFAULT= FULL
+OPTIONS_SUB= yes
+
+HW_DESC= Install the half-width font in addition to the full font
+FULL_DESC= Install the full font (can display all CJK)
+SUBSET_DESC= Install the subset font (can display SC only)
+SUBSET_PREVENTS= HW
+SUBSET_PREVENTS_MSG= Half-width can only be installed in addition to the full font
+
+FULL_VARS= FONTNAME=SourceHanSansSC SRCFONTSDIR=OTF/SimplifiedChinese
+SUBSET_VARS= FONTNAME=SourceHanSansCN SRCFONTSDIR=SubsetOTF/CN
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${SRCFONTSDIR}/*.otf ${STAGEDIR}${FONTSDIR}
+
+post-install-HW-on:
+ ${INSTALL_DATA} ${WRKSRC}/OTF/SimplifiedChineseHW/*.otf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/sourcehansans-sc-otf/distinfo b/chinese/sourcehansans-sc-otf/distinfo
new file mode 100644
index 000000000000..4a60feacb6f4
--- /dev/null
+++ b/chinese/sourcehansans-sc-otf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543452538
+SHA256 (adobe-fonts-source-han-sans-2.000R_GH0.tar.gz) = 3c4dae5225605a90f115570d1c6a86eea8e6b04057297a5566f72f4e48ed0aa8
+SIZE (adobe-fonts-source-han-sans-2.000R_GH0.tar.gz) = 2093662207
diff --git a/chinese/sourcehansans-sc-otf/files/pkg-message.in b/chinese/sourcehansans-sc-otf/files/pkg-message.in
new file mode 100644
index 000000000000..2e8f2addd159
--- /dev/null
+++ b/chinese/sourcehansans-sc-otf/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+You can start using the font by following this instruction:
+
+Add the following line to the "Files" section of your X.org configuration file:
+
+ FontPath "%%FONTSDIR%%/"
+
diff --git a/chinese/sourcehansans-sc-otf/pkg-descr b/chinese/sourcehansans-sc-otf/pkg-descr
new file mode 100644
index 000000000000..ca61ab235fd7
--- /dev/null
+++ b/chinese/sourcehansans-sc-otf/pkg-descr
@@ -0,0 +1,14 @@
+Source Han Sans: A new open source Pan-CJK typeface family from Adobe
+
+This is Source Han Sans SC/CN, which supports all four variants in this family
+but prioritizes Simplified Chinese Hanzi over other three.
+
+"Source Han Sans, available in seven weights, is a typeface family which
+provides full support for Japanese, Korean, Traditional Chinese, and Simplified
+Chinese, all in one font. It also includes Latin, Greek, and Cyrillic glyphs
+from our popular Source Sans family. All told, each font weight in the family
+has a total of 65,535 glyphs (the maximum supported in the OpenType format), and
+the entire family rounds out at just under half a million total glyphs."
+--- The Typekit Blog, Adobe
+
+WWW: https://github.com/adobe-fonts/source-han-sans
diff --git a/chinese/sourcehansans-sc-otf/pkg-plist b/chinese/sourcehansans-sc-otf/pkg-plist
new file mode 100644
index 000000000000..20b1d734175d
--- /dev/null
+++ b/chinese/sourcehansans-sc-otf/pkg-plist
@@ -0,0 +1,16 @@
+%%HW%%%%FONTSDIR%%/SourceHanSansHWSC-Bold.otf
+%%HW%%%%FONTSDIR%%/SourceHanSansHWSC-Regular.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansSC-Bold.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansSC-ExtraLight.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansSC-Heavy.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansSC-Light.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansSC-Medium.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansSC-Normal.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansSC-Regular.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansCN-Bold.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansCN-ExtraLight.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansCN-Heavy.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansCN-Light.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansCN-Medium.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansCN-Normal.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansCN-Regular.otf