aboutsummaryrefslogtreecommitdiff
path: root/chinese/sunpinyin/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-11 02:46:16 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-11 02:46:16 +0000
commit4f88e888c0c58f13245f2f2290e188988a8e6201 (patch)
tree6f3b5a1b148a50131b042de47ba1f4eb84f24602 /chinese/sunpinyin/Makefile
parent76793f1b749e7b279ffb78980d56ce8c4db5ea6a (diff)
downloadports-4f88e888c0c58f13245f2f2290e188988a8e6201.tar.gz
ports-4f88e888c0c58f13245f2f2290e188988a8e6201.zip
Notes
Diffstat (limited to 'chinese/sunpinyin/Makefile')
-rw-r--r--chinese/sunpinyin/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/chinese/sunpinyin/Makefile b/chinese/sunpinyin/Makefile
new file mode 100644
index 000000000000..107dd9fb138b
--- /dev/null
+++ b/chinese/sunpinyin/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: sunpinyin
+# Date created: 10 Nov 2011
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sunpinyin
+PORTVERSION= 2.0.3
+CATEGORIES= chinese devel
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}:1 \
+ http://open-gram.googlecode.com/files/:2
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:1 \
+ lm_sc.t3g.arpa.tar.bz2:2 dict.utf8.tar.bz2:2
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A statistical language model based input method engine
+
+LICENSE= LGPL21 CDDL
+LICENSE_COMB= dual
+
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
+
+LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL.LICENSE
+LICENSE_FILE_CDDL= ${WRKSRC}/OPENSOLARIS.LICENSE
+
+USE_SCONS= yes
+SCONS_ARGS+= --prefix=${PREFIX} --libdatadir=${PREFIX}/share
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+post-patch:
+ @${CP} ${_DISTDIR}/lm_sc.t3g.arpa.tar.bz2 \
+ ${_DISTDIR}/dict.utf8.tar.bz2 ${WRKSRC}/raw
+
+.include <bsd.port.mk>