aboutsummaryrefslogtreecommitdiff
path: root/chinese/sunpinyin
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-05-25 07:25:44 +0000
committerWen Heping <wen@FreeBSD.org>2012-05-25 07:25:44 +0000
commit6507fdb245a42b2b8fa3b5b0d71801824cb4aaf5 (patch)
tree4754ce184885e1fcf87fa1a4c6c30f0d32d543de /chinese/sunpinyin
parentd77ee3ea892ce95e452923cc5fa1357185335ed3 (diff)
downloadports-6507fdb245a42b2b8fa3b5b0d71801824cb4aaf5.tar.gz
ports-6507fdb245a42b2b8fa3b5b0d71801824cb4aaf5.zip
Notes
Diffstat (limited to 'chinese/sunpinyin')
-rw-r--r--chinese/sunpinyin/Makefile7
-rw-r--r--chinese/sunpinyin/distinfo12
-rw-r--r--chinese/sunpinyin/files/patch-2.0.4-compatible88
-rw-r--r--chinese/sunpinyin/files/patch-xdg28
-rw-r--r--chinese/sunpinyin/pkg-plist2
5 files changed, 30 insertions, 107 deletions
diff --git a/chinese/sunpinyin/Makefile b/chinese/sunpinyin/Makefile
index 48e23e5e7c61..5312156406e5 100644
--- a/chinese/sunpinyin/Makefile
+++ b/chinese/sunpinyin/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= sunpinyin
-PORTVERSION= 2.0.3
-PORTREVISION= 1
+DISTVERSION= 2.0.4rc1
CATEGORIES= chinese devel
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}:1 \
+MASTER_SITES= LOCAL/wen:1 \
+ ${MASTER_SITE_GOOGLE_CODE}:1 \
http://open-gram.googlecode.com/files/:2
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:1 \
lm_sc.t3g.arpa.tar.bz2:2 dict.utf8.tar.bz2:2
@@ -27,6 +27,7 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL.LICENSE
LICENSE_FILE_CDDL= ${WRKSRC}/OPENSOLARIS.LICENSE
+USE_XZ= yes
USE_SCONS= yes
SCONS_ARGS+= --prefix=${PREFIX} --libdatadir=${PREFIX}/share
USE_LDCONFIG= yes
diff --git a/chinese/sunpinyin/distinfo b/chinese/sunpinyin/distinfo
index 3397689b52ab..705b0eb89484 100644
--- a/chinese/sunpinyin/distinfo
+++ b/chinese/sunpinyin/distinfo
@@ -1,6 +1,6 @@
-SHA256 (sunpinyin-2.0.3.tar.gz) = 4ab776e7563f69f8dbda8fac7cfaa42bd0db1ea68bab15f756094ce5398d83d1
-SIZE (sunpinyin-2.0.3.tar.gz) = 169394
-SHA256 (lm_sc.t3g.arpa.tar.bz2) = e66380518ba51c5c666babc09e91c253c8bb5809f6d853e9a56f0368f057659e
-SIZE (lm_sc.t3g.arpa.tar.bz2) = 35959362
-SHA256 (dict.utf8.tar.bz2) = 42f8eb6e8e4de809022069f25ff82a20c09f43b705fa2946162a92960857c97c
-SIZE (dict.utf8.tar.bz2) = 496006
+SHA256 (sunpinyin-2.0.4rc1.tar.xz) = e8d752ca3fdf475cb097e71dfae3fbf7e118c373a3ea98d3742fc12ae838594e
+SIZE (sunpinyin-2.0.4rc1.tar.xz) = 969976
+SHA256 (lm_sc.t3g.arpa.tar.bz2) = 5fcbb6264befd03a75fad1301b8804a8df52972b2ea91045c7f2613904bbc6c7
+SIZE (lm_sc.t3g.arpa.tar.bz2) = 36280876
+SHA256 (dict.utf8.tar.bz2) = d0bcbc5b7005823e69c490a178d456d476069c640bf292028282e9a94d784418
+SIZE (dict.utf8.tar.bz2) = 583655
diff --git a/chinese/sunpinyin/files/patch-2.0.4-compatible b/chinese/sunpinyin/files/patch-2.0.4-compatible
deleted file mode 100644
index 677c0f9859e3..000000000000
--- a/chinese/sunpinyin/files/patch-2.0.4-compatible
+++ /dev/null
@@ -1,88 +0,0 @@
---- src/ime-core/imi_view_classic.h.orig 2011-02-17 21:39:52.000000000 -0600
-+++ src/ime-core/imi_view_classic.h 2011-11-10 23:00:20.374788681 -0600
-@@ -61,6 +61,9 @@ public:
- virtual int onCandidatePageRequest(int pgno, bool relative);
- virtual int onCandidateSelectRequest(int index);
-
-+ void makeSelection(int candiIdx, unsigned& mask);
-+ void deleteCandidate(int candiIdx, unsigned& mask);
-+
- private:
- unsigned m_cursorFrIdx;
- unsigned m_candiFrIdx;
-@@ -75,8 +78,6 @@ private:
- inline void _erase (bool backward, unsigned& mask);
-
- inline void _getCandidates ();
-- inline void _makeSelection (int candiIdx, unsigned& mask);
-- inline void _deleteCandidate (int candiIdx, unsigned& mask);
-
- inline void _commitChar (TWCHAR ch);
- inline void _commitString (const wstring& wstr);
---- src/ime-core/imi_view_classic.cpp.orig 2011-02-17 21:39:52.000000000 -0600
-+++ src/ime-core/imi_view_classic.cpp 2011-11-10 23:01:01.213605402 -0600
-@@ -168,7 +168,7 @@ CIMIClassicView::onKeyEvent(const CKeyEv
- !m_pIC->isEmpty ()) {
- changeMasks |= KEYEVENT_USED;
- unsigned sel = (keyvalue == '0'? 9: keyvalue-'1');
-- _deleteCandidate (sel, changeMasks);
-+ deleteCandidate (sel, changeMasks);
- goto PROCESSED;
-
- } else if ((modifiers & (IM_CTRL_MASK | IM_ALT_MASK | IM_SUPER_MASK | IM_RELEASE_MASK)) == 0) {
-@@ -177,7 +177,7 @@ CIMIClassicView::onKeyEvent(const CKeyEv
- if (!m_pIC->isEmpty ()) {
- changeMasks |= KEYEVENT_USED;
- unsigned sel = (keyvalue == '0'? 9: keyvalue-'1');
-- _makeSelection (sel, changeMasks);
-+ makeSelection (sel, changeMasks);
- } else {
- m_numeric_mode = true;
- }
-@@ -216,7 +216,7 @@ CIMIClassicView::onKeyEvent(const CKeyEv
- } else if (keycode == IM_VK_SPACE) {
- if (!m_pIC->isEmpty ()) {
- changeMasks |= KEYEVENT_USED;
-- _makeSelection (0, changeMasks);
-+ makeSelection (0, changeMasks);
- } else {
- wstring wstr = (m_pIC->fullPuncOp()) (keyvalue);
- if (wstr.size()) {
-@@ -327,7 +327,7 @@ CIMIClassicView::onCandidateSelectReques
- unsigned changeMasks = 0;
-
- if (!m_pIC->isEmpty())
-- _makeSelection(index, changeMasks);
-+ makeSelection(index, changeMasks);
-
- updateWindows(changeMasks);
- return 0;
-@@ -612,7 +612,7 @@ CIMIClassicView::_moveEnd (unsigned& mas
- }
-
- void
--CIMIClassicView::_makeSelection (int candiIdx, unsigned& mask)
-+CIMIClassicView::makeSelection (int candiIdx, unsigned& mask)
- {
- candiIdx += m_candiPageFirst;
- if (!m_tailSentence.empty ()) --candiIdx;
-@@ -655,7 +655,7 @@ CIMIClassicView::_makeSelection (int can
- }
-
- void
--CIMIClassicView::_deleteCandidate (int candiIdx, unsigned& mask)
-+CIMIClassicView::deleteCandidate (int candiIdx, unsigned& mask)
- {
- candiIdx += m_candiPageFirst;
- if (!m_tailSentence.empty ()) --candiIdx;
---- src/ime-core/imi_view.h.orig 2011-02-17 21:39:52.000000000 -0600
-+++ src/ime-core/imi_view.h 2011-11-10 23:05:14.515633839 -0600
-@@ -188,7 +188,7 @@ public:
- CIMIWinHandler* getWinHandler(void) {return m_pWinHandler;}
-
- void setHotkeyProfile (CHotkeyProfile *prof) { m_pHotkeyProfile = prof;}
-- void setCandiWindowSize (unsigned size) {m_candiWindowSize = size<10? size: 10;}
-+ void setCandiWindowSize (unsigned size) {m_candiWindowSize = size;}
- CHotkeyProfile* getHotkeyProfile() { return m_pHotkeyProfile; }
- unsigned getCandiWindowSize() { return m_candiWindowSize; }
-
diff --git a/chinese/sunpinyin/files/patch-xdg b/chinese/sunpinyin/files/patch-xdg
index 69361e1e22e8..40f4ffd6a355 100644
--- a/chinese/sunpinyin/files/patch-xdg
+++ b/chinese/sunpinyin/files/patch-xdg
@@ -1,17 +1,24 @@
-diff -uNr src/ime-core/imi_options.cpp src/ime-core/imi_options.cpp
---- src/ime-core/imi_options.cpp 2010-09-22 13:14:32.876000000 +0800
-+++ src/ime-core/imi_options.cpp 2010-09-22 13:21:48.181000000 +0800
-@@ -73,8 +73,11 @@
+--- src/ime-core/imi_options.cpp~ 2012-05-13 22:55:19.000000000 -0500
++++ src/ime-core/imi_options.cpp 2012-05-13 23:08:27.566965023 -0500
+@@ -73,12 +73,15 @@ CSimplifiedChinesePolicy::loadResources(
if (!m_user_data_dir.size()) {
char path[256];
-- const char *home = getenv ("HOME");
-- snprintf (path, sizeof(path), "%s/%s", home, SUNPINYIN_USERDATA_DIR_PREFIX);
-+ const char *home = getenv ("XDG_CONFIG_HOME");
-+ if(home == NULL)
-+ snprintf (path, sizeof(path), "%s/.config/%s", getenv("HOME"), SUNPINYIN_USERDATA_DIR_PREFIX);
+- const char *home = getenv("HOME");
+- snprintf(path,
+- sizeof(path),
+- "%s/%s",
+- home,
+- SUNPINYIN_USERDATA_DIR_PREFIX);
++ const char *home = getenv("XDG_CONFIG_HOME");
++ if (home == NULL)
++ snprintf(path, sizeof(path),
++ "%s/.config/%s", getenv("HOME"),
++ SUNPINYIN_USERDATA_DIR_PREFIX);
+ else
-+ snprintf (path, sizeof(path), "%s/%s", home, SUNPINYIN_USERDATA_DIR_PREFIX);
++ snprintf(path, sizeof(path),
++ "%s/%s", home,
++ SUNPINYIN_USERDATA_DIR_PREFIX);
m_user_data_dir = path;
}
@@ -27,3 +34,4 @@ diff -uNr src/ime-core/imi_options.h src/ime-core/imi_options.h
#endif
struct CSimplifiedChinesePolicy : public IConfigurable
+
diff --git a/chinese/sunpinyin/pkg-plist b/chinese/sunpinyin/pkg-plist
index a20b43768ea1..98317b256586 100644
--- a/chinese/sunpinyin/pkg-plist
+++ b/chinese/sunpinyin/pkg-plist
@@ -3,10 +3,12 @@ include/sunpinyin-2.0/ime-core/imi_context.h
include/sunpinyin-2.0/ime-core/imi_data.h
include/sunpinyin-2.0/ime-core/imi_defines.h
include/sunpinyin-2.0/ime-core/imi_funcobjs.h
+include/sunpinyin-2.0/ime-core/imi_glibHandler.h
include/sunpinyin-2.0/ime-core/imi_keys.h
include/sunpinyin-2.0/ime-core/imi_option_event.h
include/sunpinyin-2.0/ime-core/imi_option_keys.h
include/sunpinyin-2.0/ime-core/imi_options.h
+include/sunpinyin-2.0/ime-core/imi_plugin.h
include/sunpinyin-2.0/ime-core/imi_uiobjects.h
include/sunpinyin-2.0/ime-core/imi_view.h
include/sunpinyin-2.0/ime-core/imi_view_classic.h