aboutsummaryrefslogtreecommitdiff
path: root/chinese/tin
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2012-01-02 15:34:21 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2012-01-02 15:34:21 +0000
commit2f2516d4df04f9ee2e7e9bbe7214ad2e476e6261 (patch)
tree98889b2e1d91fc8216b1786a4a99e99d9e4000b6 /chinese/tin
parentd2373e139b443953fe33170f43fc29796c7ae157 (diff)
downloadports-2f2516d4df04f9ee2e7e9bbe7214ad2e476e6261.tar.gz
ports-2f2516d4df04f9ee2e7e9bbe7214ad2e476e6261.zip
Notes
Diffstat (limited to 'chinese/tin')
-rw-r--r--chinese/tin/Makefile10
-rw-r--r--chinese/tin/files/patch-attrib.c26
-rw-r--r--chinese/tin/files/patch-cook.c15
-rw-r--r--chinese/tin/files/patch-init.c27
-rw-r--r--chinese/tin/files/patch-mail.c18
-rw-r--r--chinese/tin/files/patch-tin.defaults (renamed from chinese/tin/files/patch-tin_defaults)4
6 files changed, 35 insertions, 65 deletions
diff --git a/chinese/tin/Makefile b/chinese/tin/Makefile
index 3046d360733f..7b180f17d40b 100644
--- a/chinese/tin/Makefile
+++ b/chinese/tin/Makefile
@@ -6,22 +6,16 @@
# $FreeBSD$
#
-PORTREVISION= 3
CATEGORIES= chinese
-MAINTAINER= leeym@FreeBSD.org
-
-BROKEN= does not patch
+MAINTAINER= ports@FreeBSD.org
EXTRA_PATCHES= ${.CURDIR}/files/patch-attrib.c \
${.CURDIR}/files/patch-cook.c \
${.CURDIR}/files/patch-mail.c \
${.CURDIR}/files/patch-init.c \
- ${.CURDIR}/files/patch-tin_defaults
+ ${.CURDIR}/files/patch-tin.defaults
MASTERDIR= ${.CURDIR}/../../news/tin
-WITH_TIN_SCREEN=termcap
-CONFIGURE_ARGS= --disable-locale
-
.include "${MASTERDIR}/Makefile"
diff --git a/chinese/tin/files/patch-attrib.c b/chinese/tin/files/patch-attrib.c
index a2ede1710dbd..d179ff4f16a3 100644
--- a/chinese/tin/files/patch-attrib.c
+++ b/chinese/tin/files/patch-attrib.c
@@ -1,14 +1,12 @@
---- src/attrib.c.orig Wed Aug 20 19:19:52 2003
-+++ src/attrib.c Wed Aug 20 19:23:06 2003
-@@ -687,6 +687,11 @@
- fprintf(fp, "post_proc_type=%d\n", POST_PROC_YES);
- fprintf(fp, "delete_tmp_files=ON\n");
- fprintf(fp, "followup_to=poster\n\n");
-+
-+ fprintf(fp, _("# set charset to Big5 in all newsgroups\n"));
-+ fprintf(fp, "scope=*\n");
-+ fprintf(fp, "mm_network_charset=Big5\n");
-+ fprintf(fp, "undeclared_charset=Big5\n");
- } else {
- char *ptr;
- char buf[LEN];
+--- src/attrib.c.orig 2011-09-18 04:55:30.000000000 -0700
++++ src/attrib.c 2012-01-02 03:14:00.000000000 -0800
+@@ -548,6 +548,9 @@
+ add_scope("*");
+ snprintf(buf, sizeof(buf), "%s", "~/.tin/headers");
+ set_attrib(OPT_ATTRIB_X_HEADERS, "*", "", buf);
++ num = 25;
++ set_attrib(OPT_ATTRIB_MM_NETWORK_CHARSET, "*", "", (char *) &num);
++ set_attrib(OPT_ATTRIB_UNDECLARED_CHARSET, "*", "", "Big5");
+
+ add_scope("*sources*");
+ num = POST_PROC_SHAR;
diff --git a/chinese/tin/files/patch-cook.c b/chinese/tin/files/patch-cook.c
index a51fbc0cb991..a8916bf1b63e 100644
--- a/chinese/tin/files/patch-cook.c
+++ b/chinese/tin/files/patch-cook.c
@@ -1,16 +1,15 @@
---- src/cook.c.orig Wed Dec 1 18:48:37 2004
-+++ src/cook.c Fri Mar 18 23:34:58 2005
-@@ -408,8 +408,13 @@
- if (!(line && strlen(line)))
+--- src/cook.c.orig 2011-08-18 03:58:24.288554846 +0800
++++ src/cook.c 2011-08-18 13:36:23.791151539 +0800
+@@ -472,7 +472,12 @@
break; /* premature end of file, file error etc. */
-+#ifndef CHARSET_CONVERSION
/* convert network to local charset, tex2iso, iso2asc etc. */
++#ifndef CHARSET_CONVERSION
process_charsets(&line, &max_line_len, get_param(part->params, "charset"), tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
+#else
-+ // force to use undeclared_charset first
-+ process_charsets(&line, &max_line_len, (curr_group->attribute->undeclared_charset) ? (curr_group->attribute->undeclared_charset) : get_param(part->params, "charset"), tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
-+#endif /* !CHARSET_CONVERSION */
++ /* use undeclared charset */
++ process_charsets(&line, &max_line_len, get_param(part->params, "charset") ? get_param(part->params, "charset") : curr_group->attribute->undeclared_charset, tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
++#endif
#if defined(MULTIBYTE_ABLE) && !defined(NO_LOCALE)
if (IS_LOCAL_CHARSET("UTF-8"))
diff --git a/chinese/tin/files/patch-init.c b/chinese/tin/files/patch-init.c
index 16486b0046cd..ef36fa3aafec 100644
--- a/chinese/tin/files/patch-init.c
+++ b/chinese/tin/files/patch-init.c
@@ -1,26 +1,6 @@
---- src/init.c.orig Sun Aug 10 09:37:40 2003
-+++ src/init.c Wed Aug 20 19:23:32 2003
-@@ -282,8 +282,8 @@
- 32, /* groupname_max_length */
- UUE_NO, /* hide_uue */
- KILL_UNREAD, /* kill_level */
-- MIME_ENCODING_7BIT, /* mail_mime_encoding */
-- MIME_ENCODING_7BIT, /* post_mime_encoding */
-+ MIME_ENCODING_8BIT, /* mail_mime_encoding */
-+ MIME_ENCODING_8BIT, /* post_mime_encoding */
- POST_PROC_NO, /* post_process */
- REREAD_ACTIVE_FILE_SECS, /* reread_active_file_secs */
- 1, /* scroll_lines */
-@@ -330,7 +330,7 @@
- TRUE, /* word_highlight */
- 0, /* wrap_column */
- #ifdef HAVE_COLOR
-- FALSE, /* use_color */
-+ TRUE, /* use_color */
- #endif /* HAVE_COLOR */
- TRUE, /* add_posted_to_filter */
- TRUE, /* advertising */
-@@ -360,12 +360,12 @@
+--- src/init.c.orig 2011-08-18 12:58:08.564585495 +0800
++++ src/init.c 2011-08-18 12:58:30.264685035 +0800
+@@ -354,11 +354,11 @@
#endif /* USE_INVERSE_HACK */
TRUE, /* keep_dead_articles */
POSTED_FILE, /* posted_articles_file */
@@ -28,7 +8,6 @@
+ TRUE, /* mail_8bit_header */
FALSE, /* mark_ignore_tags */
TRUE, /* mark_saved_read */
- TRUE, /* pgdn_goto_next */
TRUE, /* pos_first_unread */
- FALSE, /* post_8bit_header */
+ TRUE, /* post_8bit_header */
diff --git a/chinese/tin/files/patch-mail.c b/chinese/tin/files/patch-mail.c
index 63e977afc71d..11b01f140cea 100644
--- a/chinese/tin/files/patch-mail.c
+++ b/chinese/tin/files/patch-mail.c
@@ -1,15 +1,15 @@
---- src/mail.c.orig Sun Aug 10 21:27:36 2003
-+++ src/mail.c Wed Oct 8 14:52:42 2003
-@@ -327,7 +327,12 @@
- *
- * TODO: change US-ASCII to UTF-8 when NNTP draft becomes RFC
+--- src/mail.c.orig 2011-04-17 15:14:00.000000000 -0700
++++ src/mail.c 2012-01-02 05:08:38.000000000 -0800
+@@ -510,7 +510,12 @@
+ /*
+ * Protect against invalid character sequences.
*/
+#ifndef CHARSET_CONVERSION
- process_charsets(&r, &r_len, "US-ASCII", tinrc.mm_local_charset, FALSE);
+ process_charsets(&r, &r_len, "UTF-8", tinrc.mm_local_charset, FALSE);
+#else
-+ process_charsets(&r, &r_len, (CURR_GROUP.attribute->undeclared_charset) ? (CURR_GROUP.attribute->undeclared_charset) : "US-ASCII", tinrc.mm_local_charset, FALSE);
-+#endif /* !CHARSET_CONVERSION */
++ process_charsets(&r, &r_len, (CURR_GROUP.attribute->undeclared_charset) ? (CURR_GROUP.attribute->undeclared_charset) : "UTF-8", tinrc.mm_local_charset, FALSE);
++#endif
+
- group->description = convert_to_printable(r);
+ group->description = convert_to_printable(r, FALSE);
}
diff --git a/chinese/tin/files/patch-tin_defaults b/chinese/tin/files/patch-tin.defaults
index 3369aaf00fcf..760b9d15f154 100644
--- a/chinese/tin/files/patch-tin_defaults
+++ b/chinese/tin/files/patch-tin.defaults
@@ -1,5 +1,5 @@
---- doc/tin.defaults~~ Thu Oct 9 22:01:04 2003
-+++ doc/tin.defaults Thu Oct 9 22:01:14 2003
+--- doc/tin.defaults.orig 2011-08-18 05:28:38.347241197 +0800
++++ doc/tin.defaults 2011-08-18 05:29:00.242883933 +0800
@@ -55,7 +55,7 @@
# idea to set mm_charset here for providing a default
# in most western countries ISO-8859-1 might be the best value