aboutsummaryrefslogtreecommitdiff
path: root/chinese/wangttf/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-12-02 09:32:25 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-12-02 09:32:25 +0000
commit198caae13771cda46021f0b9dc573363325eb63f (patch)
tree981225c330f70ed7bf306f0506bf594fa3b92229 /chinese/wangttf/Makefile
parent0154eba66fc2b2aa89dc48d283d327bf00196005 (diff)
downloadports-198caae13771cda46021f0b9dc573363325eb63f.tar.gz
ports-198caae13771cda46021f0b9dc573363325eb63f.zip
Notes
Diffstat (limited to 'chinese/wangttf/Makefile')
-rw-r--r--chinese/wangttf/Makefile39
1 files changed, 20 insertions, 19 deletions
diff --git a/chinese/wangttf/Makefile b/chinese/wangttf/Makefile
index 556b5e90b98f..78a3bae61784 100644
--- a/chinese/wangttf/Makefile
+++ b/chinese/wangttf/Makefile
@@ -1,38 +1,39 @@
# New ports collection makefile for: zh-wangttf
-# Date created: 1 Sep 2004
-# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+# Date created: 2006/12/01
+# Whom: chinsan <chinsan.tw@gmail.com>
+# Origin: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+# 2004/09/01
#
# $FreeBSD$
#
PORTNAME= wangttf
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= chinese x11-fonts
-MASTER_SITES= ftp://cle.linux.org.tw/pub/fonts/wangfonts/ \
- ftp://cle.linux.org.tw/pub/fonts/wangfonts/WCL/
-DISTFILES= wp010-05.ttf wp010-08.ttf wp110-05.ttf wp110-08.ttf \
- wp210-05.ttf wp210-08.ttf wp310-05.ttf wp310-08.ttf \
- wt001.ttf wt002.ttf wt003.ttf wt004.ttf wt005.ttf \
- wt006.ttf wt009.ttf wt011.ttf wt014.ttf wt021.ttf \
- wt024.ttf wt028.ttf wt034.ttf wt040.ttf wt064.ttf \
- wt071.ttf wtcc02.ttf wtcc15.ttf wtg-06cut1x.ttf \
- wthc06.ttf wts11.ttf wts43.ttf wts47.ttf wts55.ttf \
- WCL-01.ttf WCL-02.ttf WCL-03.ttf WCL-04.ttf WCL-05.ttf \
- WCL-06.ttf WCL-07.ttf WCL-08.ttf WCL-09.ttf WCL-10.ttf
+MASTER_SITES= http://cle.linux.org.tw/fonts/wangfonts/:main \
+ http://cle.linux.org.tw/fonts/truetype/:another \
+ ftp://cle.linux.org.tw/pub2/fonts/wangfonts/:main \
+ ftp://cle.linux.org.tw/pub2/fonts/truetype/:another
+DISTFILES= wp010-05.ttf:main wp010-08.ttf:main wp110-05.ttf:main \
+ wp110-08.ttf:main wp210-05.ttf:main wp210-08.ttf:main \
+ wp310-05.ttf:main wp310-08.ttf:main wts11.ttf:main \
+ wts43.ttf:main wts47.ttf:main wts55.ttf:main \
+ wcl-01.ttf:another wcl-02.ttf:another wcl-03.ttf:another \
+ wcl-04.ttf:another wcl-05.ttf:another wcl-06.ttf:another \
+ wcl-07.ttf:another wcl-08.ttf:another wcl-09.ttf:another \
+ wcl-10.ttf:another
EXTRACT_ONLY=
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= chinsan@FreeBSD.org
COMMENT= Many Chinese Big5 TrueType fonts, made by Dr. Hann-Tzong Wang
-NO_PACKAGE= "Package will be 190MB, set FORCE_PACKAGE if you really want to build it"
-
-DEPRECATED= mastersite disappeared, no longer maintained by author"
-EXPIRATION_DATE= 2005-12-31
+NO_PACKAGE= Package will be 216MB, set FORCE_PACKAGE if you really want to build it
DIST_SUBDIR= zh-wangttf
NO_BUILD= yes
-TTF= ${DISTFILES}
+TTF= ${DISTFILES:C/:[^:]+$//}
PORTDOCS= wangttf.txt
do-install: