aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2018-06-13 03:24:40 +0000
committerKevin Lo <kevlo@FreeBSD.org>2018-06-13 03:24:40 +0000
commit1377dcaf29d80a1de9682aa9eb111caf9e3c5a3e (patch)
treeea30070811c89c106a855208df97317adc755c93 /chinese
parent693629c61aa314e13cadfdf8573b4d8995b17e50 (diff)
downloadports-1377dcaf29d80a1de9682aa9eb111caf9e3c5a3e.tar.gz
ports-1377dcaf29d80a1de9682aa9eb111caf9e3c5a3e.zip
Remove chinese/unrar, use archivers/unrar instead.
Notes
Notes: svn path=/head/; revision=472281
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/unrar/Makefile15
-rw-r--r--chinese/unrar/files/patch-arcread.cpp27
-rw-r--r--chinese/unrar/files/patch-unicode.cpp10
4 files changed, 0 insertions, 53 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index e32c5fb1bee1..00607d2d9857 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -108,7 +108,6 @@
SUBDIR += tintin++
SUBDIR += ttf2pt1
SUBDIR += ttfm
- SUBDIR += unrar
SUBDIR += ve
SUBDIR += wenju
SUBDIR += wordpress-zh_CN
diff --git a/chinese/unrar/Makefile b/chinese/unrar/Makefile
deleted file mode 100644
index c7ca793193d4..000000000000
--- a/chinese/unrar/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-# Created by: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
-# $FreeBSD$
-
-CATEGORIES= chinese
-
-MAINTAINER= sunpoet@FreeBSD.org
-
-MASTERDIR= ${.CURDIR}/../../archivers/unrar
-
-EXTRA_PATCHES= ${.CURDIR}/files/patch-arcread.cpp \
- ${.CURDIR}/files/patch-unicode.cpp
-
-CONFLICTS_INSTALL= unrar unrar-iconv
-
-.include "${MASTERDIR}/Makefile"
diff --git a/chinese/unrar/files/patch-arcread.cpp b/chinese/unrar/files/patch-arcread.cpp
deleted file mode 100644
index a8c5a693d489..000000000000
--- a/chinese/unrar/files/patch-arcread.cpp
+++ /dev/null
@@ -1,27 +0,0 @@
---- arcread.cpp.orig 2017-04-28 17:28:45 UTC
-+++ arcread.cpp
-@@ -1308,6 +1308,7 @@ void Archive::ConvertAttributes()
-
- void Archive::ConvertFileHeader(FileHeader *hd)
- {
-+ int big5=0;
- if (Format==RARFMT15 && hd->UnpVer<20 && (hd->FileAttr & 0x10))
- hd->Dir=true;
- if (hd->HSType==HSYS_UNKNOWN)
-@@ -1323,6 +1324,16 @@ void Archive::ConvertFileHeader(FileHead
-
- for (wchar *s=hd->FileName;*s!=0;s++)
- {
-+ if (big5==1) /* skip Big5 second byte */
-+ {
-+ big5=0;
-+ continue;
-+ }
-+ if ((byte)*s>127) /* Big5 first byte */
-+ {
-+ big5=1;
-+ continue;
-+ }
- #ifdef _UNIX
- // Backslash is the invalid character for Windows file headers,
- // but it can present in Unix file names extracted in Unix.
diff --git a/chinese/unrar/files/patch-unicode.cpp b/chinese/unrar/files/patch-unicode.cpp
deleted file mode 100644
index eb873acba057..000000000000
--- a/chinese/unrar/files/patch-unicode.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- unicode.cpp.orig 2017-04-28 17:28:47 UTC
-+++ unicode.cpp
-@@ -20,6 +20,7 @@ static const uint MappedStringMark=0xFFF
- bool WideToChar(const wchar *Src,char *Dest,size_t DestSize)
- {
- bool RetCode=true;
-+ return(RetCode); /* patch for chinese filename */
- *Dest=0; // Set 'Dest' to zero just in case the conversion will fail.
-
- #ifdef _WIN_ALL