aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-27 00:53:05 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-27 00:53:05 +0000
commit997c4f318dd2517faead78f006025ef23d64c9d0 (patch)
tree8528f4d05b0c64a9d97f5481887e0faf2266c176 /chinese
parent7cc0eb68542068c7c231371418a372d4ca288129 (diff)
downloadports-997c4f318dd2517faead78f006025ef23d64c9d0.tar.gz
ports-997c4f318dd2517faead78f006025ef23d64c9d0.zip
chinese/librime: unbreak with boost 1.69
CMake Error at /usr/local/share/cmake/Modules/FindBoost.cmake:2049 (message): Unable to find the requested Boost libraries. Boost version: 1.69.0 Boost include path: /usr/local/include Could not find the following Boost libraries: boost_signals Some (but not all) of the required Boost libraries were found. You may need to install these additional Boost libraries. Alternatively, set BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT to the location of Boost. Call Stack (most recent call first): CMakeLists.txt:41 (find_package) PR: 232525
Notes
Notes: svn path=/head/; revision=483074
Diffstat (limited to 'chinese')
-rw-r--r--chinese/librime/files/patch-boost-1.6913
1 files changed, 13 insertions, 0 deletions
diff --git a/chinese/librime/files/patch-boost-1.69 b/chinese/librime/files/patch-boost-1.69
new file mode 100644
index 000000000000..3873db20f1af
--- /dev/null
+++ b/chinese/librime/files/patch-boost-1.69
@@ -0,0 +1,13 @@
+https://github.com/rime/librime/issues/225
+
+--- CMakeLists.txt.orig 2014-12-21 11:46:44 UTC
++++ CMakeLists.txt
+@@ -38,7 +38,7 @@ set(Boost_USE_MULTITHREADED ON)
+ if(MSVC)
+ set(Boost_USE_STATIC_RUNTIME ON)
+ endif(MSVC)
+-find_package(Boost 1.46.0 REQUIRED COMPONENTS filesystem regex signals system)
++find_package(Boost 1.46.0 REQUIRED COMPONENTS filesystem regex system)
+ if(Boost_FOUND)
+ include_directories(${Boost_INCLUDE_DIRS})
+ link_directories(${Boost_LIBRARY_DIRS})