aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /chinese
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'chinese')
-rw-r--r--chinese/fcitx-libpinyin/Makefile3
-rw-r--r--chinese/fcitx/Makefile5
-rw-r--r--chinese/gcin-qt4/Makefile4
-rw-r--r--chinese/gcin-qt5/Makefile4
-rw-r--r--chinese/qt4-codecs-cn/Makefile4
-rw-r--r--chinese/qt4-codecs-tw/Makefile4
-rw-r--r--chinese/qterm/Makefile13
7 files changed, 21 insertions, 16 deletions
diff --git a/chinese/fcitx-libpinyin/Makefile b/chinese/fcitx-libpinyin/Makefile
index a5ec9d328094..c2f5da28676c 100644
--- a/chinese/fcitx-libpinyin/Makefile
+++ b/chinese/fcitx-libpinyin/Makefile
@@ -31,7 +31,8 @@ QT4_DESC= Enable Qt4 for dictmanager
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MQT4}
-USE_QT4= qmake_build moc_build rcc_build uic_build gui webkit
+USES+= qt:4
+USE_QT= qmake_build moc_build rcc_build uic_build gui webkit
USE_LDCONFIG= ${PREFIX}/lib/fcitx/qt
PLIST_SUB+= QT4=""
.else
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index 472450958e2e..17e966a8d1c2 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -39,7 +39,7 @@ USE_GNOME= pango intltool libxml2 introspection
USE_KDE= ecm
USE_XORG= x11 xext xkbfile sm ice
USE_LDCONFIG= yes
-USES= tar:xz cmake:noninja desktop-file-utils \
+USES= qt:4 tar:xz cmake:noninja desktop-file-utils \
gettext-tools:build,run gettext-runtime iconv:wchar_t \
kde:5 pkgconfig shared-mime-info
INSTALLS_ICONS= yes
@@ -87,7 +87,8 @@ SUB_LIST+= GTK3_IM=xim
.endif
.if ${PORT_OPTIONS:MQT4}
-USE_QT4+= qmake_build moc_build rcc_build uic_build dbus gui inputmethods corelib
+USES+= qt:4
+USE_QT+= qmake_build moc_build rcc_build uic_build dbus gui inputmethods corelib
USE_LDCONFIG+= ${PREFIX}/lib/fcitx/qt
PLIST_SUB+= QT4=""
.else
diff --git a/chinese/gcin-qt4/Makefile b/chinese/gcin-qt4/Makefile
index 98d6f3e314a5..f7abf42e8c17 100644
--- a/chinese/gcin-qt4/Makefile
+++ b/chinese/gcin-qt4/Makefile
@@ -16,8 +16,8 @@ LICENSE= LGPL21
LIB_DEPENDS= libgcin-im-client.so:chinese/gcin
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/qt4-im
-USES= gmake pkgconfig tar:xz
-USE_QT4= inputmethods qmake_build moc_build corelib gui
+USES= gmake pkgconfig qt:4 tar:xz
+USE_QT= inputmethods qmake_build moc_build corelib gui
MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
MKDIR="${MKDIR}"
diff --git a/chinese/gcin-qt5/Makefile b/chinese/gcin-qt5/Makefile
index 3f1bc70e6497..e076c1352771 100644
--- a/chinese/gcin-qt5/Makefile
+++ b/chinese/gcin-qt5/Makefile
@@ -17,8 +17,8 @@ LICENSE= LGPL21
LIB_DEPENDS= libgcin-im-client.so:chinese/gcin
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/qt5-im
-USES= compiler:c++11-lang gmake pkgconfig tar:xz
-USE_QT5= qdbus qmake_build buildtools_build core gui
+USES= compiler:c++11-lang gmake pkgconfig qt:5 tar:xz
+USE_QT= qdbus qmake_build buildtools_build core gui
USE_CXXSTD= c++11
MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
MKDIR="${MKDIR}"
diff --git a/chinese/qt4-codecs-cn/Makefile b/chinese/qt4-codecs-cn/Makefile
index 36129ec9cfc0..5b7f0382d944 100644
--- a/chinese/qt4-codecs-cn/Makefile
+++ b/chinese/qt4-codecs-cn/Makefile
@@ -11,8 +11,8 @@ PKGNAMESUFFIX= -cn
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt GB 18030 codec plugin
-USE_QT4= qmake_build corelib
-QT_DIST= yes
+USES= qmake:no_env qt-dist:4
+USE_QT= corelib
HAS_CONFIGURE= yes
diff --git a/chinese/qt4-codecs-tw/Makefile b/chinese/qt4-codecs-tw/Makefile
index 7deebcfbc62b..2447c8b3bdba 100644
--- a/chinese/qt4-codecs-tw/Makefile
+++ b/chinese/qt4-codecs-tw/Makefile
@@ -11,8 +11,8 @@ PKGNAMESUFFIX= -tw
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt Big-5 codec plugin
-USE_QT4= qmake_build corelib
-QT_DIST= yes
+USES= qmake:no_env qt-dist:4
+USE_QT= corelib
HAS_CONFIGURE= yes
diff --git a/chinese/qterm/Makefile b/chinese/qterm/Makefile
index b227fca586f4..836e4cc591e1 100644
--- a/chinese/qterm/Makefile
+++ b/chinese/qterm/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF/qterm/qterm/${PORTVERSION}
MAINTAINER= kaiwang27@gmail.com
COMMENT= BBS client for BSD/Linux
-USES= tar:bzip2 cmake perl5
+USES= qt:4 tar:bzip2 cmake perl5
USE_PERL5= build
-USE_QT4= codecs-cn_run codecs-tw_run gui help-tools_build \
+USE_QT= codecs-cn_run codecs-tw_run gui help-tools_build \
linguist_build moc_build network qt3support_build \
qmake_build rcc_build uic_build xml
USE_XORG= x11 ice
@@ -31,15 +31,18 @@ OPENSSL_USES= ssl
OPENSSL_CMAKE_ON= -DQTERM_ENABLE_SSH:BOOL=TRUE
OPENSSL_CMAKE_OFF= -DQTERM_ENABLE_SSH:BOOL=FALSE
-DBUS_USE= QT4=dbus
+DBUS_USES= qt:4
+DBUS_USE= QT=dbus
DBUS_CMAKE_ON= -DQTERM_ENABLE_DBUS:BOOL=TRUE
DBUS_CMAKE_OFF= -DQTERM_ENABLE_DBUS:BOOL=FALSE
-PHONON_USE= QT4=phonon
+PHONON_USES= qt:4
+PHONON_USE= QT=phonon
PHONON_CMAKE_ON= -DQTERM_ENABLE_PHONON:BOOL=TRUE
PHONON_CMAKE_OFF= -DQTERM_ENABLE_PHONON:BOOL=FALSE
-QTSCRIPT_USE= QT4=script
+QTSCRIPT_USES= qt:4
+QTSCRIPT_USE= QT=script
QTSCRIPT_RUN_DEPENDS= ${QT_PLUGINDIR}/script/libqtscript_core.so:devel/qtscriptgenerator
QTSCRIPT_CMAKE_ON= -DQTERM_ENABLE_SCRIPT:BOOL=TRUE
QTSCRIPT_CMAKE_OFF= -DQTERM_ENABLE_SCRIPT:BOOL=FALSE