aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorJing-Tang Keith Jang <keith@FreeBSD.org>2000-11-06 18:43:17 +0000
committerJing-Tang Keith Jang <keith@FreeBSD.org>2000-11-06 18:43:17 +0000
commit04586e3b44949d5f88b10d02520e1507b8cf8d2d (patch)
tree7407b9081ec650fe931a999f3fbf8393f1f40fdc /chinese
parent2593f0a3275d485f253480b055f4e380464bcb0a (diff)
downloadports-04586e3b44949d5f88b10d02520e1507b8cf8d2d.tar.gz
ports-04586e3b44949d5f88b10d02520e1507b8cf8d2d.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/linux-netscape47-communicator/Makefile92
-rw-r--r--chinese/linux-netscape47-communicator/distinfo1
-rw-r--r--chinese/linux-netscape47-communicator/pkg-comment1
-rw-r--r--chinese/linux-netscape47-communicator/pkg-descr11
-rw-r--r--chinese/linux-netscape47-communicator/pkg-plist126
-rw-r--r--chinese/linux-netscape47-navigator/Makefile11
6 files changed, 242 insertions, 0 deletions
diff --git a/chinese/linux-netscape47-communicator/Makefile b/chinese/linux-netscape47-communicator/Makefile
new file mode 100644
index 000000000000..8c2c8c640661
--- /dev/null
+++ b/chinese/linux-netscape47-communicator/Makefile
@@ -0,0 +1,92 @@
+# New ports collection makefile for: zh Big5/GB-ized Linux Netscape
+# Date created: 23 Oct 2000
+# Whom: Jing-Tang Keith Jang <keith@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${REGION}-netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VERSION}
+CATEGORIES= chinese www
+MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
+DISTNAME= ${REGION}-nskit-${BROWSER_VERSION}
+
+MAINTAINER= keith@FreeBSD.org
+
+# ?= is for ports that include this Makefile.
+# We need Arphic because there's no font with all sizes to deal with Java.
+RUN_DEPENDS?= \
+ /compat/linux/CLE-0.9p1:${PORTSDIR}/chinese/cle_base \
+ ${LOCALBASE}/bin/${BROWSER_ARC}-${BROWSER_VERSION}:${PORTSDIR}/www/linux-netscape47-${BROWSER} \
+ ${X11BASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/arphicttf
+
+# These variables can be defined in ports that include this Makefile.
+LOCALE?= zh_TW.Big5
+REGION?= tw
+BROWSER?= communicator
+BROWSER_VER?= 47
+BROWSER_VERSION?= 4.76
+BROWSER_ARC?= ${BROWSER}-linux
+BROWSER_BIN?= ${BROWSER_ARC}-${BROWSER_VERSION}.bin
+BROWSER_CMD?= ${REGION}-${BROWSER_ARC}-${BROWSER_VER}
+NSUBDIR?= lib/netscape-linux
+
+NO_BUILD= YES
+NSKITDIR= ${WRKDIR}/${REGION}-nskit-${BROWSER_VERSION}
+NDIR= ${PREFIX}/${NSUBDIR}
+PLIST_SUB= BROWSER=${BROWSER_ARC} VER=${BROWSER_VER} NSUBDIR=${NSUBDIR} LOCALE=${LOCALE} REGION=${REGION} X11BASE=${X11BASE}
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGMESSAGE= ${WRKDIR}/pkg-message
+# RDIR is the resource directory.
+MAKESCRIPT= ${SED} -e "s;@X11BASE@;${X11BASE};g" \
+ -e "s;@LOCALBASE@;${LOCALBASE};g" \
+ -e "s;@PREFIX@;${PREFIX};g" \
+ -e "s;@NDIR@;${NDIR};g" \
+ -e "s;@RDIR@;${NDIR};g" \
+ -e "s;@BROWSER_BIN@;${BROWSER_BIN};g" \
+ -e "s;@LOCALE@;${LOCALE};g"
+START_SCRIPT?= ${FILESDIR}/start.sh.in
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ ${MAKESCRIPT} ${START_SCRIPT} > ${WRKDIR}/${BROWSER_CMD}
+ ${MAKESCRIPT} ${FILESDIR}/INSTALL.in > ${WRKDIR}/pkg-install
+ ${MAKESCRIPT} ${FILESDIR}/MESSAGE.in > ${WRKDIR}/pkg-message
+ ${MAKESCRIPT} ${FILESDIR}/DEINSTALL.in > ${WRKDIR}/pkg-deinstall
+.if (${BROWSER} == navigator)
+ ${SED} "s/Communicator/Navigator/g" ${NSKITDIR}/Netscape.ad \
+ > ${NSKITDIR}/Netscape
+.else
+ ${CP} ${NSKITDIR}/Netscape.ad ${NSKITDIR}/Netscape
+.endif
+
+pre-install:
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+do-install:
+ ${INSTALL_DATA} ${NSKITDIR}/XLC_LOCALE.Big5 ${X11BASE}/lib/X11/locale/zh_TW.Big5/XLC_LOCALE
+ ${INSTALL_SCRIPT} ${WRKDIR}/${BROWSER_CMD} ${PREFIX}/bin/
+ ${LN} -sf ${BROWSER_CMD} ${PREFIX}/bin/netscape.run
+.for f in font.properties.zh_GB2312 font.properties.zh_TW_Big5
+ ${INSTALL_DATA} ${NSKITDIR}/$f ${NDIR}/java/classes
+.endfor
+ ${MKDIR} ${NDIR}/${LOCALE}
+ ${CP} -R ${NSKITDIR}/nethelp ${NDIR}/${LOCALE}/
+.for f in BDP_LICENSE Netscape Netscape.WheelMouse
+ ${INSTALL_DATA} ${NSKITDIR}/$f ${NDIR}/${LOCALE}/
+.endfor
+ ${INSTALL_DATA} ${NSKITDIR}/preferences.js ${NDIR}/${LOCALE}
+# I know Japanese & Korean's netscape ports all install netscape.cfg
+# in ${NSUBDIR}, but then only a single locale's netscape.cfg is available
+# to all users, which is unreasonable.
+ ${MKDIR} /compat/linux/usr/X11R6/lib/X11/${LOCALE}/app-defaults
+.for f in netscape.cfg netscape.jsc
+ ${INSTALL_DATA} ${NSKITDIR}/$f /compat/linux/usr/X11R6/lib/X11/${LOCALE}/app-defaults
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/chinese/linux-netscape47-communicator/distinfo b/chinese/linux-netscape47-communicator/distinfo
new file mode 100644
index 000000000000..ca7552e638da
--- /dev/null
+++ b/chinese/linux-netscape47-communicator/distinfo
@@ -0,0 +1 @@
+MD5 (tw-nskit-4.76.tar.gz) = 7f03f00526bbaf2fb9ca09e9594b7feb
diff --git a/chinese/linux-netscape47-communicator/pkg-comment b/chinese/linux-netscape47-communicator/pkg-comment
new file mode 100644
index 000000000000..338e4458f2a1
--- /dev/null
+++ b/chinese/linux-netscape47-communicator/pkg-comment
@@ -0,0 +1 @@
+Big5 localized Netscape
diff --git a/chinese/linux-netscape47-communicator/pkg-descr b/chinese/linux-netscape47-communicator/pkg-descr
new file mode 100644
index 000000000000..3d4f9ff52a72
--- /dev/null
+++ b/chinese/linux-netscape47-communicator/pkg-descr
@@ -0,0 +1,11 @@
+This port provides a Big5 localized Netscape, including menus,
+toolbars, error messages and many others. It also contains a
+libX11 fix, which allows Netscape to show Big5 buttons in html
+documents.
+
+The patches are mainly contributed by thhsieh@linux.org.tw &
+hcchu@r350.ee.ntu.edu.tw. The localized Netscape.Big5 is
+translated by Antony Shen <u8618806@cc.nctu.edu.tw>, with some
+modifications.
+
+Jing-Tang Keith Jang <keith@freebsd.sinica.edu.tw>
diff --git a/chinese/linux-netscape47-communicator/pkg-plist b/chinese/linux-netscape47-communicator/pkg-plist
new file mode 100644
index 000000000000..d5ee01a89f43
--- /dev/null
+++ b/chinese/linux-netscape47-communicator/pkg-plist
@@ -0,0 +1,126 @@
+bin/%%REGION%%-%%BROWSER%%-%%VER%%
+@exec ln -sf %f %B/netscape.run
+@unexec rm -f %B/netscape.run
+%%NSUBDIR%%/java/classes/font.properties.zh_GB2312
+%%NSUBDIR%%/java/classes/font.properties.zh_TW_Big5
+%%NSUBDIR%%/%%LOCALE%%/BDP_LICENSE
+%%NSUBDIR%%/%%LOCALE%%/Netscape
+%%NSUBDIR%%/%%LOCALE%%/Netscape.WheelMouse
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Back_dep.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Back_dis.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Back_sel.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Back_up.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Blank.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Button.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/CntData.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/CntTool.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/CntTool.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Exit_dep.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Exit_sel.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Exit_up.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Forw_dep.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Forw_dis.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Forw_sel.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Forw_up.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Header.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/IdxData.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/IdxFill.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/IdxKey.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/IdxTool.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/IdxTopic.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Local-1.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/NSHIfrm.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/NavUI.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/NoJSerr.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Prnt_dep.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Prnt_sel.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Prnt_up.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Stack.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Status.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/System.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/System.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/ToolUI.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Tool_dep.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Tool_sel.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Tool_up.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Topic.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Utility.js
+%%NSUBDIR%%/%%LOCALE%%/nethelp/Wait.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/collabra/coll.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/collabra/collHdr.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/collabra/collabra.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/collabra/discgrps.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/collabra/help.hpf
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/collabra/mailbox2.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/composer/comp.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/composer/compHdr.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/composer/composer.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/composer/comtlbr2.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/composer/fmtlbr3.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/composer/help.hpf
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/composer/tagicon2.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/home/help.hpf
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/home/home.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/home/home.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/home/homeHdr.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/abook.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/compbar.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/help.hpf
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/mailbox.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/mailbox2.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/mess.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/messHdr.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/messengr.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/mpctrl.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/newsgrp.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr/tabs.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/navigatr/help.hpf
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/navigatr/nav.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/navigatr/navHdr.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/navigatr/navigatr.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news/abook.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news/collabra.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news/compbar.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news/discgrps.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news/help.hpf
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news/mailbox2.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news/news.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news/newsgrp.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/NetHelpm.css
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/NetHelpu.css
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/NetHelpw.css
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/admnIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/calIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/collIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/commIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/compIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/confIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/ibmIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/messIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/navIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared/netIcon.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/trouble/help.hpf
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/trouble/trouble.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/netwatch.gif
+%%NSUBDIR%%/%%LOCALE%%/nethelp/picsfail.htm
+%%NSUBDIR%%/%%LOCALE%%/nethelp/picsfail.jar
+%%NSUBDIR%%/%%LOCALE%%/preferences.js
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/collabra
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/composer
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/home
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/messengr
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/navigatr
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/news
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/shared
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape/trouble
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp/netscape
+@dirrm %%NSUBDIR%%/%%LOCALE%%/nethelp
+@dirrm %%NSUBDIR%%/%%LOCALE%%
+@cwd %%X11BASE%%
+lib/X11/locale/zh_TW.Big5/XLC_LOCALE
+@cwd /compat/linux
+usr/X11R6/lib/X11/%%LOCALE%%/app-defaults/netscape.cfg
+usr/X11R6/lib/X11/%%LOCALE%%/app-defaults/netscape.jsc
+@unexec rmdir /compat/linux/usr/X11R6/lib/X11/%%LOCALE%%/app-defaults 2>/dev/null || true
+@unexec rmdir /compat/linux/usr/X11R6/lib/X11/%%LOCALE%% 2>/dev/null || true
+@unexec rmdir /compat/linux/usr/X11R6/lib/X11 2>/dev/null || true
diff --git a/chinese/linux-netscape47-navigator/Makefile b/chinese/linux-netscape47-navigator/Makefile
new file mode 100644
index 000000000000..38e56945c662
--- /dev/null
+++ b/chinese/linux-netscape47-navigator/Makefile
@@ -0,0 +1,11 @@
+# New ports collection makefile for: zh Big5/GB-ized Linux Netcape Navigator
+# Date created: 23 Oct 2000
+# Whom: Jing-Tang Keith Jang <keith@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+BROWSER= navigator
+
+MASTERDIR= ${.CURDIR}/../linux-netscape47-communicator
+.include "${.CURDIR}/../linux-netscape47-communicator/Makefile"